aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/yaf/Makefile
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-03-06 22:40:46 +0800
committerpi <pi@FreeBSD.org>2016-03-06 22:40:46 +0800
commit9ecb85782be0b930b281ca54caaeca8166c772fd (patch)
tree45d3e889ae20913ae18db8b12e47f2d9b5808f9c /net-mgmt/yaf/Makefile
parent1a3f756c6304b041eabe1cfbe5717a7af2c96b2d (diff)
downloadfreebsd-ports-gnome-9ecb85782be0b930b281ca54caaeca8166c772fd.tar.gz
freebsd-ports-gnome-9ecb85782be0b930b281ca54caaeca8166c772fd.tar.zst
freebsd-ports-gnome-9ecb85782be0b930b281ca54caaeca8166c772fd.zip
net-mgmt/yaf: 2.8.0 -> 2.8.1, with many new OPTIONs
- Fix compile error when configured with --disable-payload - Force buffer emit with IPFIX Options record when inactive Please report if you find OPTION combinations that cause problems. PR: 202611 Submitted by: Chris Inacio <nacho319+freebsdZilla@gmail.com> Approved by: dikshie@sfc.wide.ad.jp
Diffstat (limited to 'net-mgmt/yaf/Makefile')
-rw-r--r--net-mgmt/yaf/Makefile47
1 files changed, 45 insertions, 2 deletions
diff --git a/net-mgmt/yaf/Makefile b/net-mgmt/yaf/Makefile
index daf2218df496..7c0d52b21bf9 100644
--- a/net-mgmt/yaf/Makefile
+++ b/net-mgmt/yaf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yaf
-PORTVERSION= 2.8.0
+PORTVERSION= 2.8.1
CATEGORIES= net-mgmt
MASTER_SITES= http://tools.netsa.cert.org/releases/
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfixbuf.so:${PORTSDIR}/net/libfixbuf \
libltdl.so:${PORTSDIR}/devel/libltdl \
+ libpcap.so:${PORTSDIR}/net/libpcap \
libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
@@ -21,10 +22,51 @@ INSTALL_TARGET= install-strip
USES= libtool pathfix perl5 pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-doxygen-doc --enable-applabel --enable-plugins
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+OPTIONS_DEFINE= PAYLOAD APPLABEL PLUGIN FPEXPORT ENTROPY MPLS NONIP P0FPRINT IFEXP CMPTIP4 LOCALTIME DNSAUTH DNSNX
+OPTIONS_DEFAULT= PAYLOAD APPLABEL PLUGIN ENTROPY
+
+PAYLOAD_DESC= YAF will enable reading past IP headers to do deep packet inspection
+APPLABEL_DESC= Create protocol application labels via traffic header inspection.
+PLUGIN_DESC= Enable YAF plugins, primary for application labeling.
+FPEXPORT_DESC= Export of OS fingerprinting information, e.g. p0f.
+ENTROPY_DESC= Generate Shannon entropy values of the data stream.
+MPLS_DESC= MPLS capture and export
+NONIP_DESC= Capture non-IP packets
+P0FPRINT_DESC= Generate p0f O/S fingerprinting.
+IFEXP_DESC= Export capture interface for DAG/Napatech/Netronome cards.
+CMPTIP4_DESC= Create compact IPv4 output (no IPv6 support).
+LOCALTIME_DESC= Allow localtime to be used for command inputs and record printing. Flow records are always in UTC.
+DNSAUTH_DESC= Modify DNS export to only export Authoritative DNS responses.
+DNSNX_DESC= Modify DNS export to only export NXDomain responses.
+
+PAYLOAD_CONFIGURE_ENABLE= payload
+APPLABEL_CONFIGURE_ENABLE= applabel
+PLUGIN_CONFIGURE_ENABLE= plugins
+FPEXPORT_CONFIGURE_ENABLE= fpexporter
+ENTROPY_CONFIGURE_ENABLE= entropy
+MPLS_CONFIGURE_ENABLE= mpls
+NONIP_CONFIGURE_ENABLE= nonip
+P0FPRINT_CONFIGURE_ENABLE= p0fprinter
+IFEXP_CONFIGURE_ENABLE= interface
+CMPTIP4_CONFIGURE_ENABLE= compact-ip4
+LOCALTIME_CONFIGURE_ENABLE= localtime
+DNSAUTH_CONFIGURE_ENABLE= exportDNSAuth
+DNSNX_CONFIGURE_ENABLE= exportDNSNXDomain
+
+APPLABEL_IMPLIES= PAYLOAD
+DNSAUTH_IMPLIES= PLUGIN APPLABEL
+DNSNX_IMPLIES= PLUGIN APPLABEL
+ENTROPY_IMPLIES= PAYLOAD
+P0FPRINT_IMPLIES= APPLABEL
+NONIP_IMPLIES= MPLS
+
+P0FPRINT_LIB_DEPENDS= libp0f.so:${PORTSDIR}/net/libp0f
+
+.include <bsd.port.options.mk>
+
.if defined(WITH_DAG)
CONFIGURE_ARGS+= --with-dag=${LOCALBASE}
.endif
@@ -33,5 +75,6 @@ post-install:
.for f in dhcp_fingerprints.conf yafApplabelRules.conf yafDPIRules.conf
${MV} ${STAGEDIR}${PREFIX}/etc/$f ${STAGEDIR}${PREFIX}/etc/$f.sample
.endfor
+ ${RM} ${STAGEDIR}${PREFIX}/etc/p0f.fp
.include <bsd.port.mk>