aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix-frontend
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-14 06:30:18 +0800
committerpav <pav@FreeBSD.org>2009-12-14 06:30:18 +0800
commit104b1808f07091c7cc71e41926c2ad03143f1d02 (patch)
tree76604f3c0ff989980b752b98913bd1b546a0e602 /net-mgmt/zabbix-frontend
parent584a1736c953a5b36bd41d67681967b176905e4a (diff)
downloadfreebsd-ports-gnome-104b1808f07091c7cc71e41926c2ad03143f1d02.tar.gz
freebsd-ports-gnome-104b1808f07091c7cc71e41926c2ad03143f1d02.tar.zst
freebsd-ports-gnome-104b1808f07091c7cc71e41926c2ad03143f1d02.zip
- Update zabbix to 1.8
- Split the port to server, frontend, agent and proxy slaves - Add zabbix16 for people who don't want to update to 1.8 yet PR: ports/141364 Submitted by: Jim Riggs <ports@christianserving.org> (maintainer)
Diffstat (limited to 'net-mgmt/zabbix-frontend')
-rw-r--r--net-mgmt/zabbix-frontend/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-mgmt/zabbix-frontend/Makefile b/net-mgmt/zabbix-frontend/Makefile
new file mode 100644
index 000000000000..a57bfff739e2
--- /dev/null
+++ b/net-mgmt/zabbix-frontend/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: zabbix-frontend
+# Date created: 2009-12-09
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zabbix
+PKGNAMESUFFIX= -frontend
+
+MASTERDIR= ${.CURDIR}/../zabbix-server
+
+NO_BUILD= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath gd pcre snmp sockets
+IGNORE_WITH_PHP= 4
+WANT_PHP_WEB= yes
+
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend" off
+
+.include <bsd.port.options.mk>
+
+.ifndef WITHOUT_MYSQL
+USE_PHP+= mysql
+.endif
+
+.ifdef WITH_MYSQLI
+USE_PHP+= mysqli
+.endif
+
+.ifdef WITH_PGSQL
+USE_PHP+= pgsql
+.endif
+
+.ifdef WITH_SQLITE
+USE_PHP+= sqlite
+.endif
+
+do-install:
+ @${INSTALL} -d ${WWWDIR}
+ @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${WWWDIR}
+
+.include "${MASTERDIR}/Makefile"