aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix-server
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-12-14 06:30:18 +0800
committerpav <pav@FreeBSD.org>2009-12-14 06:30:18 +0800
commit104b1808f07091c7cc71e41926c2ad03143f1d02 (patch)
tree76604f3c0ff989980b752b98913bd1b546a0e602 /net-mgmt/zabbix-server
parent584a1736c953a5b36bd41d67681967b176905e4a (diff)
downloadfreebsd-ports-gnome-104b1808f07091c7cc71e41926c2ad03143f1d02.tar.gz
freebsd-ports-gnome-104b1808f07091c7cc71e41926c2ad03143f1d02.tar.zst
freebsd-ports-gnome-104b1808f07091c7cc71e41926c2ad03143f1d02.zip
- Update zabbix to 1.8
- Split the port to server, frontend, agent and proxy slaves - Add zabbix16 for people who don't want to update to 1.8 yet PR: ports/141364 Submitted by: Jim Riggs <ports@christianserving.org> (maintainer)
Diffstat (limited to 'net-mgmt/zabbix-server')
-rw-r--r--net-mgmt/zabbix-server/Makefile122
-rw-r--r--net-mgmt/zabbix-server/distinfo3
-rw-r--r--net-mgmt/zabbix-server/files/pkg-message.in11
-rw-r--r--net-mgmt/zabbix-server/files/zabbix_agentd.in26
-rw-r--r--net-mgmt/zabbix-server/files/zabbix_proxy.in26
-rw-r--r--net-mgmt/zabbix-server/files/zabbix_server.in26
-rw-r--r--net-mgmt/zabbix-server/pkg-descr12
-rw-r--r--net-mgmt/zabbix-server/pkg-plist56
-rw-r--r--net-mgmt/zabbix-server/pkg-plist.agent8
-rw-r--r--net-mgmt/zabbix-server/pkg-plist.frontend442
10 files changed, 732 insertions, 0 deletions
diff --git a/net-mgmt/zabbix-server/Makefile b/net-mgmt/zabbix-server/Makefile
new file mode 100644
index 000000000000..220c7e2ff5a7
--- /dev/null
+++ b/net-mgmt/zabbix-server/Makefile
@@ -0,0 +1,122 @@
+# New ports collection makefile for: zabbix-server
+# Date created: 2009-12-09
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zabbix
+PORTVERSION= 1.8
+PORTEPOCH= 2
+CATEGORIES= net-mgmt
+MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
+PKGNAMESUFFIX?= -server
+
+MAINTAINER= ports@christianserving.org
+COMMENT= Enterprise-class open source distributed monitoring (${PKGNAMESUFFIX:S/^-//})
+
+CONFLICTS= ${PKGBASE}-1.[0-6]*
+
+.if ${PKGNAMESUFFIX} != "-agent"
+CONFLICTS+= ${PORTNAME}-1.[0-6]*
+.endif
+
+ZABBIX_BUILD= ${PKGNAMESUFFIX:S/^-//}
+
+.if ${ZABBIX_BUILD} != "frontend" # frontend only needs the version/distribution settings
+LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
+ curl:${PORTSDIR}/ftp/curl
+
+SUB_FILES= pkg-message
+
+.if ${ZABBIX_BUILD} != "agent"
+MAN8= ${PORTNAME}_${ZABBIX_BUILD}.8
+USE_RC_SUBR= ${PORTNAME}_${ZABBIX_BUILD}
+.else
+USE_ICONV= yes
+MAN1= ${PORTNAME}_get.1 ${PORTNAME}_sender.1
+MAN8= ${PORTNAME}_${ZABBIX_BUILD}d.8
+USE_RC_SUBR= ${PORTNAME}_${ZABBIX_BUILD}d
+.endif
+
+USERS= zabbix
+GROUPS= zabbix
+
+PLIST_SUB= ZABBIX_BUILD=${ZABBIX_BUILD}
+SUB_LIST= ZABBIX_BUILD=${ZABBIX_BUILD}
+
+MAKE_ARGS+= ARCH=freebsd
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} --with-net-snmp
+
+.if ${ZABBIX_BUILD} != "agent"
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend" off \
+ IPV6 "Support for IPv6" on \
+ LDAP "Support for checking LDAP servers" on \
+ JABBER "Use jabber media type" on \
+ FPING "Use fping for pinging hosts" on
+
+.include <bsd.port.options.mk>
+
+.ifndef WITHOUT_MYSQL
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --with-mysql
+.elifdef WITH_PGSQL
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --with-pgsql
+.elifdef WITH_SQLITE
+USE_SQLITE= yes
+CONFIGURE_ARGS+= --with-sqlite3
+.else
+IGNORE= zabbix requires a database backend
+.endif
+
+.ifndef WITHOUT_LDAP
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+= --with-ldap
+.endif
+
+.ifndef WITHOUT_JABBER
+LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
+CONFIGURE_ARGS+= --with-jabber
+.endif
+
+.ifndef WITHOUT_FPING
+RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
+.endif
+.endif # if ${ZABBIX_BUILD} != "agent"
+
+.ifdef WITH_IPV6
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+post-patch:
+ @${GREP} -rl "/etc/zabbix" ${WRKSRC} \
+ | ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g' \
+ && ${FIND} ${WRKSRC} -type f -name '*.bak' -exec ${RM} -f {} +
+
+.if ${ZABBIX_BUILD} != "agent"
+.ifdef WITHOUT_FPING
+ @${ECHO} 'DisablePinger=yes' >> ${WRKSRC}/misc/conf/${PORTNAME}_${ZABBIX_BUILD}.conf
+.endif
+.endif
+
+post-install:
+ @${INSTALL} -d ${ETCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/misc/conf/${PORTNAME}_${ZABBIX_BUILD}.conf ${ETCDIR}/${PORTNAME}_${ZABBIX_BUILD}.conf.sample
+
+.if ${ZABBIX_BUILD} == "agent"
+ @${INSTALL_DATA} ${WRKSRC}/misc/conf/${PORTNAME}_${ZABBIX_BUILD}d.conf ${ETCDIR}/${PORTNAME}_${ZABBIX_BUILD}d.conf.sample
+.endif
+
+.if ${ZABBIX_BUILD} != "agent"
+ @cd ${WRKSRC}/upgrades/ && ${COPYTREE_SHARE} dbpatches ${DATADIR}/${ZABBIX_BUILD}/upgrades/
+ @cd ${WRKSRC}/create/ && ${COPYTREE_SHARE} "data schema" ${DATADIR}/${ZABBIX_BUILD}/create/
+ @${CAT} ${PKGMESSAGE}
+.endif
+.endif # if ${ZABBIX_BUILD} != "frontend"
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/zabbix-server/distinfo b/net-mgmt/zabbix-server/distinfo
new file mode 100644
index 000000000000..3ee658f07890
--- /dev/null
+++ b/net-mgmt/zabbix-server/distinfo
@@ -0,0 +1,3 @@
+MD5 (zabbix-1.8.tar.gz) = 066153713c05f873b4344e4ea1e065e9
+SHA256 (zabbix-1.8.tar.gz) = 6743f01f27116ead7b48927ac184708bb920541c88e63602fe1f2b7401866eec
+SIZE (zabbix-1.8.tar.gz) = 3549582
diff --git a/net-mgmt/zabbix-server/files/pkg-message.in b/net-mgmt/zabbix-server/files/pkg-message.in
new file mode 100644
index 000000000000..754f2c90ce66
--- /dev/null
+++ b/net-mgmt/zabbix-server/files/pkg-message.in
@@ -0,0 +1,11 @@
+======================================================================
+Zabbix requires a database. If you are using SQLite, one will be
+created automatically. Otherwise you can install one as follows (<db>
+is your database engine and <db_client> is its client program):
+
+% cd %%DATADIR%%/%%ZABBIX_BUILD%%/create
+% cat schema/<db>.sql data/data.sql data/images_<db>.sql | <db_client>
+
+To upgrade an existing database, see the scripts in
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades.
+======================================================================
diff --git a/net-mgmt/zabbix-server/files/zabbix_agentd.in b/net-mgmt/zabbix-server/files/zabbix_agentd.in
new file mode 100644
index 000000000000..b4f13bdfd4cb
--- /dev/null
+++ b/net-mgmt/zabbix-server/files/zabbix_agentd.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# PROVIDE: zabbix_agentd
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to
+# enable zabbix_agentd:
+#
+# zabbix_agentd_enable (bool): Set to NO by default. Set it to YES to
+# enable zabbix_agentd.
+#
+
+. %%RC_SUBR%%
+
+name="zabbix_agentd"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+required_files="%%ETCDIR%%/${name}.conf"
+
+load_rc_config $name
+
+: ${zabbix_agentd_enable="NO"}
+
+run_rc_command "$1"
diff --git a/net-mgmt/zabbix-server/files/zabbix_proxy.in b/net-mgmt/zabbix-server/files/zabbix_proxy.in
new file mode 100644
index 000000000000..14ab46b8a2a1
--- /dev/null
+++ b/net-mgmt/zabbix-server/files/zabbix_proxy.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# PROVIDE: zabbix_proxy
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to
+# enable zabbix_proxy:
+#
+# zabbix_proxy_enable (bool): Set to NO by default. Set it to YES to
+# enable zabbix_proxy.
+#
+
+. %%RC_SUBR%%
+
+name="zabbix_proxy"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+required_files="%%ETCDIR%%/${name}.conf"
+
+load_rc_config $name
+
+: ${zabbix_proxy_enable="NO"}
+
+run_rc_command "$1"
diff --git a/net-mgmt/zabbix-server/files/zabbix_server.in b/net-mgmt/zabbix-server/files/zabbix_server.in
new file mode 100644
index 000000000000..b8c5bc324f44
--- /dev/null
+++ b/net-mgmt/zabbix-server/files/zabbix_server.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# PROVIDE: zabbix_server
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to
+# enable zabbix_server:
+#
+# zabbix_server_enable (bool): Set to NO by default. Set it to YES to
+# enable zabbix_server.
+#
+
+. %%RC_SUBR%%
+
+name="zabbix_server"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/sbin/${name}"
+required_files="%%ETCDIR%%/${name}.conf"
+
+load_rc_config $name
+
+: ${zabbix_server_enable="NO"}
+
+run_rc_command "$1"
diff --git a/net-mgmt/zabbix-server/pkg-descr b/net-mgmt/zabbix-server/pkg-descr
new file mode 100644
index 000000000000..4165c097388f
--- /dev/null
+++ b/net-mgmt/zabbix-server/pkg-descr
@@ -0,0 +1,12 @@
+Zabbix is an enterprise-class open source distributed monitoring
+solution.
+
+Zabbix is software that monitors numerous parameters of a network and
+the health and integrity of servers. Zabbix uses a flexible
+notification mechanism that allows users to configure e-mail based
+alerts for virtually any event. This allows a fast reaction to server
+problems. Zabbix offers excellent reporting and data visualisation
+features based on the stored data. This makes Zabbix ideal for
+capacity planning.
+
+WWW: http://www.zabbix.com/
diff --git a/net-mgmt/zabbix-server/pkg-plist b/net-mgmt/zabbix-server/pkg-plist
new file mode 100644
index 000000000000..3f1ab4463203
--- /dev/null
+++ b/net-mgmt/zabbix-server/pkg-plist
@@ -0,0 +1,56 @@
+@comment $FreeBSD$
+%%ETCDIR%%/zabbix_%%ZABBIX_BUILD%%.conf.sample
+sbin/zabbix_%%ZABBIX_BUILD%%
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/data.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Hub.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Hub_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Network.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Network_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Notebook.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Notebook_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Phone.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Phone_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Printer.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Printer_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Router.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Router_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Satellite.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Satellite_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Server.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Server_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/UPS.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/UPS_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Workstation.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images/Workstation_small.png
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images_mysql.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images_oracle.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images_pgsql.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images_sqlite3.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/schema/mysql.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/schema/oracle.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/schema/postgresql.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/create/schema/sqlite.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6/mysql/patch.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6/oracle/patch.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6/postgresql/patch.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/oracle/patch.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/postgresql/patch.sql
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/mysql/upgrade
+%%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/mysql/patch.sql
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/postgresql
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/oracle
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8/mysql
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.8
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6/postgresql
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6/oracle
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6/mysql
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches/1.6
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades/dbpatches
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/upgrades
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/create/schema
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/create/data/images
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/create/data
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%/create
+@dirrm %%DATADIR%%/%%ZABBIX_BUILD%%
+@dirrmtry %%DATADIR%%
+@dirrmtry %%ETCDIR%%
diff --git a/net-mgmt/zabbix-server/pkg-plist.agent b/net-mgmt/zabbix-server/pkg-plist.agent
new file mode 100644
index 000000000000..098c6d80e769
--- /dev/null
+++ b/net-mgmt/zabbix-server/pkg-plist.agent
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%ETCDIR%%/zabbix_agent.conf.sample
+%%ETCDIR%%/zabbix_agentd.conf.sample
+bin/zabbix_get
+bin/zabbix_sender
+sbin/zabbix_agent
+sbin/zabbix_agentd
+@dirrmtry %%ETCDIR%%
diff --git a/net-mgmt/zabbix-server/pkg-plist.frontend b/net-mgmt/zabbix-server/pkg-plist.frontend
new file mode 100644
index 000000000000..1bc178631f52
--- /dev/null
+++ b/net-mgmt/zabbix-server/pkg-plist.frontend
@@ -0,0 +1,442 @@
+@comment $FreeBSD$
+%%WWWDIR%%/acknow.php
+%%WWWDIR%%/actionconf.php
+%%WWWDIR%%/api/.htaccess
+%%WWWDIR%%/api/classes/class.caction.php
+%%WWWDIR%%/api/classes/class.calert.php
+%%WWWDIR%%/api/classes/class.capiinfo.php
+%%WWWDIR%%/api/classes/class.capplication.php
+%%WWWDIR%%/api/classes/class.cevent.php
+%%WWWDIR%%/api/classes/class.cgraph.php
+%%WWWDIR%%/api/classes/class.cgraphitem.php
+%%WWWDIR%%/api/classes/class.chost.php
+%%WWWDIR%%/api/classes/class.chostgroup.php
+%%WWWDIR%%/api/classes/class.citem.php
+%%WWWDIR%%/api/classes/class.cmaintenance.php
+%%WWWDIR%%/api/classes/class.cmap.php
+%%WWWDIR%%/api/classes/class.cscreen.php
+%%WWWDIR%%/api/classes/class.cscript.php
+%%WWWDIR%%/api/classes/class.ctemplate.php
+%%WWWDIR%%/api/classes/class.ctrigger.php
+%%WWWDIR%%/api/classes/class.cuser.php
+%%WWWDIR%%/api/classes/class.cusergroup.php
+%%WWWDIR%%/api/classes/class.cusermacro.php
+%%WWWDIR%%/api/classes/class.czbxapi.php
+%%WWWDIR%%/api/rpc/class.cjsonrpc.php
+%%WWWDIR%%/api/rpc/class.czbxrpc.php
+%%WWWDIR%%/api_jsonrpc.php
+%%WWWDIR%%/applications.php
+%%WWWDIR%%/audio/trigger_off.wav
+%%WWWDIR%%/audio/trigger_on.wav
+%%WWWDIR%%/audio/trigger_on_average.wav
+%%WWWDIR%%/audio/trigger_on_disaster.wav
+%%WWWDIR%%/audio/trigger_on_high.wav
+%%WWWDIR%%/audio/trigger_on_warning.wav
+%%WWWDIR%%/auditacts.php
+%%WWWDIR%%/auditlogs.php
+%%WWWDIR%%/authentication.php
+%%WWWDIR%%/chart.php
+%%WWWDIR%%/chart2.php
+%%WWWDIR%%/chart3.php
+%%WWWDIR%%/chart4.php
+%%WWWDIR%%/chart5.php
+%%WWWDIR%%/chart6.php
+%%WWWDIR%%/chart7.php
+%%WWWDIR%%/chart_bar.php
+%%WWWDIR%%/chart_sla.php
+%%WWWDIR%%/charts.php
+%%WWWDIR%%/conf/.htaccess
+%%WWWDIR%%/conf/COPYING
+%%WWWDIR%%/conf/maintenance.inc.php
+%%WWWDIR%%/conf/zabbix.conf.php.example
+%%WWWDIR%%/config.php
+%%WWWDIR%%/css.css
+%%WWWDIR%%/dashboard.php
+%%WWWDIR%%/discovery.php
+%%WWWDIR%%/discoveryconf.php
+%%WWWDIR%%/events.php
+%%WWWDIR%%/export.php
+%%WWWDIR%%/fonts/DejaVuSans.ttf
+%%WWWDIR%%/graphs.php
+%%WWWDIR%%/history.php
+%%WWWDIR%%/hostgroups.php
+%%WWWDIR%%/hostprofiles.php
+%%WWWDIR%%/hosts.php
+%%WWWDIR%%/httpconf.php
+%%WWWDIR%%/httpdetails.php
+%%WWWDIR%%/httpmon.php
+%%WWWDIR%%/image.php
+%%WWWDIR%%/images/flash/zbxclock.swf
+%%WWWDIR%%/images/general/arrowdown.gif
+%%WWWDIR%%/images/general/arrowup.gif
+%%WWWDIR%%/images/general/bar/arrow_down.gif
+%%WWWDIR%%/images/general/bar/arrow_sm.gif
+%%WWWDIR%%/images/general/bar/arrow_up.gif
+%%WWWDIR%%/images/general/bar/bar_bg.png
+%%WWWDIR%%/images/general/bar/bar_middle.png
+%%WWWDIR%%/images/general/bar/bg.png
+%%WWWDIR%%/images/general/bar/cal.gif
+%%WWWDIR%%/images/general/bar/left.png
+%%WWWDIR%%/images/general/bar/left_arr.png
+%%WWWDIR%%/images/general/bar/right.png
+%%WWWDIR%%/images/general/bar/right_arr.png
+%%WWWDIR%%/images/general/bttn/arrowdown.png
+%%WWWDIR%%/images/general/bttn/arrowdown_bb.png
+%%WWWDIR%%/images/general/bttn/arrowleft.png
+%%WWWDIR%%/images/general/bttn/arrowleft_bb.png
+%%WWWDIR%%/images/general/bttn/arrowright.png
+%%WWWDIR%%/images/general/bttn/arrowright_bb.png
+%%WWWDIR%%/images/general/bttn/arrowup.png
+%%WWWDIR%%/images/general/bttn/arrowup_bb.png
+%%WWWDIR%%/images/general/bttn/down.png
+%%WWWDIR%%/images/general/bttn/down_bb.png
+%%WWWDIR%%/images/general/bttn/fullscreen.png
+%%WWWDIR%%/images/general/bttn/fullscreen_bb.png
+%%WWWDIR%%/images/general/bttn/help.png
+%%WWWDIR%%/images/general/bttn/help_bb.png
+%%WWWDIR%%/images/general/bttn/menu.png
+%%WWWDIR%%/images/general/bttn/menu_bb.png
+%%WWWDIR%%/images/general/bttn/minus.png
+%%WWWDIR%%/images/general/bttn/minus_bb.png
+%%WWWDIR%%/images/general/bttn/mute.png
+%%WWWDIR%%/images/general/bttn/mute_bb.png
+%%WWWDIR%%/images/general/bttn/plus.png
+%%WWWDIR%%/images/general/bttn/plus_bb.png
+%%WWWDIR%%/images/general/bttn/reset.png
+%%WWWDIR%%/images/general/bttn/reset_bb.png
+%%WWWDIR%%/images/general/bttn/sound.png
+%%WWWDIR%%/images/general/bttn/sound_bb.png
+%%WWWDIR%%/images/general/bttn/up.png
+%%WWWDIR%%/images/general/bttn/up_bb.png
+%%WWWDIR%%/images/general/chart.png
+%%WWWDIR%%/images/general/closed.gif
+%%WWWDIR%%/images/general/dbl_arrow_down.png
+%%WWWDIR%%/images/general/dbl_arrow_down2.png
+%%WWWDIR%%/images/general/dbl_arrow_up.png
+%%WWWDIR%%/images/general/dbl_arrow_up2.png
+%%WWWDIR%%/images/general/down_icon.png
+%%WWWDIR%%/images/general/error.png
+%%WWWDIR%%/images/general/error_icon.png
+%%WWWDIR%%/images/general/error_small.gif
+%%WWWDIR%%/images/general/help.gif
+%%WWWDIR%%/images/general/inst_completed.gif
+%%WWWDIR%%/images/general/inst_current.gif
+%%WWWDIR%%/images/general/inst_step.gif
+%%WWWDIR%%/images/general/ipmi_available.png
+%%WWWDIR%%/images/general/ipmi_available_bb.png
+%%WWWDIR%%/images/general/ipmi_unavailable.png
+%%WWWDIR%%/images/general/ipmi_unknown.png
+%%WWWDIR%%/images/general/ok.png
+%%WWWDIR%%/images/general/ok_bb.png
+%%WWWDIR%%/images/general/ok_icon.png
+%%WWWDIR%%/images/general/ok_icon_bb.png
+%%WWWDIR%%/images/general/opened.gif
+%%WWWDIR%%/images/general/snmp_available.png
+%%WWWDIR%%/images/general/snmp_available_bb.png
+%%WWWDIR%%/images/general/snmp_unavailable.png
+%%WWWDIR%%/images/general/snmp_unknown.png
+%%WWWDIR%%/images/general/sort_down.png
+%%WWWDIR%%/images/general/sort_down_bb.png
+%%WWWDIR%%/images/general/sort_downw.gif
+%%WWWDIR%%/images/general/sort_up.png
+%%WWWDIR%%/images/general/sort_up_bb.png
+%%WWWDIR%%/images/general/sort_upw.gif
+%%WWWDIR%%/images/general/sortdown.gif
+%%WWWDIR%%/images/general/sortdown_off.gif
+%%WWWDIR%%/images/general/sortup.gif
+%%WWWDIR%%/images/general/sortup_off.gif
+%%WWWDIR%%/images/general/tick.png
+%%WWWDIR%%/images/general/tr_space.gif
+%%WWWDIR%%/images/general/tr_top_bottom.gif
+%%WWWDIR%%/images/general/tr_top_right.gif
+%%WWWDIR%%/images/general/tr_top_right_bottom.gif
+%%WWWDIR%%/images/general/tree/minus.gif
+%%WWWDIR%%/images/general/tree/plus.gif
+%%WWWDIR%%/images/general/tree/point.gif
+%%WWWDIR%%/images/general/tree/pointc.gif
+%%WWWDIR%%/images/general/tree/pointl.gif
+%%WWWDIR%%/images/general/tree/zero.gif
+%%WWWDIR%%/images/general/up_icon.png
+%%WWWDIR%%/images/general/warning16r.gif
+%%WWWDIR%%/images/general/warning_small.gif
+%%WWWDIR%%/images/general/zabbix.ico
+%%WWWDIR%%/images/general/zabbix.png
+%%WWWDIR%%/images/general/zabbix_available.png
+%%WWWDIR%%/images/general/zabbix_available_bb.png
+%%WWWDIR%%/images/general/zabbix_bb.ico
+%%WWWDIR%%/images/general/zabbix_bb.png
+%%WWWDIR%%/images/general/zabbix_ob.ico
+%%WWWDIR%%/images/general/zabbix_unavailable.png
+%%WWWDIR%%/images/general/zabbix_unknown.png
+%%WWWDIR%%/images/general/zero.gif
+%%WWWDIR%%/images/gradients/blink1.gif
+%%WWWDIR%%/images/gradients/blink2.gif
+%%WWWDIR%%/images/gradients/button.gif
+%%WWWDIR%%/images/gradients/gradient.png
+%%WWWDIR%%/images/gradients/menu_not_active.gif
+%%WWWDIR%%/images/gradients/menu_not_active2.gif
+%%WWWDIR%%/images/gradients/menu_not_active_bb.gif
+%%WWWDIR%%/images/gradients/sla_blue.png
+%%WWWDIR%%/images/gradients/sla_blue15.png
+%%WWWDIR%%/images/gradients/sla_green.png
+%%WWWDIR%%/images/gradients/sla_green15.png
+%%WWWDIR%%/images/gradients/sla_red.png
+%%WWWDIR%%/images/gradients/sla_red15.png
+%%WWWDIR%%/images/gradients/table_head.gif
+%%WWWDIR%%/images/gradients/table_head2.gif
+%%WWWDIR%%/images/gradients/table_head2_bb.gif
+%%WWWDIR%%/images/gradients/table_head_bb.gif
+%%WWWDIR%%/images/sysmaps/Hub.png
+%%WWWDIR%%/images/sysmaps/Hub_small.png
+%%WWWDIR%%/images/sysmaps/Network.png
+%%WWWDIR%%/images/sysmaps/Network_small.png
+%%WWWDIR%%/images/sysmaps/Notebook.png
+%%WWWDIR%%/images/sysmaps/Notebook_small.png
+%%WWWDIR%%/images/sysmaps/Phone.png
+%%WWWDIR%%/images/sysmaps/Phone_small.png
+%%WWWDIR%%/images/sysmaps/Printer.png
+%%WWWDIR%%/images/sysmaps/Printer_small.png
+%%WWWDIR%%/images/sysmaps/README
+%%WWWDIR%%/images/sysmaps/Router.png
+%%WWWDIR%%/images/sysmaps/Router_small.png
+%%WWWDIR%%/images/sysmaps/Satellite.png
+%%WWWDIR%%/images/sysmaps/Satellite_small.png
+%%WWWDIR%%/images/sysmaps/Server.png
+%%WWWDIR%%/images/sysmaps/Server_small.png
+%%WWWDIR%%/images/sysmaps/UPS.png
+%%WWWDIR%%/images/sysmaps/UPS_small.png
+%%WWWDIR%%/images/sysmaps/Workstation.png
+%%WWWDIR%%/images/sysmaps/Workstation_small.png
+%%WWWDIR%%/images/sysmaps/old/Hub.png
+%%WWWDIR%%/images/sysmaps/old/Notebook.png
+%%WWWDIR%%/images/sysmaps/old/Printer.png
+%%WWWDIR%%/images/sysmaps/old/Router.png
+%%WWWDIR%%/images/sysmaps/old/Server.png
+%%WWWDIR%%/images/sysmaps/old/Workstation.png
+%%WWWDIR%%/imgstore.php
+%%WWWDIR%%/import.php
+%%WWWDIR%%/include/.htaccess
+%%WWWDIR%%/include/acknow.inc.php
+%%WWWDIR%%/include/actions.inc.php
+%%WWWDIR%%/include/audit.inc.php
+%%WWWDIR%%/include/blocks.inc.php
+%%WWWDIR%%/include/classes/.htaccess
+%%WWWDIR%%/include/classes/class.carea.php
+%%WWWDIR%%/include/classes/class.careamap.php
+%%WWWDIR%%/include/classes/class.cbar.php
+%%WWWDIR%%/include/classes/class.cbutton.php
+%%WWWDIR%%/include/classes/class.cbuttoncancel.php
+%%WWWDIR%%/include/classes/class.cbuttondelete.php
+%%WWWDIR%%/include/classes/class.cbuttonqmessage.php
+%%WWWDIR%%/include/classes/class.cchart.php
+%%WWWDIR%%/include/classes/class.ccheckbox.php
+%%WWWDIR%%/include/classes/class.ccol.php
+%%WWWDIR%%/include/classes/class.ccolor.php
+%%WWWDIR%%/include/classes/class.ccolorcell.php
+%%WWWDIR%%/include/classes/class.ccombobox.php
+%%WWWDIR%%/include/classes/class.ccomboitem.php
+%%WWWDIR%%/include/classes/class.cdiv.php
+%%WWWDIR%%/include/classes/class.ceditablecombobox.php
+%%WWWDIR%%/include/classes/class.cfile.php
+%%WWWDIR%%/include/classes/class.cflash.php
+%%WWWDIR%%/include/classes/class.cflashclock.php
+%%WWWDIR%%/include/classes/class.cflashembed.php
+%%WWWDIR%%/include/classes/class.cform.php
+%%WWWDIR%%/include/classes/class.cformtable.php
+%%WWWDIR%%/include/classes/class.cgraphdraw.php
+%%WWWDIR%%/include/classes/class.chelp.php
+%%WWWDIR%%/include/classes/class.chostsinfo.php
+%%WWWDIR%%/include/classes/class.chttp_request.php
+%%WWWDIR%%/include/classes/class.ciframe.php
+%%WWWDIR%%/include/classes/class.cimagetexttable.php
+%%WWWDIR%%/include/classes/class.cimg.php
+%%WWWDIR%%/include/classes/class.cipbox.php
+%%WWWDIR%%/include/classes/class.cjson.php
+%%WWWDIR%%/include/classes/class.cjsscript.php
+%%WWWDIR%%/include/classes/class.cldap.php
+%%WWWDIR%%/include/classes/class.clink.php
+%%WWWDIR%%/include/classes/class.clist.php
+%%WWWDIR%%/include/classes/class.clistbox.php
+%%WWWDIR%%/include/classes/class.clistitem.php
+%%WWWDIR%%/include/classes/class.cnumericbox.php
+%%WWWDIR%%/include/classes/class.cobject.php
+%%WWWDIR%%/include/classes/class.cparam.php
+%%WWWDIR%%/include/classes/class.cpassbox.php
+%%WWWDIR%%/include/classes/class.cpie.php
+%%WWWDIR%%/include/classes/class.cpumenu.php
+%%WWWDIR%%/include/classes/class.crow.php
+%%WWWDIR%%/include/classes/class.cserverinfo.php
+%%WWWDIR%%/include/classes/class.cspan.php
+%%WWWDIR%%/include/classes/class.ctable.php
+%%WWWDIR%%/include/classes/class.ctableinfo.php
+%%WWWDIR%%/include/classes/class.ctag.php
+%%WWWDIR%%/include/classes/class.ctextarea.php
+%%WWWDIR%%/include/classes/class.ctextbox.php
+%%WWWDIR%%/include/classes/class.ctree.php
+%%WWWDIR%%/include/classes/class.ctriggersinfo.php
+%%WWWDIR%%/include/classes/class.ctweenbox.php
+%%WWWDIR%%/include/classes/class.curl.php
+%%WWWDIR%%/include/classes/class.cvar.php
+%%WWWDIR%%/include/classes/class.cvartag.php
+%%WWWDIR%%/include/classes/class.cvisibilitybox.php
+%%WWWDIR%%/include/classes/class.cwidget.php
+%%WWWDIR%%/include/config.inc.php
+%%WWWDIR%%/include/copt.lib.php
+%%WWWDIR%%/include/db.inc.php
+%%WWWDIR%%/include/defines.inc.php
+%%WWWDIR%%/include/discovery.inc.php
+%%WWWDIR%%/include/events.inc.php
+%%WWWDIR%%/include/export.inc.php
+%%WWWDIR%%/include/forms.inc.php
+%%WWWDIR%%/include/func.inc.php
+%%WWWDIR%%/include/graphs.inc.php
+%%WWWDIR%%/include/hosts.inc.php
+%%WWWDIR%%/include/html.inc.php
+%%WWWDIR%%/include/httptest.inc.php
+%%WWWDIR%%/include/images.inc.php
+%%WWWDIR%%/include/items.inc.php
+%%WWWDIR%%/include/js.inc.php
+%%WWWDIR%%/include/locales.inc.php
+%%WWWDIR%%/include/locales/cn_zh.inc.php
+%%WWWDIR%%/include/locales/de_de.inc.php
+%%WWWDIR%%/include/locales/en_gb.inc.php
+%%WWWDIR%%/include/locales/fr_fr.inc.php
+%%WWWDIR%%/include/locales/hu_hu.inc.php
+%%WWWDIR%%/include/locales/it_it.inc.php
+%%WWWDIR%%/include/locales/ja_jp.inc.php
+%%WWWDIR%%/include/locales/ko_kr.inc.php
+%%WWWDIR%%/include/locales/lv_lv.inc.php
+%%WWWDIR%%/include/locales/nl_nl.inc.php
+%%WWWDIR%%/include/locales/pl_pl.inc.php
+%%WWWDIR%%/include/locales/pt_br.inc.php
+%%WWWDIR%%/include/locales/ru_ru.inc.php
+%%WWWDIR%%/include/locales/sp_sp.inc.php
+%%WWWDIR%%/include/locales/sv_se.inc.php
+%%WWWDIR%%/include/maintenances.inc.php
+%%WWWDIR%%/include/maps.inc.php
+%%WWWDIR%%/include/media.inc.php
+%%WWWDIR%%/include/menu.inc.php
+%%WWWDIR%%/include/nodes.inc.php
+%%WWWDIR%%/include/page_footer.php
+%%WWWDIR%%/include/page_header.php
+%%WWWDIR%%/include/perm.inc.php
+%%WWWDIR%%/include/profiles.inc.php
+%%WWWDIR%%/include/regexp.inc.php
+%%WWWDIR%%/include/reports.inc.php
+%%WWWDIR%%/include/screens.inc.php
+%%WWWDIR%%/include/scripts.inc.php
+%%WWWDIR%%/include/services.inc.php
+%%WWWDIR%%/include/setup.inc.php
+%%WWWDIR%%/include/triggers.inc.php
+%%WWWDIR%%/include/users.inc.php
+%%WWWDIR%%/include/validate.inc.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/instal.php
+%%WWWDIR%%/items.php
+%%WWWDIR%%/js/class.calendar.js
+%%WWWDIR%%/js/class.cmap.js
+%%WWWDIR%%/js/class.cookie.js
+%%WWWDIR%%/js/class.cscreen.js
+%%WWWDIR%%/js/class.ctree.js
+%%WWWDIR%%/js/class.curl.js
+%%WWWDIR%%/js/class.pmaster.js
+%%WWWDIR%%/js/class.switcher.js
+%%WWWDIR%%/js/common.js
+%%WWWDIR%%/js/functions.js
+%%WWWDIR%%/js/gtlc.js
+%%WWWDIR%%/js/main.js
+%%WWWDIR%%/js/menu.js
+%%WWWDIR%%/js/prototype.js
+%%WWWDIR%%/js/scriptaculous.js
+%%WWWDIR%%/js/scriptaculous/builder.js
+%%WWWDIR%%/js/scriptaculous/controls.js
+%%WWWDIR%%/js/scriptaculous/dragdrop.js
+%%WWWDIR%%/js/scriptaculous/effects.js
+%%WWWDIR%%/js/scriptaculous/slider.js
+%%WWWDIR%%/js/scriptaculous/sound.js
+%%WWWDIR%%/latest.php
+%%WWWDIR%%/locales.php
+%%WWWDIR%%/maintenance.php
+%%WWWDIR%%/map.php
+%%WWWDIR%%/maps.php
+%%WWWDIR%%/media_types.php
+%%WWWDIR%%/nodes.php
+%%WWWDIR%%/overview.php
+%%WWWDIR%%/popup.php
+%%WWWDIR%%/popup_bitem.php
+%%WWWDIR%%/popup_gitem.php
+%%WWWDIR%%/popup_httpstep.php
+%%WWWDIR%%/popup_link_tr.php
+%%WWWDIR%%/popup_media.php
+%%WWWDIR%%/popup_period.php
+%%WWWDIR%%/popup_right.php
+%%WWWDIR%%/popup_trexpr.php
+%%WWWDIR%%/popup_users.php
+%%WWWDIR%%/popup_usrgrp.php
+%%WWWDIR%%/profile.php
+%%WWWDIR%%/proxies.php
+%%WWWDIR%%/queue.php
+%%WWWDIR%%/report1.php
+%%WWWDIR%%/report2.php
+%%WWWDIR%%/report3.php
+%%WWWDIR%%/report4.php
+%%WWWDIR%%/report5.php
+%%WWWDIR%%/report6.php
+%%WWWDIR%%/screenconf.php
+%%WWWDIR%%/screenedit.php
+%%WWWDIR%%/screens.php
+%%WWWDIR%%/scripts.php
+%%WWWDIR%%/scripts_exec.php
+%%WWWDIR%%/search.php
+%%WWWDIR%%/services.php
+%%WWWDIR%%/services_form.php
+%%WWWDIR%%/setup.php
+%%WWWDIR%%/slides.php
+%%WWWDIR%%/srv_status.php
+%%WWWDIR%%/styles/blocks.css
+%%WWWDIR%%/styles/calendar.css
+%%WWWDIR%%/styles/css_bb.css
+%%WWWDIR%%/styles/css_ob.css
+%%WWWDIR%%/styles/default.css
+%%WWWDIR%%/styles/div.css
+%%WWWDIR%%/styles/form.css
+%%WWWDIR%%/styles/link.css
+%%WWWDIR%%/styles/p.css
+%%WWWDIR%%/styles/popupmenu.css
+%%WWWDIR%%/styles/table.css
+%%WWWDIR%%/styles/ul.css
+%%WWWDIR%%/sysmap.php
+%%WWWDIR%%/sysmaps.php
+%%WWWDIR%%/templates.php
+%%WWWDIR%%/tr_comments.php
+%%WWWDIR%%/tr_events.php
+%%WWWDIR%%/tr_logform.php
+%%WWWDIR%%/tr_status.php
+%%WWWDIR%%/tr_testexpr.php
+%%WWWDIR%%/triggers.php
+%%WWWDIR%%/usergrps.php
+%%WWWDIR%%/users.php
+%%WWWDIR%%/vtext.php
+%%WWWDIR%%/warning.php
+@dirrm %%WWWDIR%%/styles
+@dirrm %%WWWDIR%%/js/scriptaculous
+@dirrm %%WWWDIR%%/js
+@dirrm %%WWWDIR%%/include/locales
+@dirrm %%WWWDIR%%/include/classes
+@dirrm %%WWWDIR%%/include
+@dirrm %%WWWDIR%%/images/sysmaps/old
+@dirrm %%WWWDIR%%/images/sysmaps
+@dirrm %%WWWDIR%%/images/gradients
+@dirrm %%WWWDIR%%/images/general/tree
+@dirrm %%WWWDIR%%/images/general/bttn
+@dirrm %%WWWDIR%%/images/general/bar
+@dirrm %%WWWDIR%%/images/general
+@dirrm %%WWWDIR%%/images/flash
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/fonts
+@dirrm %%WWWDIR%%/conf
+@dirrm %%WWWDIR%%/audio
+@dirrm %%WWWDIR%%/api/rpc
+@dirrm %%WWWDIR%%/api/classes
+@dirrm %%WWWDIR%%/api
+@dirrm %%WWWDIR%%