aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/zabbix4-server
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2019-03-27 19:37:10 +0800
committerdbaio <dbaio@FreeBSD.org>2019-03-27 19:37:10 +0800
commit04678d4b911c1bda013e9f678b94da693872eeff (patch)
treed22e3fefbd2f294f3b057a54a9d7f95fb1d46853 /net-mgmt/zabbix4-server
parentfd7a73ac366cda1f53e0dd8f777f7e1acb63c6eb (diff)
downloadfreebsd-ports-gnome-04678d4b911c1bda013e9f678b94da693872eeff.tar.gz
freebsd-ports-gnome-04678d4b911c1bda013e9f678b94da693872eeff.tar.zst
freebsd-ports-gnome-04678d4b911c1bda013e9f678b94da693872eeff.zip
net-mgmt/zabbix*-agent: Add libcurl support
This enables zabbix_agent simple_checks (net.tcp.service) for https. PR: 234831 Reported by: Marcin Gryszkalis <mg@fork.pl> Approved by: Pakhom Golynga <pg@pakhom.spb.ru> (maintainer)
Diffstat (limited to 'net-mgmt/zabbix4-server')
-rw-r--r--net-mgmt/zabbix4-server/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-mgmt/zabbix4-server/Makefile b/net-mgmt/zabbix4-server/Makefile
index a2c2d9bec013..5d04c9584221 100644
--- a/net-mgmt/zabbix4-server/Makefile
+++ b/net-mgmt/zabbix4-server/Makefile
@@ -71,7 +71,6 @@ OPTIONS_DEFINE= IPV6 FPING JABBER CURL LDAP IPMI SSH NMAP LIBXML2 UNIXODBC
OPTIONS_DEFAULT= FPING CURL UNIXODBC MYSQL OPENSSL
OPTIONS_SUB= yes
-CURL_DESC= Support for web monitoring
FPING_DESC= Build/install fping for ping checks
IPMI_DESC= Support for IPMI checks
JABBER_DESC= Support for Jabber media type
@@ -96,9 +95,6 @@ SQLITE_USES+= sqlite:3
ORACLE_CONFIGURE_WITH= oracle
-CURL_CONFIGURE_WITH= libcurl
-CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-
LDAP_CONFIGURE_WITH= ldap
LDAP_USE= OPENLDAP=yes
@@ -120,6 +116,10 @@ OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL GNUTLS
.endif # if ${ZABBIX_BUILD} != "agent" && ${ZABBIX_BUILD} != "java"
+CURL_DESC= Support for web monitoring
+CURL_CONFIGURE_WITH= libcurl
+CURL_LIB_DEPENDS= libcurl.so:ftp/curl
+
IPV6_CONFIGURE_ENABLE= ipv6
NMAP_RUN_DEPENDS= nmap:security/nmap \