aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-12-13 08:27:45 +0800
committermiwi <miwi@FreeBSD.org>2009-12-13 08:27:45 +0800
commit174b43932237eb683566490fa4aca5c9c5d1050b (patch)
tree0eecb5ff4e3626c02031e8afa0a4dccc864671f8 /net-mgmt
parentc610d7904f3b11f2591d05ba0cce22598f2e3205 (diff)
downloadfreebsd-ports-gnome-174b43932237eb683566490fa4aca5c9c5d1050b.tar.gz
freebsd-ports-gnome-174b43932237eb683566490fa4aca5c9c5d1050b.tar.zst
freebsd-ports-gnome-174b43932237eb683566490fa4aca5c9c5d1050b.zip
qKismet is graphical Kismet client writtent in Qt. It aims to be a full-featured
client, which provides features allowing easy overwiew of Kismet output. Currently it displays networks, clients, alerts and status messages and allows to sort and filter them. WWW: http://qkismet.sourceforge.net PR: ports/141205 Submitted by: Gvozdikov Veniamin <g.veniamin at googlemail.com>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/qkismet/Makefile39
-rw-r--r--net-mgmt/qkismet/distinfo3
-rw-r--r--net-mgmt/qkismet/pkg-descr6
-rw-r--r--net-mgmt/qkismet/pkg-plist22
5 files changed, 71 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 17fa9b0262c3..ed17844134e6 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -227,6 +227,7 @@
SUBDIR += py-snmp4-mibs
SUBDIR += py-twistedSNMP
SUBDIR += py-yapsnmp
+ SUBDIR += qkismet
SUBDIR += rancid
SUBDIR += rancid-devel
SUBDIR += rate
diff --git a/net-mgmt/qkismet/Makefile b/net-mgmt/qkismet/Makefile
new file mode 100644
index 000000000000..6a667fe43566
--- /dev/null
+++ b/net-mgmt/qkismet/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: qkismet
+# Date created: 2009-11-12
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qkismet
+PORTVERSION= 0.3.1
+CATEGORIES= net-mgmt
+MASTER_SITES= SF/${PORTNAME}/qKismet/${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= This is graphical Kismet client writtent in Qt
+
+RUN_DEPENDS= kismet:${PORTSDIR}/net-mgmt/kismet
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network
+
+QMAKE_PRO= ${PORTNAME}.pro
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+do-patch:
+ ${REINPLACE_CMD} -e 's,:/img/,${DATADIR}/img/,g' \
+ ${WRKSRC}/*.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/../build/release/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} img ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/qkismet/distinfo b/net-mgmt/qkismet/distinfo
new file mode 100644
index 000000000000..7619b4d7b6a2
--- /dev/null
+++ b/net-mgmt/qkismet/distinfo
@@ -0,0 +1,3 @@
+MD5 (qkismet-0.3.1.tar.bz2) = 4011311a03ffae7ee34fcd3059e2137c
+SHA256 (qkismet-0.3.1.tar.bz2) = 531aecbe320fdf33f038ed2770cba79b2daef2ad1242ff8438ceee8e5c42f6f3
+SIZE (qkismet-0.3.1.tar.bz2) = 70497
diff --git a/net-mgmt/qkismet/pkg-descr b/net-mgmt/qkismet/pkg-descr
new file mode 100644
index 000000000000..835dc7aed9ed
--- /dev/null
+++ b/net-mgmt/qkismet/pkg-descr
@@ -0,0 +1,6 @@
+qKismet is graphical Kismet client writtent in Qt. It aims to be a full-featured
+client, which provides features allowing easy overwiew of Kismet output.
+Currently it displays networks, clients, alerts and status messages and allows
+to sort and filter them.
+
+WWW: http://qkismet.sourceforge.net
diff --git a/net-mgmt/qkismet/pkg-plist b/net-mgmt/qkismet/pkg-plist
new file mode 100644
index 000000000000..bb4959ef5432
--- /dev/null
+++ b/net-mgmt/qkismet/pkg-plist
@@ -0,0 +1,22 @@
+bin/qkismet
+share/qkismet/img/alert.png
+share/qkismet/img/document-save.png
+share/qkismet/img/edit-clear.png
+share/qkismet/img/edit-copy.png
+share/qkismet/img/edit-select-all.png
+share/qkismet/img/emblem-important.png
+share/qkismet/img/error.png
+share/qkismet/img/fatal.png
+share/qkismet/img/help-about.png
+share/qkismet/img/icon.svg
+share/qkismet/img/info.png
+share/qkismet/img/media-playback-pause.png
+share/qkismet/img/media-playback-start.png
+share/qkismet/img/network-connect.png
+share/qkismet/img/network-disconnect.png
+share/qkismet/img/network-workgroup.png
+share/qkismet/img/text-x-generic.png
+share/qkismet/img/utilities-system-monitor.png
+share/qkismet/img/view-filter.png
+@dirrm share/qkismet/img
+@dirrm share/qkismet/