aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-06-07 05:43:03 +0800
committersylvio <sylvio@FreeBSD.org>2010-06-07 05:43:03 +0800
commit1b8fa3d94238720e5bde894c39c81ef333218d71 (patch)
treec56f06583c3c81822d0e720fd801dba8a8f0906d /net-mgmt
parentd6e9f26cb41f02b46ee6ade78eed7e419e2bcc80 (diff)
downloadfreebsd-ports-gnome-1b8fa3d94238720e5bde894c39c81ef333218d71.tar.gz
freebsd-ports-gnome-1b8fa3d94238720e5bde894c39c81ef333218d71.tar.zst
freebsd-ports-gnome-1b8fa3d94238720e5bde894c39c81ef333218d71.zip
- Dependency on x11-toolkits/p5-Tk optional
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile14
-rw-r--r--net-mgmt/net-snmp/pkg-plist2
2 files changed, 13 insertions, 3 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index a9ae0db52ce8..6890d2973b87 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -15,13 +15,12 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= sylvio@FreeBSD.org
COMMENT= An extendable SNMP implementation
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
-
OPTIONS= IPV6 "Build with IPv6 support" on \
MFD_REWRITES "Build with 64-bit Interface Counters" off \
PERL "Install additional perl modules" on \
PERL_EMBEDDED "Build embedded perl" on \
DUMMY "Enable dummy values as placeholders" on \
+ TKMIB "Install graphical MIB browser" off \
DMALLOC "Enable dmalloc debug memory allocator" off
MAKE_JOBS_UNSAFE= yes
@@ -53,6 +52,14 @@ CONFIGURE_ARGS+= --with-openssl="${OPENSSLBASE}"
CONFIGURE_ARGS+=--with-dummy-values
.endif
+.if !defined(WITH_TKMIB)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-local:Makefile.in
+PLIST_SUB+= WITH_TKMIB="@comment "
+.else
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+PLIST_SUB+= WITH_TKMIB=""
+.endif
+
.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+=--with-perl-modules
@@ -207,6 +214,9 @@ SBIN_FILES= snmpd snmptrapd
STARTUP_DIR= ${PREFIX}/etc/rc.d
SCRIPT_FILES= snmpcheck.def mib2c fixproc ipf-mod.pl snmpconf \
traptoemail
+.if defined(WITH_TKMIB)
+SCRIPT_FILES+= tkmib
+.endif
DOC_FILES= AGENT.txt COPYING FAQ NEWS README \
README.agentx README.krb5 README.snmpv3 README.thread \
agent/mibgroup/README.smux
diff --git a/net-mgmt/net-snmp/pkg-plist b/net-mgmt/net-snmp/pkg-plist
index 66e3f2e981b8..d9007057b76a 100644
--- a/net-mgmt/net-snmp/pkg-plist
+++ b/net-mgmt/net-snmp/pkg-plist
@@ -24,7 +24,7 @@ bin/snmptrap
bin/snmpusm
bin/snmpvacm
bin/snmpwalk
-bin/tkmib
+%%WITH_TKMIB%%bin/tkmib
bin/traptoemail
@exec mkdir %D/etc/snmp 2>/dev/null || true
include/net-snmp/agent/agent_callbacks.h