aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2003-05-15 19:31:35 +0800
committermich <mich@FreeBSD.org>2003-05-15 19:31:35 +0800
commit2093db383eeacf9801393b9c37f8feb88b10a88c (patch)
tree7ba606b4ad35b0a82c8d61665228d32fbd925257 /net-mgmt
parent8c341d82d2d8c2e5c6399acd8840214f5aabe662 (diff)
downloadfreebsd-ports-gnome-2093db383eeacf9801393b9c37f8feb88b10a88c.tar.gz
freebsd-ports-gnome-2093db383eeacf9801393b9c37f8feb88b10a88c.tar.zst
freebsd-ports-gnome-2093db383eeacf9801393b9c37f8feb88b10a88c.zip
New port.
Remote Arpwatch collects ARP tables from remote devices using SNMP and checks them for changes. It is very useful for detecting problems and malicious users in networks with routers that don't support static ARP tables. PR: 50521 Approved by: roberto(mentor)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/remarp/Makefile50
-rw-r--r--net-mgmt/remarp/distinfo1
-rw-r--r--net-mgmt/remarp/pkg-descr10
-rw-r--r--net-mgmt/remarp/pkg-plist5
4 files changed, 66 insertions, 0 deletions
diff --git a/net-mgmt/remarp/Makefile b/net-mgmt/remarp/Makefile
new file mode 100644
index 000000000000..08aca81355a0
--- /dev/null
+++ b/net-mgmt/remarp/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: remarp
+# Date created: Tue Apr 1 14:02:35 GMT 2003
+# Whom: mich@freebsdcluster.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= remarp
+PORTVERSION= 0.05
+CATEGORIES= net
+MASTER_SITES= http://www.raccoon.kiev.ua/projects/remarp/
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= An SNMP-based ARP watcher
+
+RUN_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
+ ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net/p5-Net-SNMP
+
+USE_REINPLACE= YES
+USE_PERL5= YES
+NO_BUILD= YES
+
+REMARP_SPOOL= /var/spool/remarp
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|; \
+ s|use lib "\$$Bin/../lib";||' ${WRKSRC}/sbin/remarp.pl
+ @${REINPLACE_CMD} -e 's|\$$Bin/../etc/remarp.conf|${PREFIX}/etc/remarp.conf|; \
+ s|\$$Bin/../var/run/remarp.pid|/var/run/remarp.pid|; \
+ s|\$$Bin/../var/spool|${REMARP_SPOOL}|; \
+ s|use lib "\$$Bin/../lib";||' ${WRKSRC}/lib/remarp/configure.pm
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/remarp
+ ${MKDIR} ${REMARP_SPOOL}
+ ${INSTALL_DATA} ${WRKSRC}/etc/remarp.conf ${PREFIX}/etc/remarp.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/lib/remarp/*.pm ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/remarp
+ ${INSTALL_SCRIPT} ${WRKSRC}/sbin/remarp.pl ${PREFIX}/sbin/remarp
+
+post-install:
+.if !defined(BATCH)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "###############################################################################"
+ @${ECHO_MSG} "# Please create a remarp config file in ${PREFIX}/etc/ #"
+ @${ECHO_MSG} "# A sample configuration file is installed as remarp.conf.sample #"
+ @${ECHO_MSG} "###############################################################################"
+ @${ECHO_MSG}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/remarp/distinfo b/net-mgmt/remarp/distinfo
new file mode 100644
index 000000000000..6a147284dd7d
--- /dev/null
+++ b/net-mgmt/remarp/distinfo
@@ -0,0 +1 @@
+MD5 (remarp-0.05.tar.gz) = b54723dcc163d7c9abb7ca4362017247
diff --git a/net-mgmt/remarp/pkg-descr b/net-mgmt/remarp/pkg-descr
new file mode 100644
index 000000000000..32b2c5bb3ad1
--- /dev/null
+++ b/net-mgmt/remarp/pkg-descr
@@ -0,0 +1,10 @@
+Remote Arpwatch collects ARP tables from remote devices using SNMP and
+checks them for changes. It is very useful for detecting problems and
+malicious users in networks with routers that don't support static
+ARP tables.
+
+WWW: http://www.raccoon.kiev.ua/projects/remarp/
+AUTHOR: melnik <melnik@raccoon.kiev.ua>
+
+- Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/net-mgmt/remarp/pkg-plist b/net-mgmt/remarp/pkg-plist
new file mode 100644
index 000000000000..7b1cdbf0912a
--- /dev/null
+++ b/net-mgmt/remarp/pkg-plist
@@ -0,0 +1,5 @@
+sbin/remarp
+etc/remarp.conf.sample
+lib/perl5/site_perl/%%PERL_VER%%/remarp/config.pm
+lib/perl5/site_perl/%%PERL_VER%%/remarp/configure.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/remarp