aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-09-11 23:11:39 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-09-11 23:11:39 +0800
commit396994df76c0ff2c3418ee18f5e10e12727994bf (patch)
treeeb2efaec0b2010232b5e2bcc8e54d081affa1fce /net-mgmt
parent33159e4aaa44fb98b3a0f25c5b56e1bd9f9eb7c8 (diff)
downloadfreebsd-ports-gnome-396994df76c0ff2c3418ee18f5e10e12727994bf.tar.gz
freebsd-ports-gnome-396994df76c0ff2c3418ee18f5e10e12727994bf.tar.zst
freebsd-ports-gnome-396994df76c0ff2c3418ee18f5e10e12727994bf.zip
- Convert to new options framework
- Add missing dependency on perl - Bump PORTREVISION due to added dependency Approved by: eadler, bapt (mentors, implicit)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ndoutils/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-mgmt/ndoutils/Makefile b/net-mgmt/ndoutils/Makefile
index d7c4599bced6..0ebca05acc20 100644
--- a/net-mgmt/ndoutils/Makefile
+++ b/net-mgmt/ndoutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ndoutils
PORTVERSION= 1.4b8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt
MASTER_SITES= SF/nagios/${PORTNAME}-1.x/${PORTNAME}-${PORTVERSION}
@@ -16,8 +16,11 @@ COMMENT= Keep Nagios perfdata in MySQL or Postgresql database
RUN_DEPENDS= ${LOCALBASE}/bin/nagios:${PORTSDIR}/net-mgmt/nagios
-OPTIONS= MYSQL "MySQL Backend" on \
- PGSQL "Postgresql Backend" off
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
+MYSQL_DESC= MySQL backend support
+PGSQL_DESC= Postgresql backend support
MAKE_JOBS_UNSAFE= yes
@@ -27,11 +30,13 @@ CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/ndoutils
CFG_FILES= misccommands ndo2db ndomod
+USE_PERL5= yes
USE_RC_SUBR= ndo2db
SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_MYSQL)
+
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL=yes
CONFIGURE_ARGS+= --enable-mysql \
--with-mysql-lib=${LOCALBASE}/lib/mysql \
@@ -40,7 +45,7 @@ CONFIGURE_ARGS+= --enable-mysql \
CONFIGURE_ARGS+= --disable-mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL=yes
CONFIGURE_ARGS+= --enable-pgsql \
--with-pgsql-lib=${LOCALBASE}/lib/pgsql \
@@ -49,10 +54,6 @@ CONFIGURE_ARGS+= --enable-pgsql \
CONFIGURE_ARGS+= --disable-pgsql
.endif
-.if defined(WITHOUT_MYSQL) && defined(WITHOUT_PGSQL)
-IGNORE= you should define at least 1 of WITH_MYSQL or WITH_PGSQL, WITH_MYSQL=yes is the default
-.endif
-
.if !defined(NOPORTDOCS)
PLIST_SUB+= PORTDOCS=""
.else