aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-12-16 20:57:54 +0800
committerzi <zi@FreeBSD.org>2011-12-16 20:57:54 +0800
commit4bc7dd137c0315ff0487a79118d7deb3ebc516b8 (patch)
tree8127c4afbb59eeac8ab9f0cc4ba08ec924c25618 /net-mgmt
parente7fa140eb10f05eccd9d96dab6c7eda4b2869679 (diff)
downloadfreebsd-ports-gnome-4bc7dd137c0315ff0487a79118d7deb3ebc516b8.tar.gz
freebsd-ports-gnome-4bc7dd137c0315ff0487a79118d7deb3ebc516b8.tar.zst
freebsd-ports-gnome-4bc7dd137c0315ff0487a79118d7deb3ebc516b8.zip
- Merge in fix for bug 3411437 to address stack overflow issue
- Bump PORTREVISION Reported by: brian@ Obtained from: upstream bug tracker
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 9f918f9ed5d7..b7ac7b5d55e3 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c b/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c
new file mode 100644
index 000000000000..a2ebd9efe63d
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c
@@ -0,0 +1,11 @@
+--- ./agent/mibgroup/host/data_access/swrun_kinfo.c.orig 2011-12-16 07:32:47.000000000 -0500
++++ ./agent/mibgroup/host/data_access/swrun_kinfo.c 2011-12-16 07:32:40.000000000 -0500
+@@ -183,7 +183,7 @@
+ #if HAVE_KVM_GETPROC2
+ argv = kvm_getargv2( kd, &(proc_table[i]), 0);
+ #else
+- argv = kvm_getargv( kd, &(proc_table[i]), 0);
++ argv = kvm_getargv( kd, &(proc_table[i]), BUFSIZ);
+ #endif
+
+ entry->hrSWRunName_len = snprintf(entry->hrSWRunName,