aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2011-09-07 09:49:27 +0800
committersylvio <sylvio@FreeBSD.org>2011-09-07 09:49:27 +0800
commit4e3e871b5389f3f267a1443722a4cc6c768f2fac (patch)
tree8bdb6f3d755071491818d87e5817c5aecd63bb42 /net-mgmt
parent363a520e002da21e7ea6da5bd25157bebbbd7f94 (diff)
downloadfreebsd-ports-gnome-4e3e871b5389f3f267a1443722a4cc6c768f2fac.tar.gz
freebsd-ports-gnome-4e3e871b5389f3f267a1443722a4cc6c768f2fac.tar.zst
freebsd-ports-gnome-4e3e871b5389f3f267a1443722a4cc6c768f2fac.zip
- Add patch to fix problem with percent of UCD-SNMP-MIB::dskTable
- BUMP PORTREVISION
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent-mibgroup-ucd-snmp_disk_hw.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 2dd030394a60..350e546b6a43 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent-mibgroup-ucd-snmp_disk_hw.c b/net-mgmt/net-snmp/files/patch-agent-mibgroup-ucd-snmp_disk_hw.c
new file mode 100644
index 000000000000..db9cbd1dff78
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent-mibgroup-ucd-snmp_disk_hw.c
@@ -0,0 +1,11 @@
+--- agent/mibgroup/ucd-snmp/disk_hw.c.orig 2011-09-06 22:38:43.000000000 -0300
++++ agent/mibgroup/ucd-snmp/disk_hw.c 2011-09-06 22:40:13.000000000 -0300
+@@ -245,7 +245,7 @@
+
+
+ static int _percent( int value, int total ) {
+- return (int)( value * 100 ) / total;
++ return (int)( value / (total / 100));
+ }
+
+ static netsnmp_fsys_info **