aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-02-04 05:43:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-02-04 05:43:51 +0800
commit8f3282b6fc9aceb1903c7ef77494726c8987ecaa (patch)
tree31eed93f01e7583045d772f5ba98641fbb7c059a /net-mgmt
parentb93a43b3e97fae0592332a9075396fc6fa3c15b4 (diff)
downloadfreebsd-ports-gnome-8f3282b6fc9aceb1903c7ef77494726c8987ecaa.tar.gz
freebsd-ports-gnome-8f3282b6fc9aceb1903c7ef77494726c8987ecaa.tar.zst
freebsd-ports-gnome-8f3282b6fc9aceb1903c7ef77494726c8987ecaa.zip
- Don't break directory permissions - fixes build from non-root
- Silence post-extract - Strip binary
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/lanmap/Makefile5
-rw-r--r--net-mgmt/lanmap/files/patch-Makefile.in3
2 files changed, 5 insertions, 3 deletions
diff --git a/net-mgmt/lanmap/Makefile b/net-mgmt/lanmap/Makefile
index 2345723079a1..4173215cd0b4 100644
--- a/net-mgmt/lanmap/Makefile
+++ b/net-mgmt/lanmap/Makefile
@@ -16,6 +16,9 @@ GNU_CONFIGURE= yes
USES= zip
post-extract:
- ${CHMOD} 755 ${WRKSRC}/configure
+ @${CHMOD} 755 ${WRKSRC}/configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/net-mgmt/lanmap/files/patch-Makefile.in b/net-mgmt/lanmap/files/patch-Makefile.in
index c2031cad500b..1602090ffc03 100644
--- a/net-mgmt/lanmap/files/patch-Makefile.in
+++ b/net-mgmt/lanmap/files/patch-Makefile.in
@@ -1,6 +1,6 @@
--- Makefile.in.orig 2006-03-07 23:44:34.000000000 +0800
+++ Makefile.in 2014-06-09 11:51:38.403957445 +0800
-@@ -8,20 +8,21 @@ prefix = @prefix@
+@@ -8,20 +8,20 @@ prefix = @prefix@
BINARY = lanmap
BINDEST = ${prefix}/bin/
DATADEST = ${prefix}/share/lanmap/
@@ -26,7 +26,6 @@
+ install -m 0755 -d $(DESTDIR)$(DATADEST)data/graph/
+ install -m 0755 -d $(DESTDIR)$(DATADEST)graph/img/
+ install -m 0644 ./data/mac_vendor $(DESTDIR)$(DATADEST)data/
-+ install -m 0644 -d $(DESTDIR)$(DATADEST)graph
+ install -m 0644 ./graph/lanmap.header $(DESTDIR)$(DATADEST)graph/
+ for f in ./graph/img/*.png ./graph/img/*.gif ./graph/img/*.svg; do install -m 0644 $$f $(DESTDIR)$(DATADEST)graph/img/; done