aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-09 02:28:19 +0800
committermiwi <miwi@FreeBSD.org>2007-10-09 02:28:19 +0800
commit9288ebfa07ebfefea70ffc1c33abee8b1e3ce033 (patch)
tree47a01eca1bbd4c7b3404a5dafcab46cdcf2e89ab /net-mgmt
parent7d7c7fb9960639eafc8ec2774ec17126788da0d6 (diff)
downloadfreebsd-ports-gnome-9288ebfa07ebfefea70ffc1c33abee8b1e3ce033.tar.gz
freebsd-ports-gnome-9288ebfa07ebfefea70ffc1c33abee8b1e3ce033.tar.zst
freebsd-ports-gnome-9288ebfa07ebfefea70ffc1c33abee8b1e3ce033.zip
collectd is a small daemon written in C for performance. It reads various
system & network statistics along with updating output RRD or CSV files. The daemon is very fast and allows for frequent polling of values, with support for polling as frequent as every 10 seconds. WWW: http://www.collectd.org/ PR: ports/116736 Submitted by: Matt Peterson <matt at peterson.org>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/collectd/Makefile151
-rw-r--r--net-mgmt/collectd/distinfo3
-rw-r--r--net-mgmt/collectd/pkg-descr6
-rw-r--r--net-mgmt/collectd/pkg-plist52
-rw-r--r--net-mgmt/collectd5/Makefile151
-rw-r--r--net-mgmt/collectd5/distinfo3
-rw-r--r--net-mgmt/collectd5/pkg-descr6
-rw-r--r--net-mgmt/collectd5/pkg-plist52
9 files changed, 425 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 24e8c4bd6a8f..4cb45d084eea 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -43,6 +43,7 @@
SUBDIR += cisco_conf
SUBDIR += ciscoconf
SUBDIR += clog
+ SUBDIR += collectd
SUBDIR += confregdecode
SUBDIR += cricket
SUBDIR += darkstat
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
new file mode 100644
index 000000000000..c077af485d54
--- /dev/null
+++ b/net-mgmt/collectd/Makefile
@@ -0,0 +1,151 @@
+# New ports collection makefile for: collectd
+# Date created: Sat Sep 29 05:19:31 PDT 2007
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= collectd
+PORTVERSION= 4.1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://collectd.org/files/ \
+ http://matt.peterson.org/FreeBSD/ports/
+
+MAINTAINER= matt@peterson.org
+COMMENT= Systems & network statistics collection daemon
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+OPTIONS= APACHE "Apache mod_status statistics (libcurl)" Off \
+ APCUPS "APC UPS support" Off \
+ DEBUG "enable debugging" Off \
+ INTERFACE "Network interface statistics (libstatgrab)" On \
+ MBMON "Query mbmond" Off \
+ MYSQL "MySQL statistics" Off \
+ PING "Network latency statistics (liboping)" On \
+ RRDTOOL "RRDTool output plugin" On \
+ SNMP "SNMP support" On \
+ XMMS "XMMS statistics" Off
+
+MAN1= collectd.1 collectd-nagios.1
+MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
+ collectd-snmp.5 collectd-unixsock.5 collectd-perl.5
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITH_XMMS) || defined(WITH_INTERFACE)
+USE_GNOME= pkgconfig
+. if defined(WITH_XMMS)
+USE_GNOME+= glib
+. endif
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ( ${OSVERSION} < 601103 )
+BROKEN= Need bind9 import post 6.1
+.endif
+
+CONFIGURE_ARGS= --disable-apple_sensors \
+ --disable-battery \
+ --disable-hddtemp \
+ --disable-multimeter \
+ --disable-iptables \
+ --disable-perl \
+ --disable-sensors \
+ --disable-serial \
+ --disable-vserver \
+ --disable-wireless
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.else
+PLIST_SUB+= APACHE="@comment "
+.endif
+
+.if defined(WITH_APACHE)
+CONFIGURE_ARGS+= --enable-apache
+BUILD_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+PLIST_SUB+= APACHE=""
+.else
+CONFIGURE_ARGS+= --disable-apache
+PLIST_SUB+= APACHE="@comment "
+.endif
+
+.if defined(WITH_APCUPS)
+CONFIGURE_ARGS+= --enable-apcups
+BUILD_DEPENDS+= ${LOCALBASE}/sbin/apcupsd:${PORTSDIR}/sysutils/apcupsd
+PLIST_SUB+= APCUPS=""
+.else
+CONFIGURE_ARGS+= --disable-apcups
+PLIST_SUB+= APCUPS="@comment "
+.endif
+
+.if defined(WITH_INTERFACE)
+CONFIGURE_ARGS+= --enable-interface
+LIB_DEPENDS+= statgrab.8:${PORTSDIR}/devel/libstatgrab
+PLIST_SUB+= INTERFACE=""
+CONFIGURE_ENV+= LIBS="`pkg-config --libs libstatgrab`"
+.else
+CONFIGURE_ARGS+= --disable-interface
+PLIST_SUB+= INTERFACE="@comment "
+.endif
+
+.if defined(WITH_MBMON)
+CONFIGURE_ARGS+= --enable-mbmon
+RUN_DEPENDS+= ${LOCALBASE}/sbin/mbmond:${PORTSDIR}/sysutils/mbmon
+PLIST_SUB+= MBMON=""
+.else
+CONFIGURE_ARGS+= --disable-mbmon
+PLIST_SUB+= MBMON="@comment "
+.endif
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --enable-mysql
+PLIST_SUB+= MYSQL=""
+.else
+CONFIGURE_ARGS+= --disable-mysql
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if defined(WITH_PING)
+LIB_DEPENDS+= oping:${PORTSDIR}/net/liboping
+CONFIGURE_ARGS+= --enable-ping
+PLIST_SUB+= PING=""
+.else
+CONFIGURE_ARGS+= --disable-ping
+PLIST_SUB+= PING="@comment "
+.endif
+
+.if defined(WITH_RRDTOOL)
+LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
+CONFIGURE_ARGS+= --enable-rrdtool
+PLIST_SUB+= RRD=""
+.else
+CONFIGURE_ARGS+= --disable-rrdtool
+PLIST_SUB+= RRD="@comment "
+.endif
+
+.if defined(WITH_SNMP)
+LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
+CONFIGURE_ARGS+= --enable-snmp
+PLIST_SUB+= SNMP=""
+.else
+CONFIGURE_ARGS+= --disable-snmp
+PLIST_SUB+= SNMP="@comment "
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+CONFIGURE_ARGS+= --enable-xmms
+CFLAGS= `pkg-config glib --cflags`
+PLIST_SUB+= XMMS=""
+.else
+CONFIGURE_ARGS+= --disable-xmms
+PLIST_SUB+= XMMS="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/collectd/distinfo b/net-mgmt/collectd/distinfo
new file mode 100644
index 000000000000..7fce046fb9d7
--- /dev/null
+++ b/net-mgmt/collectd/distinfo
@@ -0,0 +1,3 @@
+MD5 (collectd-4.1.2.tar.gz) = 40458dabe8ec5df87323c1862a03cb94
+SHA256 (collectd-4.1.2.tar.gz) = fba4423378a8a270de8b48f98dc2f102f4f3c630381672267344776885a6e690
+SIZE (collectd-4.1.2.tar.gz) = 999229
diff --git a/net-mgmt/collectd/pkg-descr b/net-mgmt/collectd/pkg-descr
new file mode 100644
index 000000000000..b4c750a96be2
--- /dev/null
+++ b/net-mgmt/collectd/pkg-descr
@@ -0,0 +1,6 @@
+collectd is a small daemon written in C for performance. It reads various
+system & network statistics along with updating output RRD or CSV files.
+The daemon is very fast and allows for frequent polling of values, with
+support for polling as frequent as every 10 seconds.
+
+WWW: http://www.collectd.org/
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
new file mode 100644
index 000000000000..373023f5430f
--- /dev/null
+++ b/net-mgmt/collectd/pkg-plist
@@ -0,0 +1,52 @@
+bin/collectd-nagios
+etc/collectd.conf
+%%APACHE%%lib/collectd/apache.la
+%%APACHE%%lib/collectd/apache.so
+%%APCUPS%%lib/collectd/apcups.la
+%%APCUPS%%lib/collectd/apcups.so
+lib/collectd/cpu.la
+lib/collectd/cpu.so
+lib/collectd/csv.la
+lib/collectd/csv.so
+lib/collectd/df.la
+lib/collectd/df.so
+lib/collectd/dns.la
+lib/collectd/dns.so
+lib/collectd/email.la
+lib/collectd/email.so
+lib/collectd/exec.la
+lib/collectd/exec.so
+%%INTERFACE%%lib/collectd/interface.la
+%%INTERFACE%%lib/collectd/interface.so
+lib/collectd/load.la
+lib/collectd/load.so
+lib/collectd/logfile.la
+lib/collectd/logfile.so
+%%MBMON%%lib/collectd/mbmon.la
+%%MBMON%%lib/collectd/mbmon.so
+lib/collectd/memory.la
+lib/collectd/memory.so
+%%MYSQL%%lib/collectd/mysql.la
+%%MYSQL%%lib/collectd/mysql.so
+lib/collectd/network.la
+lib/collectd/network.so
+lib/collectd/ntpd.la
+lib/collectd/ntpd.so
+%%PING%%lib/collectd/ping.la
+%%PING%%lib/collectd/ping.so
+%%RRD%%lib/collectd/rrdtool.la
+%%RRD%%lib/collectd/rrdtool.so
+%%SNMP%%lib/collectd/snmp.la
+%%SNMP%%lib/collectd/snmp.so
+lib/collectd/swap.la
+lib/collectd/swap.so
+lib/collectd/syslog.la
+lib/collectd/syslog.so
+lib/collectd/types.db
+lib/collectd/unixsock.la
+lib/collectd/unixsock.so
+%%XMMS%%lib/collectd/xmms.la
+%%XMMS%%lib/collectd/xmms.so
+@dirrm lib/collectd
+sbin/collectd
+@dirrmtry var/lib/collectd
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
new file mode 100644
index 000000000000..c077af485d54
--- /dev/null
+++ b/net-mgmt/collectd5/Makefile
@@ -0,0 +1,151 @@
+# New ports collection makefile for: collectd
+# Date created: Sat Sep 29 05:19:31 PDT 2007
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= collectd
+PORTVERSION= 4.1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://collectd.org/files/ \
+ http://matt.peterson.org/FreeBSD/ports/
+
+MAINTAINER= matt@peterson.org
+COMMENT= Systems & network statistics collection daemon
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+OPTIONS= APACHE "Apache mod_status statistics (libcurl)" Off \
+ APCUPS "APC UPS support" Off \
+ DEBUG "enable debugging" Off \
+ INTERFACE "Network interface statistics (libstatgrab)" On \
+ MBMON "Query mbmond" Off \
+ MYSQL "MySQL statistics" Off \
+ PING "Network latency statistics (liboping)" On \
+ RRDTOOL "RRDTool output plugin" On \
+ SNMP "SNMP support" On \
+ XMMS "XMMS statistics" Off
+
+MAN1= collectd.1 collectd-nagios.1
+MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
+ collectd-snmp.5 collectd-unixsock.5 collectd-perl.5
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITH_XMMS) || defined(WITH_INTERFACE)
+USE_GNOME= pkgconfig
+. if defined(WITH_XMMS)
+USE_GNOME+= glib
+. endif
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ( ${OSVERSION} < 601103 )
+BROKEN= Need bind9 import post 6.1
+.endif
+
+CONFIGURE_ARGS= --disable-apple_sensors \
+ --disable-battery \
+ --disable-hddtemp \
+ --disable-multimeter \
+ --disable-iptables \
+ --disable-perl \
+ --disable-sensors \
+ --disable-serial \
+ --disable-vserver \
+ --disable-wireless
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.else
+PLIST_SUB+= APACHE="@comment "
+.endif
+
+.if defined(WITH_APACHE)
+CONFIGURE_ARGS+= --enable-apache
+BUILD_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+PLIST_SUB+= APACHE=""
+.else
+CONFIGURE_ARGS+= --disable-apache
+PLIST_SUB+= APACHE="@comment "
+.endif
+
+.if defined(WITH_APCUPS)
+CONFIGURE_ARGS+= --enable-apcups
+BUILD_DEPENDS+= ${LOCALBASE}/sbin/apcupsd:${PORTSDIR}/sysutils/apcupsd
+PLIST_SUB+= APCUPS=""
+.else
+CONFIGURE_ARGS+= --disable-apcups
+PLIST_SUB+= APCUPS="@comment "
+.endif
+
+.if defined(WITH_INTERFACE)
+CONFIGURE_ARGS+= --enable-interface
+LIB_DEPENDS+= statgrab.8:${PORTSDIR}/devel/libstatgrab
+PLIST_SUB+= INTERFACE=""
+CONFIGURE_ENV+= LIBS="`pkg-config --libs libstatgrab`"
+.else
+CONFIGURE_ARGS+= --disable-interface
+PLIST_SUB+= INTERFACE="@comment "
+.endif
+
+.if defined(WITH_MBMON)
+CONFIGURE_ARGS+= --enable-mbmon
+RUN_DEPENDS+= ${LOCALBASE}/sbin/mbmond:${PORTSDIR}/sysutils/mbmon
+PLIST_SUB+= MBMON=""
+.else
+CONFIGURE_ARGS+= --disable-mbmon
+PLIST_SUB+= MBMON="@comment "
+.endif
+
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --enable-mysql
+PLIST_SUB+= MYSQL=""
+.else
+CONFIGURE_ARGS+= --disable-mysql
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if defined(WITH_PING)
+LIB_DEPENDS+= oping:${PORTSDIR}/net/liboping
+CONFIGURE_ARGS+= --enable-ping
+PLIST_SUB+= PING=""
+.else
+CONFIGURE_ARGS+= --disable-ping
+PLIST_SUB+= PING="@comment "
+.endif
+
+.if defined(WITH_RRDTOOL)
+LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
+CONFIGURE_ARGS+= --enable-rrdtool
+PLIST_SUB+= RRD=""
+.else
+CONFIGURE_ARGS+= --disable-rrdtool
+PLIST_SUB+= RRD="@comment "
+.endif
+
+.if defined(WITH_SNMP)
+LIB_DEPENDS+= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
+CONFIGURE_ARGS+= --enable-snmp
+PLIST_SUB+= SNMP=""
+.else
+CONFIGURE_ARGS+= --disable-snmp
+PLIST_SUB+= SNMP="@comment "
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+CONFIGURE_ARGS+= --enable-xmms
+CFLAGS= `pkg-config glib --cflags`
+PLIST_SUB+= XMMS=""
+.else
+CONFIGURE_ARGS+= --disable-xmms
+PLIST_SUB+= XMMS="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/collectd5/distinfo b/net-mgmt/collectd5/distinfo
new file mode 100644
index 000000000000..7fce046fb9d7
--- /dev/null
+++ b/net-mgmt/collectd5/distinfo
@@ -0,0 +1,3 @@
+MD5 (collectd-4.1.2.tar.gz) = 40458dabe8ec5df87323c1862a03cb94
+SHA256 (collectd-4.1.2.tar.gz) = fba4423378a8a270de8b48f98dc2f102f4f3c630381672267344776885a6e690
+SIZE (collectd-4.1.2.tar.gz) = 999229
diff --git a/net-mgmt/collectd5/pkg-descr b/net-mgmt/collectd5/pkg-descr
new file mode 100644
index 000000000000..b4c750a96be2
--- /dev/null
+++ b/net-mgmt/collectd5/pkg-descr
@@ -0,0 +1,6 @@
+collectd is a small daemon written in C for performance. It reads various
+system & network statistics along with updating output RRD or CSV files.
+The daemon is very fast and allows for frequent polling of values, with
+support for polling as frequent as every 10 seconds.
+
+WWW: http://www.collectd.org/
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
new file mode 100644
index 000000000000..373023f5430f
--- /dev/null
+++ b/net-mgmt/collectd5/pkg-plist
@@ -0,0 +1,52 @@
+bin/collectd-nagios
+etc/collectd.conf
+%%APACHE%%lib/collectd/apache.la
+%%APACHE%%lib/collectd/apache.so
+%%APCUPS%%lib/collectd/apcups.la
+%%APCUPS%%lib/collectd/apcups.so
+lib/collectd/cpu.la
+lib/collectd/cpu.so
+lib/collectd/csv.la
+lib/collectd/csv.so
+lib/collectd/df.la
+lib/collectd/df.so
+lib/collectd/dns.la
+lib/collectd/dns.so
+lib/collectd/email.la
+lib/collectd/email.so
+lib/collectd/exec.la
+lib/collectd/exec.so
+%%INTERFACE%%lib/collectd/interface.la
+%%INTERFACE%%lib/collectd/interface.so
+lib/collectd/load.la
+lib/collectd/load.so
+lib/collectd/logfile.la
+lib/collectd/logfile.so
+%%MBMON%%lib/collectd/mbmon.la
+%%MBMON%%lib/collectd/mbmon.so
+lib/collectd/memory.la
+lib/collectd/memory.so
+%%MYSQL%%lib/collectd/mysql.la
+%%MYSQL%%lib/collectd/mysql.so
+lib/collectd/network.la
+lib/collectd/network.so
+lib/collectd/ntpd.la
+lib/collectd/ntpd.so
+%%PING%%lib/collectd/ping.la
+%%PING%%lib/collectd/ping.so
+%%RRD%%lib/collectd/rrdtool.la
+%%RRD%%lib/collectd/rrdtool.so
+%%SNMP%%lib/collectd/snmp.la
+%%SNMP%%lib/collectd/snmp.so
+lib/collectd/swap.la
+lib/collectd/swap.so
+lib/collectd/syslog.la
+lib/collectd/syslog.so
+lib/collectd/types.db
+lib/collectd/unixsock.la
+lib/collectd/unixsock.so
+%%XMMS%%lib/collectd/xmms.la
+%%XMMS%%lib/collectd/xmms.so
+@dirrm lib/collectd
+sbin/collectd
+@dirrmtry var/lib/collectd