aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2011-07-04 11:59:48 +0800
committersahil <sahil@FreeBSD.org>2011-07-04 11:59:48 +0800
commitb160401d7ac5bc66417f6282186cd8fbd821f5f4 (patch)
treee8078790f6b699d1e5e8ade4d5d4059c84001c50 /net-mgmt
parentddbddf235998563e441f0e580ed91bc0dc6299bb (diff)
downloadfreebsd-ports-gnome-b160401d7ac5bc66417f6282186cd8fbd821f5f4.tar.gz
freebsd-ports-gnome-b160401d7ac5bc66417f6282186cd8fbd821f5f4.tar.zst
freebsd-ports-gnome-b160401d7ac5bc66417f6282186cd8fbd821f5f4.zip
Add option to build with libgcrypt.
PR: ports/156776 Submitted by: Brett Wynkoop <wynkoop@wynn.com> Approved by: maintainer timeout
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile6
-rw-r--r--net-mgmt/collectd5/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index a11522f9d088..d01df047174f 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -29,6 +29,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
CURL_XML "Input: CURL XML generic web statistics" Off \
DBI "Input: database abstraction library" Off \
DISK "Input: Disk performance statistics" Off \
+ GCRYPT "Build with libgcrypt" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
@@ -222,6 +223,11 @@ CONFIGURE_ARGS+=--disable-disk
PLIST_SUB+= DISK="@comment "
.endif
+.if defined(WITH_GCRYPT)
+CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
+LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index a11522f9d088..d01df047174f 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -29,6 +29,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
CURL_XML "Input: CURL XML generic web statistics" Off \
DBI "Input: database abstraction library" Off \
DISK "Input: Disk performance statistics" Off \
+ GCRYPT "Build with libgcrypt" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
@@ -222,6 +223,11 @@ CONFIGURE_ARGS+=--disable-disk
PLIST_SUB+= DISK="@comment "
.endif
+.if defined(WITH_GCRYPT)
+CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
+LIB_DEPENDS+= gcrypt.17:${PORTSDIR}/security/libgcrypt
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut