aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-02 02:56:56 +0800
committermarino <marino@FreeBSD.org>2015-03-02 02:56:56 +0800
commitbe3db1932c90ac26388dc16a3a9fb1029aa4f9ec (patch)
tree04b6521aca658d78615599f7a421cf78f9897fb9 /net-mgmt
parent71f8eb5334e59cd42fdce31b9c1f244c93b19ba8 (diff)
downloadfreebsd-ports-gnome-be3db1932c90ac26388dc16a3a9fb1029aa4f9ec.tar.gz
freebsd-ports-gnome-be3db1932c90ac26388dc16a3a9fb1029aa4f9ec.tar.zst
freebsd-ports-gnome-be3db1932c90ac26388dc16a3a9fb1029aa4f9ec.zip
net-mgmt/seafile-gui: Upgrade version 3.1.5 => 4.1.0
PR: 197984 Submitted by: maintainer (Jingfeng Yan)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/seafile-gui/Makefile10
-rw-r--r--net-mgmt/seafile-gui/distinfo4
-rw-r--r--net-mgmt/seafile-gui/files/patch-CMakeLists.txt47
3 files changed, 28 insertions, 33 deletions
diff --git a/net-mgmt/seafile-gui/Makefile b/net-mgmt/seafile-gui/Makefile
index 3b93a92325b0..22fd6785a293 100644
--- a/net-mgmt/seafile-gui/Makefile
+++ b/net-mgmt/seafile-gui/Makefile
@@ -1,8 +1,9 @@
# $FreeBSD$
PORTNAME= seafile-gui
-PORTVERSION= 3.1.5
+PORTVERSION= 4.1.0
CATEGORIES= net-mgmt
+DISTNAME= seafile-client-${PORTVERSION}
MAINTAINER= yan_jingfeng@yahoo.com
COMMENT= Seafile desktop client
@@ -19,8 +20,8 @@ LIB_DEPENDS+= libglib-2.0.so:${PORTSDIR}/devel/glib20 \
USE_GITHUB= yes
GH_ACCOUNT= haiwen
GH_PROJECT= seafile-client
-GH_TAGNAME= v3.1.5
-GH_COMMIT= ce808db
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 74817c4
USES= cmake pkgconfig
USE_QT4= corelib dbus gui network \
@@ -34,4 +35,7 @@ CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:PATH=include/glib-2.0
WITH_OPENSSL_PORT= yes
CMAKE_BUILD_TYPE= Release
+# Note that per PR 197984, cairo must be built with X11 and XCB options
+# otherwise configure fails with "cairo needs x11 enabled" message
+
.include <bsd.port.mk>
diff --git a/net-mgmt/seafile-gui/distinfo b/net-mgmt/seafile-gui/distinfo
index b1f2cb2f5b61..41b946709dd6 100644
--- a/net-mgmt/seafile-gui/distinfo
+++ b/net-mgmt/seafile-gui/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seafile-gui-3.1.5.tar.gz) = 81102eb267b8e3e507ddf78d5b019fd527f521e9cff1e2dd3dfcd41eec69e6ff
-SIZE (seafile-gui-3.1.5.tar.gz) = 763089
+SHA256 (seafile-client-4.1.0.tar.gz) = 7de5d09fa969c18a37d3f71ccafa82f7e678440616ce61819e245a98aded768d
+SIZE (seafile-client-4.1.0.tar.gz) = 1002057
diff --git a/net-mgmt/seafile-gui/files/patch-CMakeLists.txt b/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
index d2dae5decc8b..d54632166b6c 100644
--- a/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
+++ b/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
@@ -1,29 +1,20 @@
---- CMakeLists.txt.orig 2014-09-03 23:17:55.314282575 -0400
-+++ CMakeLists.txt 2014-09-03 23:19:48.914240566 -0400
-@@ -21,7 +21,7 @@
- IF (${CMAKE_BUILD_TYPE} MATCHES Release)
- SET(GUI_TYPE WIN32)
+--- CMakeLists.txt.orig 2015-01-28 22:35:49.000000000 -0500
++++ CMakeLists.txt 2015-01-28 22:42:26.000000000 -0500
+@@ -85,7 +85,7 @@
+ SET(USE_QT_LIBRARIES ${USE_QT_LIBRARIES} "WebKit" "WebKitWidgets")
+ ADD_DEFINITIONS(-DHAVE_SHIBBOLETH_SUPPORT)
ENDIF()
--ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-+ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|DragonFly|NetBSD|OpenBSD")
- INCLUDE_DIRECTORIES(${QT_QTDBUS_INCLUDE_DIR})
- LINK_DIRECTORIES(${QT_QTDBUS_LIBRARIES})
- SET(EXTRA_LIBS ${EXTRA_LIBS} ${QT_QTDBUS_LIBRARIES})
-@@ -42,7 +42,7 @@
- ####################
- ###### BEGIN: QT configuration
- ####################
--IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-+IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|DragonFly|NetBSD|OpenBSD")
- SET(QtDBus "QtDBus")
- ENDIF()
-
-@@ -380,7 +380,7 @@
- ${EXTRA_LIBS}
- )
-
--IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-+IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|DragonFly|NetBSD|OpenBSD")
- TARGET_LINK_LIBRARIES(seafile-applet
- ${QT_QTDBUS_LIBRARIES}
- )
+- IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
++ IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
+ SET(USE_QT_LIBRARIES ${USE_QT_LIBRARIES} "DBus")
+ ENDIF()
+ FIND_PACKAGE(Qt5 REQUIRED ${USE_QT_LIBRARIES})
+@@ -100,7 +100,7 @@
+ SET(QtWebKit "QtWebKit")
+ ADD_DEFINITIONS(-DHAVE_SHIBBOLETH_SUPPORT)
+ ENDIF()
+- IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
++ IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
+ SET(QtDBus "QtDBus")
+ ENDIF()
+ FIND_PACKAGE(Qt4 REQUIRED QtCore QtGui QtNetwork ${QtDBus} ${QtWebKit})