aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 02:19:23 +0800
committermarino <marino@FreeBSD.org>2015-03-25 02:19:23 +0800
commitc671b7499c21f0b5d1b3b76b64de4a06c8414dcc (patch)
treed22ee47f309af4f98bfeb96fd87674677e46b434 /net-mgmt
parent581716bd366fcb585a3ced95a32b9b5d017bb1cf (diff)
downloadfreebsd-ports-gnome-c671b7499c21f0b5d1b3b76b64de4a06c8414dcc.tar.gz
freebsd-ports-gnome-c671b7499c21f0b5d1b3b76b64de4a06c8414dcc.tar.zst
freebsd-ports-gnome-c671b7499c21f0b5d1b3b76b64de4a06c8414dcc.zip
4 ports categories: Remove $PTHREAD_LIBS
Categories: www, ftp, net-im, net-mgmt approved by: PTHREAD blanket
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/aircrack-ng/Makefile3
-rw-r--r--net-mgmt/driftnet/Makefile2
-rw-r--r--net-mgmt/driftnet/files/patch-Makefile13
-rw-r--r--net-mgmt/fprobe/Makefile3
-rw-r--r--net-mgmt/iftop/Makefile4
-rw-r--r--net-mgmt/ipcad/Makefile4
6 files changed, 8 insertions, 21 deletions
diff --git a/net-mgmt/aircrack-ng/Makefile b/net-mgmt/aircrack-ng/Makefile
index ed42b9e97b6d..20f2ab73c49d 100644
--- a/net-mgmt/aircrack-ng/Makefile
+++ b/net-mgmt/aircrack-ng/Makefile
@@ -50,9 +50,6 @@ post-patch:
@${REINPLACE_CMD} \
-E 's/air(driver|mon)-ng\.1 //' \
${WRKSRC}/manpages/Makefile
- @${REINPLACE_CMD} \
- -e 's|-lpthread|${PTHREAD_LIBS}|' \
- ${WRKSRC}/src/Makefile
post-install:
@${STRIP_CMD} ${BIN_FILES:S,^,${STAGEDIR}${PREFIX}/bin/,} \
diff --git a/net-mgmt/driftnet/Makefile b/net-mgmt/driftnet/Makefile
index 9faf47d3aaa8..0ed4c5fe39c5 100644
--- a/net-mgmt/driftnet/Makefile
+++ b/net-mgmt/driftnet/Makefile
@@ -22,8 +22,6 @@ USE_GNOME= gtk12
USES= gmake
ALL_TARGET= default
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-
PLIST_FILES= bin/driftnet man/man1/driftnet.1.gz
do-install:
diff --git a/net-mgmt/driftnet/files/patch-Makefile b/net-mgmt/driftnet/files/patch-Makefile
index fefd985d3e20..bdcae0ef83e4 100644
--- a/net-mgmt/driftnet/files/patch-Makefile
+++ b/net-mgmt/driftnet/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Jul 9 12:26:41 2002
-+++ Makefile Sat Sep 28 22:19:21 2002
+--- Makefile.orig 2002-07-09 19:26:41 UTC
++++ Makefile
@@ -16,23 +16,23 @@
#CC = gcc
@@ -19,19 +19,18 @@
+#CFLAGS += -D_BSD_SOURCE
# We always need the pcap and pthread libraries.
--LDLIBS += -lpcap -lpthread
-+LDLIBS += -lpcap ${PTHREAD_LIBS}
+ LDLIBS += -lpcap -lpthread
# Optional C compiler and linker flags. Typical driftnet builds have support
# for displaying captured images in an X window, and need the following flags:
-CFLAGS += `gtk-config --cflags`
-LDLIBS += -ljpeg -lungif `gtk-config --libs`
-+CFLAGS += ${PTHREAD_CFLAGS} `${GTK_CONFIG} --cflags`
++CFLAGS += `${GTK_CONFIG} --cflags`
+LDLIBS += -ljpeg -lgif `${GTK_CONFIG} --libs`
# Alternatively, you can build a version of driftnet which can only be used
# in `adjunct' mode as the back end for some other image-processing program. To
-@@ -43,7 +43,7 @@
+@@ -43,7 +43,7 @@ LDLIBS += -ljpeg -lungif `gtk-config --
# On systems with a C99 compiler, driftnet will use <stdint.h> for the
# definitions of types such as uint8_t. On other systems like Solaris, these
# are in <sys/types.h>, and you should uncomment this line.
@@ -40,7 +39,7 @@
# On Solaris, it is necessary to link against -lposix4 for the definition of
# nanosleep; uncomment the below.
-@@ -51,7 +51,7 @@
+@@ -51,7 +51,7 @@ LDLIBS += -ljpeg -lungif `gtk-config --
# added 20020604 edobbs
# On BSD systems, may need to use /usr/local/include
diff --git a/net-mgmt/fprobe/Makefile b/net-mgmt/fprobe/Makefile
index 39680b3a67a4..b8c5dc20f78d 100644
--- a/net-mgmt/fprobe/Makefile
+++ b/net-mgmt/fprobe/Makefile
@@ -19,9 +19,6 @@ PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS
-post-patch:
- ${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ChangeLog README
diff --git a/net-mgmt/iftop/Makefile b/net-mgmt/iftop/Makefile
index 18b2dd7f08a8..09b676cd3843 100644
--- a/net-mgmt/iftop/Makefile
+++ b/net-mgmt/iftop/Makefile
@@ -16,10 +16,6 @@ GNU_CONFIGURE= yes
PORTDOCS= README
PLIST_FILES= sbin/iftop man/man8/iftop.8.gz
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
diff --git a/net-mgmt/ipcad/Makefile b/net-mgmt/ipcad/Makefile
index 87ded8b819cc..7a98a7ee4553 100644
--- a/net-mgmt/ipcad/Makefile
+++ b/net-mgmt/ipcad/Makefile
@@ -17,8 +17,8 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|/usr/local|${PREFIX}|g; s|pthread_detach|pthread_create|g'\
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
+ s|pthread_detach|pthread_create|g'\
${WRKSRC}/configure
post-install: