aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-14 19:38:53 +0800
committermiwi <miwi@FreeBSD.org>2006-12-14 19:38:53 +0800
commitd9b3472579205b58180f5cf3d6889e665ec57baf (patch)
tree161b31f60e8b3f23ccf9a964bc519688f172acd9 /net-mgmt
parent5d223b84f307b0e3ef999c53a51a35d5a112db71 (diff)
downloadfreebsd-ports-gnome-d9b3472579205b58180f5cf3d6889e665ec57baf.tar.gz
freebsd-ports-gnome-d9b3472579205b58180f5cf3d6889e665ec57baf.tar.zst
freebsd-ports-gnome-d9b3472579205b58180f5cf3d6889e665ec57baf.zip
A set of open source tools for accessing the 2.4GHz Wi-Spy USB
spectrum analyzer by Metageek LLC, http://www.metageek.net/ WWW: http://www.kismetwireless.net/wispy.shtml PR: ports/106667 Submitted by: Henrik Brix Andersen <henrik at brixandersen.dk>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/spectools/Makefile64
-rw-r--r--net-mgmt/spectools/distinfo3
-rw-r--r--net-mgmt/spectools/files/patch-configure22
-rw-r--r--net-mgmt/spectools/pkg-descr4
-rw-r--r--net-mgmt/spectools/pkg-message4
-rw-r--r--net-mgmt/spectools/pkg-plist4
-rw-r--r--net-mgmt/wispy-tools/Makefile64
-rw-r--r--net-mgmt/wispy-tools/distinfo3
-rw-r--r--net-mgmt/wispy-tools/files/patch-configure22
-rw-r--r--net-mgmt/wispy-tools/pkg-descr4
-rw-r--r--net-mgmt/wispy-tools/pkg-message4
-rw-r--r--net-mgmt/wispy-tools/pkg-plist4
13 files changed, 203 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index df64716a7d76..4cfd3af526e5 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -209,6 +209,7 @@
SUBDIR += weplab
SUBDIR += whatmask
SUBDIR += wide-dhcp
+ SUBDIR += wispy-tools
SUBDIR += yabm
SUBDIR += zabbix
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
new file mode 100644
index 000000000000..000996285e8a
--- /dev/null
+++ b/net-mgmt/spectools/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: wispy-tools
+# Date created: 13 Dec 2006
+# Whom: Henrik Brix Andersen <henrik@brixandersen.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wispy-tools
+PORTVERSION= 200609.r1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.kismetwireless.net/code/
+DISTNAME= wispy-tools-2006-09-R1
+
+MAINTAINER= henrik@brixandersen.dk
+COMMENT= Tools for the 2.4GHz Wi-Spy spectrum analyzer from MetaGeek LLC
+
+LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+PORTDOCS= README
+
+OPTIONS= GTK "Enable graphical client" On
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 602101
+IGNORE= is unsupported on systems prior to FreeBSD v602101
+.elif ${OSVERSION} > 700000 && ${OSVERSION} < 700027
+IGNORE= is unsupported on systems prior to FreeBSD v700027
+.endif
+
+.if defined(WITH_GTK)
+LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
+PLIST_SUB= WITH_GTK=""
+.else
+PLIST_SUB= WITH_GTK="@comment "
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${GMAKE} wispy_curses wispy_log wispy_raw
+.if defined(WITH_GTK)
+ cd ${WRKSRC} && ${GMAKE} wispy_gtk
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_curses ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_log ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_raw ${PREFIX}/bin
+.if defined(WITH_GTK)
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_gtk ${PREFIX}/bin
+.endif
+
+post-install:
+.ifndef(NOPORTDOC)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/spectools/distinfo b/net-mgmt/spectools/distinfo
new file mode 100644
index 000000000000..2a41efceaac6
--- /dev/null
+++ b/net-mgmt/spectools/distinfo
@@ -0,0 +1,3 @@
+MD5 (wispy-tools-2006-09-R1.tar.gz) = c05a18813bca976450262f7b0e98b0cb
+SHA256 (wispy-tools-2006-09-R1.tar.gz) = 41b25d1d63f01f596925dbd39389668b9d4169b28e5b8a2e00e0ac66574d330f
+SIZE (wispy-tools-2006-09-R1.tar.gz) = 135474
diff --git a/net-mgmt/spectools/files/patch-configure b/net-mgmt/spectools/files/patch-configure
new file mode 100644
index 000000000000..41b13addb85b
--- /dev/null
+++ b/net-mgmt/spectools/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.in.orig Sun Nov 19 18:04:52 2006
++++ configure.in Sun Nov 19 18:01:44 2006
+@@ -204,7 +204,7 @@
+ GTKLIBS="$LIBS"
+ LIBS="$olfl"
+
+- if test "$GTK2" == "yes"; then
++ if test "$GTK2" = "yes"; then
+ AC_DEFINE(HAVE_LIB_GTK2, 1, we have libgtk2.x)
+ else
+ AC_MSG_WARN(*** GTK1 being used. GTK2 is preferred and GTK1 support may vanish in future releases ***)
+--- configure.orig Sun Nov 19 18:04:45 2006
++++ configure Sun Nov 19 18:01:18 2006
+@@ -4185,7 +4185,7 @@
+ GTKLIBS="$LIBS"
+ LIBS="$olfl"
+
+- if test "$GTK2" == "yes"; then
++ if test "$GTK2" = "yes"; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_LIB_GTK2 1
diff --git a/net-mgmt/spectools/pkg-descr b/net-mgmt/spectools/pkg-descr
new file mode 100644
index 000000000000..f4e1f0be4855
--- /dev/null
+++ b/net-mgmt/spectools/pkg-descr
@@ -0,0 +1,4 @@
+A set of open source tools for accessing the 2.4GHz Wi-Spy USB
+spectrum analyzer by Metageek LLC, http://www.metageek.net/
+
+WWW: http://www.kismetwireless.net/wispy.shtml
diff --git a/net-mgmt/spectools/pkg-message b/net-mgmt/spectools/pkg-message
new file mode 100644
index 000000000000..37cc221c0389
--- /dev/null
+++ b/net-mgmt/spectools/pkg-message
@@ -0,0 +1,4 @@
+====
+In order to use the tools you need read/write access to the ugen(4)
+device node corresponding to your your Wi-Spy device.
+====
diff --git a/net-mgmt/spectools/pkg-plist b/net-mgmt/spectools/pkg-plist
new file mode 100644
index 000000000000..4d80d344346b
--- /dev/null
+++ b/net-mgmt/spectools/pkg-plist
@@ -0,0 +1,4 @@
+bin/wispy_curses
+%%WITH_GTK%%bin/wispy_gtk
+bin/wispy_log
+bin/wispy_raw
diff --git a/net-mgmt/wispy-tools/Makefile b/net-mgmt/wispy-tools/Makefile
new file mode 100644
index 000000000000..000996285e8a
--- /dev/null
+++ b/net-mgmt/wispy-tools/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: wispy-tools
+# Date created: 13 Dec 2006
+# Whom: Henrik Brix Andersen <henrik@brixandersen.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wispy-tools
+PORTVERSION= 200609.r1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.kismetwireless.net/code/
+DISTNAME= wispy-tools-2006-09-R1
+
+MAINTAINER= henrik@brixandersen.dk
+COMMENT= Tools for the 2.4GHz Wi-Spy spectrum analyzer from MetaGeek LLC
+
+LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+PORTDOCS= README
+
+OPTIONS= GTK "Enable graphical client" On
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 602101
+IGNORE= is unsupported on systems prior to FreeBSD v602101
+.elif ${OSVERSION} > 700000 && ${OSVERSION} < 700027
+IGNORE= is unsupported on systems prior to FreeBSD v700027
+.endif
+
+.if defined(WITH_GTK)
+LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
+PLIST_SUB= WITH_GTK=""
+.else
+PLIST_SUB= WITH_GTK="@comment "
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${GMAKE} wispy_curses wispy_log wispy_raw
+.if defined(WITH_GTK)
+ cd ${WRKSRC} && ${GMAKE} wispy_gtk
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_curses ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_log ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_raw ${PREFIX}/bin
+.if defined(WITH_GTK)
+ ${INSTALL_PROGRAM} ${WRKSRC}/wispy_gtk ${PREFIX}/bin
+.endif
+
+post-install:
+.ifndef(NOPORTDOC)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/wispy-tools/distinfo b/net-mgmt/wispy-tools/distinfo
new file mode 100644
index 000000000000..2a41efceaac6
--- /dev/null
+++ b/net-mgmt/wispy-tools/distinfo
@@ -0,0 +1,3 @@
+MD5 (wispy-tools-2006-09-R1.tar.gz) = c05a18813bca976450262f7b0e98b0cb
+SHA256 (wispy-tools-2006-09-R1.tar.gz) = 41b25d1d63f01f596925dbd39389668b9d4169b28e5b8a2e00e0ac66574d330f
+SIZE (wispy-tools-2006-09-R1.tar.gz) = 135474
diff --git a/net-mgmt/wispy-tools/files/patch-configure b/net-mgmt/wispy-tools/files/patch-configure
new file mode 100644
index 000000000000..41b13addb85b
--- /dev/null
+++ b/net-mgmt/wispy-tools/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.in.orig Sun Nov 19 18:04:52 2006
++++ configure.in Sun Nov 19 18:01:44 2006
+@@ -204,7 +204,7 @@
+ GTKLIBS="$LIBS"
+ LIBS="$olfl"
+
+- if test "$GTK2" == "yes"; then
++ if test "$GTK2" = "yes"; then
+ AC_DEFINE(HAVE_LIB_GTK2, 1, we have libgtk2.x)
+ else
+ AC_MSG_WARN(*** GTK1 being used. GTK2 is preferred and GTK1 support may vanish in future releases ***)
+--- configure.orig Sun Nov 19 18:04:45 2006
++++ configure Sun Nov 19 18:01:18 2006
+@@ -4185,7 +4185,7 @@
+ GTKLIBS="$LIBS"
+ LIBS="$olfl"
+
+- if test "$GTK2" == "yes"; then
++ if test "$GTK2" = "yes"; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_LIB_GTK2 1
diff --git a/net-mgmt/wispy-tools/pkg-descr b/net-mgmt/wispy-tools/pkg-descr
new file mode 100644
index 000000000000..f4e1f0be4855
--- /dev/null
+++ b/net-mgmt/wispy-tools/pkg-descr
@@ -0,0 +1,4 @@
+A set of open source tools for accessing the 2.4GHz Wi-Spy USB
+spectrum analyzer by Metageek LLC, http://www.metageek.net/
+
+WWW: http://www.kismetwireless.net/wispy.shtml
diff --git a/net-mgmt/wispy-tools/pkg-message b/net-mgmt/wispy-tools/pkg-message
new file mode 100644
index 000000000000..37cc221c0389
--- /dev/null
+++ b/net-mgmt/wispy-tools/pkg-message
@@ -0,0 +1,4 @@
+====
+In order to use the tools you need read/write access to the ugen(4)
+device node corresponding to your your Wi-Spy device.
+====
diff --git a/net-mgmt/wispy-tools/pkg-plist b/net-mgmt/wispy-tools/pkg-plist
new file mode 100644
index 000000000000..4d80d344346b
--- /dev/null
+++ b/net-mgmt/wispy-tools/pkg-plist
@@ -0,0 +1,4 @@
+bin/wispy_curses
+%%WITH_GTK%%bin/wispy_gtk
+bin/wispy_log
+bin/wispy_raw