aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-10-31 03:33:00 +0800
committercrees <crees@FreeBSD.org>2011-10-31 03:33:00 +0800
commite41a7f688d3f318838be880ef1484177d0ce06f2 (patch)
tree786ea3a2cf51f95d14daba7e86a3a4586f1a8c48 /net-mgmt
parent572bc632a02f8e3a1f2806d1f74183581a0e4b54 (diff)
downloadfreebsd-ports-gnome-e41a7f688d3f318838be880ef1484177d0ce06f2.tar.gz
freebsd-ports-gnome-e41a7f688d3f318838be880ef1484177d0ce06f2.tar.zst
freebsd-ports-gnome-e41a7f688d3f318838be880ef1484177d0ce06f2.zip
DellMonitor provides custom modeling of devices running the Dell OpenManage
agents. It also contains hardware identification for Dell proprietary hardware. The information is collected through the SNMP interface. The following information is modeled. Hardware Model Hardware Serial Number Operating System CPU Information (socket, speed, cache, voltage) PCI Card Information (manufacturer, model) WWW: http://community.zenoss.org/docs/DOC-3492 PR: ports/157135 Submitted by: Zenoss <zenoss@experts-exchange.com>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/zenpack-dellmonitor/Makefile23
-rw-r--r--net-mgmt/zenpack-dellmonitor/distinfo2
-rw-r--r--net-mgmt/zenpack-dellmonitor/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-dellmonitor/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-dellmonitor/pkg-descr12
-rw-r--r--net-mgmt/zenpack-dellmonitor/pkg-plist2
7 files changed, 55 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index dad2854a5f33..9dd8a031a43f 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -300,6 +300,7 @@
SUBDIR += zenpack-apachemonitor
SUBDIR += zenpack-checkping
SUBDIR += zenpack-dellmon
+ SUBDIR += zenpack-dellmonitor
SUBDIR += zenpack-deviceadvdetail
SUBDIR += zenpack-devicesearch
SUBDIR += zenpack-graphportlet
diff --git a/net-mgmt/zenpack-dellmonitor/Makefile b/net-mgmt/zenpack-dellmonitor/Makefile
new file mode 100644
index 000000000000..6e93e6171a24
--- /dev/null
+++ b/net-mgmt/zenpack-dellmonitor/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: DellMonitor
+# Date created: 05 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DellMonitor
+PORTVERSION= 2.1.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://dev.zenoss.org/trac/changeset/26194/tags/zenoss-3.1.0/zenpacks/
+DISTFILES= ${ZPACKPREFIX}${PORTNAME}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Provides Zenoss monitoring options for Dell machines
+
+USE_ZIP= yes
+ZPACKGROUP= core
+WRKSRC= ${WRKDIR}/tags/zenoss-3.1.0/zenpacks/${ZPACKPREFIX}${PORTNAME}/
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-dellmonitor/distinfo b/net-mgmt/zenpack-dellmonitor/distinfo
new file mode 100644
index 000000000000..1b3dd9ae90c4
--- /dev/null
+++ b/net-mgmt/zenpack-dellmonitor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ZenPacks.zenoss.DellMonitor?old_path=%2F&format=zip) = 9e613becb673a748875abacf0f79ee1cd81aec852fc5448be103606117f13b5f
+SIZE (ZenPacks.zenoss.DellMonitor?old_path=%2F&format=zip) = 10638
diff --git a/net-mgmt/zenpack-dellmonitor/files/pkg-deinstall.in b/net-mgmt/zenpack-dellmonitor/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-dellmonitor/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-dellmonitor/files/pkg-message.in b/net-mgmt/zenpack-dellmonitor/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-dellmonitor/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-dellmonitor/pkg-descr b/net-mgmt/zenpack-dellmonitor/pkg-descr
new file mode 100644
index 000000000000..dca9b3a394e8
--- /dev/null
+++ b/net-mgmt/zenpack-dellmonitor/pkg-descr
@@ -0,0 +1,12 @@
+DellMonitor provides custom modeling of devices running the Dell OpenManage
+agents. It also contains hardware identification for Dell proprietary hardware.
+The information is collected through the SNMP interface.
+
+The following information is modeled.
+Hardware Model
+Hardware Serial Number
+Operating System
+CPU Information (socket, speed, cache, voltage)
+PCI Card Information (manufacturer, model)
+
+WWW: http://community.zenoss.org/docs/DOC-3492
diff --git a/net-mgmt/zenpack-dellmonitor/pkg-plist b/net-mgmt/zenpack-dellmonitor/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-dellmonitor/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack