aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-12-14 21:08:08 +0800
committerscheidell <scheidell@FreeBSD.org>2011-12-14 21:08:08 +0800
commit21370c4851f68b5a1e60fdda0fa4399690b007ee (patch)
tree1beb4f6ad786cee35012be035e9c854466fb416d /net-mgmt
parent88105fbea42041b5494ce9e41f5e3a8e5a2693d3 (diff)
downloadfreebsd-ports-gnome-21370c4851f68b5a1e60fdda0fa4399690b007ee.tar.gz
freebsd-ports-gnome-21370c4851f68b5a1e60fdda0fa4399690b007ee.tar.zst
freebsd-ports-gnome-21370c4851f68b5a1e60fdda0fa4399690b007ee.zip
- re-integration which enables the option of building the python bindings [1]
- with the addition of a options knob (off by default) - No portsbump so that its a 'noop' for systems that don't need python bindings PR: ports/162140 Submitted by: Geoffrey Huntley <ghuntley@ghuntley.com> [1] Approved by: zi (maintainer timeout, 30 days), gabor (mentor)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 9f918f9ed5d7..85d80fb4580b 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -23,7 +23,8 @@ OPTIONS= IPV6 "Build with IPv6 support" on \
DUMMY "Enable dummy values as placeholders" on \
TKMIB "Install graphical MIB browser" off \
DMALLOC "Enable dmalloc debug memory allocator" off \
- UNPRIVILEGED "Allow unprivileged users to execute net-snmp" off
+ UNPRIVILEGED "Allow unprivileged users to execute net-snmp" off \
+ PYTHON "Install python bindings off
MAKE_JOBS_UNSAFE= yes
@@ -46,6 +47,12 @@ CONFIGURE_ARGS+=--enable-shared --enable-internal-md5 \
CONFIGURE_ARGS+=--with-defaults
.endif
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+= --with-python-modules
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+.endif
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --with-openssl="${OPENSSLBASE}"