aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-09-30 18:59:11 +0800
committertcberner <tcberner@FreeBSD.org>2017-09-30 18:59:11 +0800
commitfd70ab16740501df0f8652715824891807d7b790 (patch)
tree3b745866379db539469641609bcb8d51e7e17c62 /net-mgmt
parent6f5a1bc44c85c5b1cb06a5d2884ebfe04cb69a1a (diff)
downloadfreebsd-ports-gnome-fd70ab16740501df0f8652715824891807d7b790.tar.gz
freebsd-ports-gnome-fd70ab16740501df0f8652715824891807d7b790.tar.zst
freebsd-ports-gnome-fd70ab16740501df0f8652715824891807d7b790.zip
New port: net-mgmt/py-msrest: AutoRest swagger generator Python client runtime
PR: 222210 Submitted by: xmj
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-msrest/Makefile29
-rw-r--r--net-mgmt/py-msrest/distinfo3
-rw-r--r--net-mgmt/py-msrest/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index a833a832e0ce..abb025cfc98b 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -297,6 +297,7 @@
SUBDIR += py-adal
SUBDIR += py-ipcalc
SUBDIR += py-ipy
+ SUBDIR += py-msrest
SUBDIR += py-pdagent
SUBDIR += py-pyang
SUBDIR += py-pysmi
diff --git a/net-mgmt/py-msrest/Makefile b/net-mgmt/py-msrest/Makefile
new file mode 100644
index 000000000000..4fcabda91c0f
--- /dev/null
+++ b/net-mgmt/py-msrest/Makefile
@@ -0,0 +1,29 @@
+# Created by: Johannes Jost Meixner <johannes@perceivon.net>
+# $FreeBSD$
+
+PORTNAME= msrest
+PORTVERSION= 0.4.14
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= johannes@perceivon.net
+COMMENT= AutoRest swagger generator Python client runtime
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi \
+ ${PYTHON_PKGNAMEPREFIX}isodate>=0.5.4:devel/py-isodate \
+ ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>0:www/py-requests-oauthlib \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/py-msrest/distinfo b/net-mgmt/py-msrest/distinfo
new file mode 100644
index 000000000000..c337a2d0eebc
--- /dev/null
+++ b/net-mgmt/py-msrest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505102734
+SHA256 (msrest-0.4.14.tar.gz) = 97654345a93a140f6e825f2a648de3100b5ff90880f7668df82d825b2de148ec
+SIZE (msrest-0.4.14.tar.gz) = 26459
diff --git a/net-mgmt/py-msrest/pkg-descr b/net-mgmt/py-msrest/pkg-descr
new file mode 100644
index 000000000000..4e3330032433
--- /dev/null
+++ b/net-mgmt/py-msrest/pkg-descr
@@ -0,0 +1,3 @@
+AutoRest swagger generator Python client runtime.
+
+WWW: https://pypi.python.org/pypi/msrest