aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
committermat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
commit0691688a506fc2dffc574eeeb80dc0d876378fed (patch)
tree204c01c7973e83331fc29d8b09e59b3e9f219bd6 /net-mgmt
parent33639ffbb666f12097ddeff5ef7da2226febf15b (diff)
downloadfreebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.gz
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.zst
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.zip
Remove OSVERSION checks that do not make sense any more.
For example (${OSVERSION} >= 900000 && ${OSVERSION} < 900021) is always true, as is (${OSVERSION} > 900002 || ${OSVERSION} < 900000 && ${OSVERSION} > 800107). Regarding patches, when an EXTRA_PATCHES is no longer needed, I remove it, when it is always needed, I renamed it, in one case, I merged two patches. Differential Revision: https://reviews.freebsd.org/D2209
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile11
-rw-r--r--net-mgmt/py-yapsnmp/Makefile2
2 files changed, 3 insertions, 10 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index c96468c7e272..f4bfbd45f10c 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -51,6 +51,7 @@ CONFIGURE_ARGS+=--enable-shared --enable-internal-md5 \
--with-logfile="${NET_SNMP_LOGFILE}" \
--with-persistent-directory="${NET_SNMP_PERSISTENTDIR}" \
--with-gnu-ld --with-libwrap \
+ --with-libs="-lssp_nonshared" \
--with-ldflags="-lm -lkvm -ldevstat -L${PKG_PREFIX}/lib -L${LOCALBASE}/lib ${LCRYPTO}"
SUB_FILES= pkg-message
@@ -145,15 +146,7 @@ NET_SNMP_SYS_CONTACT?= nobody@nowhere.invalid
NET_SNMP_SYS_LOCATION?= somewhere
NET_SNMP_LOGFILE?= /var/log/snmpd.log
NET_SNMP_PERSISTENTDIR?=/var/net-snmp
-NET_SNMP_WITH_MIB_MODULE_LIST+= host disman/event-mib mibII/mta_sendmail mibII/tcpTable ucd-snmp/diskio
-
-.if ${OSVERSION} >= 700028
-NET_SNMP_WITH_MIB_MODULE_LIST+= sctp-mib
-.endif
-
-.if ${OSVERSION} >= 800000
-CONFIGURE_ARGS+= --with-libs="-lssp_nonshared"
-.endif
+NET_SNMP_WITH_MIB_MODULE_LIST+= host disman/event-mib mibII/mta_sendmail mibII/tcpTable ucd-snmp/diskio sctp-mib
.if ${OSVERSION} >= 1000000 && ${OSVERSION} < 1100062
CFLAGS+= -D_WANT_IFADDR
diff --git a/net-mgmt/py-yapsnmp/Makefile b/net-mgmt/py-yapsnmp/Makefile
index 2f74da463fbb..427a942a52cc 100644
--- a/net-mgmt/py-yapsnmp/Makefile
+++ b/net-mgmt/py-yapsnmp/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+=--enable-site-packages-prefix=${PREFIX}
.include <bsd.port.pre.mk>
-.if (${OSVERSION} >= 800000) && (${ARCH} == "i386")
+.if (${ARCH} == "i386")
CPPFLAGS+= -fstack-protector -I${LOCALBASE}/include
.endif