aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-07-19 23:18:55 +0800
committermmokhi <mmokhi@FreeBSD.org>2017-07-19 23:18:55 +0800
commit0c5b2c12b32bb573f8a5116cf7adf05257bc9b90 (patch)
tree7e32e047e950834671c318a54b3c298488ecf4b7 /net-mgmt
parentce99520296310169fcc2a05a977d548d35164906 (diff)
downloadfreebsd-ports-gnome-0c5b2c12b32bb573f8a5116cf7adf05257bc9b90.tar.gz
freebsd-ports-gnome-0c5b2c12b32bb573f8a5116cf7adf05257bc9b90.tar.zst
freebsd-ports-gnome-0c5b2c12b32bb573f8a5116cf7adf05257bc9b90.zip
net-mgmt/netdata: Unbreak for post-ino64 12-CURRENT
Reported by: lme Reviewed by: mat (mentor) Approved by: mat (mentor) Sponsored by: Netzkommune GmbH Differential Revision: https://reviews.freebsd.org/D11648
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/netdata/Makefile2
-rw-r--r--net-mgmt/netdata/files/patch-src_apps__plugin.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/net-mgmt/netdata/Makefile b/net-mgmt/netdata/Makefile
index 0697cfce25b2..2856103038a6 100644
--- a/net-mgmt/netdata/Makefile
+++ b/net-mgmt/netdata/Makefile
@@ -25,7 +25,7 @@ USES= autoreconf pathfix pkgconfig:both python shebangfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -D_WANT_VMMETER -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/net-mgmt/netdata/files/patch-src_apps__plugin.c b/net-mgmt/netdata/files/patch-src_apps__plugin.c
new file mode 100644
index 000000000000..f78401eb2b18
--- /dev/null
+++ b/net-mgmt/netdata/files/patch-src_apps__plugin.c
@@ -0,0 +1,17 @@
+--- src/apps_plugin.c.orig 2017-07-18 22:52:41 UTC
++++ src/apps_plugin.c
+@@ -1572,7 +1572,13 @@ static inline int read_pid_file_descript
+ break;
+ default:
+ /* print protocol number and socket address */
+- sprintf(fdsname, "socket: other: %d %s %s", fds->kf_sock_protocol, fds->kf_sa_local.__ss_pad1, fds->kf_sa_local.__ss_pad2);
++ sprintf(fdsname, "socket: other: %d %s %s", fds->kf_sock_protocol,
++ #if defined(__FreeBSD__) && (__FreeBSD_version >= 1200031)
++ fds->kf_un.kf_sock.kf_sa_local.__ss_pad1, fds->kf_un.kf_sock.kf_sa_local.__ss_pad2
++ #else
++ fds->kf_sa_local.__ss_pad1, fds->kf_sa_local.__ss_pad2
++ #endif
++ );
+ }
+ break;
+ case KF_TYPE_PIPE: