aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-04-04 17:07:31 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-04-04 17:07:31 +0800
commit0e09b498d8fcd09558e5baab96312f01dbc70324 (patch)
treeb604e51b46521a43703d3807b2441f867b091f11 /net-mgmt
parentef8475506859499cda4b97b17bdfdd53e48627d9 (diff)
downloadfreebsd-ports-gnome-0e09b498d8fcd09558e5baab96312f01dbc70324.tar.gz
freebsd-ports-gnome-0e09b498d8fcd09558e5baab96312f01dbc70324.tar.zst
freebsd-ports-gnome-0e09b498d8fcd09558e5baab96312f01dbc70324.zip
- Support staging
- Use shebangfix - Use WWW: with a single space
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-certexp-plugin/Makefile13
-rw-r--r--net-mgmt/nagios-certexp-plugin/pkg-descr2
2 files changed, 8 insertions, 7 deletions
diff --git a/net-mgmt/nagios-certexp-plugin/Makefile b/net-mgmt/nagios-certexp-plugin/Makefile
index 0eb5f34c6836..9ed763b45623 100644
--- a/net-mgmt/nagios-certexp-plugin/Makefile
+++ b/net-mgmt/nagios-certexp-plugin/Makefile
@@ -15,18 +15,19 @@ RUN_DEPENDS+= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
-USES= perl5
+USES= perl5 shebangfix
NO_WRKSUBDIR= yes
NO_BUILD= yes
+
+SHEBANG_FILES= check_certexp.pl
PLIST_FILES= ${NAGIOS_PLUGIN_DIR}/check_certexp.pl
PLIST_DIRS= ${NAGIOS_PLUGIN_DIR}
NAGIOS_PLUGIN_DIR= libexec/nagios
-NO_STAGE= yes
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/check_certexp.pl
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/check_certexp.pl
post-patch:
${REINPLACE_CMD} -e \
@@ -34,7 +35,7 @@ post-patch:
${WRKSRC}/check_certexp.pl
do-install:
- ${MKDIR} ${PREFIX}/${NAGIOS_PLUGIN_DIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/check_certexp.pl ${PREFIX}/${NAGIOS_PLUGIN_DIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${NAGIOS_PLUGIN_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_certexp.pl ${STAGEDIR}${PREFIX}/${NAGIOS_PLUGIN_DIR}
.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-certexp-plugin/pkg-descr b/net-mgmt/nagios-certexp-plugin/pkg-descr
index 01a6b0208d38..f5a9a9bae2f6 100644
--- a/net-mgmt/nagios-certexp-plugin/pkg-descr
+++ b/net-mgmt/nagios-certexp-plugin/pkg-descr
@@ -5,4 +5,4 @@ the embedded Perl interpreter (not tested though) and requires Net::SSLeay and
Date::Manip to be installed on the Nagios host.
Author: Holger Weiss <holger@CIS.FU-Berlin.DE>
-WWW: http://www.jhweiss.de/software/nagios.html
+WWW: http://www.jhweiss.de/software/nagios.html