aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-21 19:45:45 +0800
committermiwi <miwi@FreeBSD.org>2009-10-21 19:45:45 +0800
commit129fa5dbe5f54aff23e5e754d69269d294aec79d (patch)
tree7f6220e17cc6a2698d2251f6e457e37cabfd1573 /net-mgmt
parent0474ac6c55e42dc19725ca24df24a2af58b5a01f (diff)
downloadfreebsd-ports-gnome-129fa5dbe5f54aff23e5e754d69269d294aec79d.tar.gz
freebsd-ports-gnome-129fa5dbe5f54aff23e5e754d69269d294aec79d.tar.zst
freebsd-ports-gnome-129fa5dbe5f54aff23e5e754d69269d294aec79d.zip
coovachilli attempts to use route to display routing information,
this patch changes the functions file so that it uses netstat instead. PR: 139546 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk> (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/coovachilli/Makefile1
-rw-r--r--net-mgmt/coovachilli/files/patch-conf_functions.in13
2 files changed, 12 insertions, 2 deletions
diff --git a/net-mgmt/coovachilli/Makefile b/net-mgmt/coovachilli/Makefile
index 5ba2739445e8..45dd0b6044db 100644
--- a/net-mgmt/coovachilli/Makefile
+++ b/net-mgmt/coovachilli/Makefile
@@ -7,6 +7,7 @@
PORTNAME= coovachilli
PORTVERSION= 1.0.12
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://ap.coova.org/chilli/ \
http://www.geeklan.co.uk/files/ \
diff --git a/net-mgmt/coovachilli/files/patch-conf_functions.in b/net-mgmt/coovachilli/files/patch-conf_functions.in
index cd399b3c6799..deb220812467 100644
--- a/net-mgmt/coovachilli/files/patch-conf_functions.in
+++ b/net-mgmt/coovachilli/files/patch-conf_functions.in
@@ -1,5 +1,5 @@
---- conf/functions.in.orig 2009-01-10 17:55:30.000000000 +0000
-+++ conf/functions.in 2009-01-10 17:56:42.000000000 +0000
+--- conf/functions.in.orig 2008-04-13 15:58:32.000000000 +0100
++++ conf/functions.in 2009-10-12 18:08:23.000000000 +0100
@@ -4,7 +4,6 @@
# Licensed under GPL. See http://coova.org/
#
@@ -17,3 +17,12 @@
HS_UAMPORT=${HS_UAMPORT:-3990}
HS_RADIUS=${HS_RADIUS:-$HS_UAMSERVER}
HS_RADSECRET=${HS_RADSECRET:-$HS_UAMSECRET}
+@@ -49,7 +46,7 @@
+ HS_PAP_OK=${HS_PAP_OK:-on}
+ HS_DNS1=${HS_DNS1:-$HS_DNS}
+ HS_DNS1=${HS_DNS1:-$(grep '^nameserver' /etc/resolv.conf | head -n1 | awk '{print $2}')}
+-HS_WANIF=${HS_WANIF:-$(route -n|grep '^0.0.0.0'|head -n1|awk '{print $8}')}
++HS_WANIF=${HS_WANIF:-$(netstat -rn|grep '^default'|head -n1|awk '{print $6}')}
+
+ bailout() { echo $1; exit; }
+