aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
committermat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
commit344522393988339d341fda0818f0281645323f90 (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /net-mgmt
parenta8ea83538e74965157afe830f9873190be5ac78a (diff)
downloadfreebsd-ports-gnome-344522393988339d341fda0818f0281645323f90.tar.gz
freebsd-ports-gnome-344522393988339d341fda0818f0281645323f90.tar.zst
freebsd-ports-gnome-344522393988339d341fda0818f0281645323f90.zip
Fix ports that confused the meaning of WRKDIR and WRKSRC.
PR: 204056 Submitted by: mat Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D2735
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/icmpquery/Makefile6
-rw-r--r--net-mgmt/nagios-check_dhcp.pl/Makefile4
-rw-r--r--net-mgmt/nagios-check_tftp/Makefile6
3 files changed, 8 insertions, 8 deletions
diff --git a/net-mgmt/icmpquery/Makefile b/net-mgmt/icmpquery/Makefile
index 250676dc37f4..956d03292b6c 100644
--- a/net-mgmt/icmpquery/Makefile
+++ b/net-mgmt/icmpquery/Makefile
@@ -16,11 +16,11 @@ NO_WRKSUBDIR= YES
ALL_TARGET= icmpquery
do-extract:
- @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}
- @${CP} ${FILESDIR}/Makefile ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
do-install:
- @${INSTALL_PROGRAM} ${WRKDIR}/icmpquery ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/icmpquery ${STAGEDIR}${PREFIX}/bin
@${CHMOD} u+s ${STAGEDIR}${PREFIX}/bin/icmpquery
.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-check_dhcp.pl/Makefile b/net-mgmt/nagios-check_dhcp.pl/Makefile
index 614f80876ed1..1fb710830b52 100644
--- a/net-mgmt/nagios-check_dhcp.pl/Makefile
+++ b/net-mgmt/nagios-check_dhcp.pl/Makefile
@@ -27,8 +27,8 @@ post-patch:
@${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL}," ${WRKSRC}/${PORTNAME}
do-extract:
- @${MKDIR} ${WRKDIR}
- @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}/
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${PORTNAME} ${WRKSRC}/
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
diff --git a/net-mgmt/nagios-check_tftp/Makefile b/net-mgmt/nagios-check_tftp/Makefile
index 1cb2d8690d37..a78daca49dc8 100644
--- a/net-mgmt/nagios-check_tftp/Makefile
+++ b/net-mgmt/nagios-check_tftp/Makefile
@@ -25,12 +25,12 @@ post-patch:
${WRKSRC}/check_tftp
do-extract:
- @${MKDIR} ${WRKDIR}
- @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${PORTNAME} ${WRKSRC}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} \
${STAGEDIR}${PREFIX}/libexec/nagios
.include <bsd.port.mk>