aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorjunovitch <junovitch@FreeBSD.org>2015-09-11 11:32:13 +0800
committerjunovitch <junovitch@FreeBSD.org>2015-09-11 11:32:13 +0800
commit5a4c2ee8615ebb085e290fa853959f65f65ebc7b (patch)
tree66fc53a9505cda1fcef58c9abcaee1c7929dd3b4 /net-mgmt
parent4c8e3c8f387ebc1e7ba68b810fb549b49916e476 (diff)
downloadfreebsd-ports-gnome-5a4c2ee8615ebb085e290fa853959f65f65ebc7b.tar.gz
freebsd-ports-gnome-5a4c2ee8615ebb085e290fa853959f65f65ebc7b.tar.zst
freebsd-ports-gnome-5a4c2ee8615ebb085e290fa853959f65f65ebc7b.zip
net-mgmt/collectd5: add support for write_kafka plugin
While here, also sort OPTIONS_GROUP_OUTPUT and two DESC items PR: 202487 Submitted by: xoan333@yahoo.com Approved by: Krzysztof <ports@bsdserwis.com> (maintainer), feld (mentor)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile19
-rw-r--r--net-mgmt/collectd5/pkg-plist1
2 files changed, 15 insertions, 5 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 1e1fb4a81706..55a8f45c9b98 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 5.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= https://collectd.org/files/ \
http://collectd.org/files/
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
OPTIONS_DEFINE= CGI DEBUG GCRYPT LOGSTASH VIRT
OPTIONS_GROUP= INPUT OUTPUT
-OPTIONS_GROUP_OUTPUT= RRDTOOL NOTIFYEMAIL NOTIFYDESKTOP RIEMANN
+OPTIONS_GROUP_OUTPUT= KAFKA NOTIFYDESKTOP NOTIFYEMAIL RIEMANN RRDTOOL
OPTIONS_GROUP_INPUT= CURL DBI IPMI JSON MEMCACHEC MODBUS MONGODB MYSQL \
NUTUPS OLSRD ONEWIRE OPENLDAP PERL PGSQL PINBA PING \
PYTHON RABBITMQ REDIS ROUTEROS SIGROK SNMP STATGRAB \
@@ -32,18 +32,19 @@ OPTIONS_GROUP_INPUT= CURL DBI IPMI JSON MEMCACHEC MODBUS MONGODB MYSQL \
CGI_DESC= Install collection.cgi (requires rrdtool)
CURL_DESC= Enable curl-based plugins (apache, nginx, etc)
-DEBUG_DESC= Enable debugging
DBI_DESC= Enable dbi plugin
+DEBUG_DESC= Enable debugging
GCRYPT_DESC= Build with libgcrypt
IPMI_DESC= Enable OpenIPMI plugin
JSON_DESC= Enable JSON plugins
+KAFKA_DESC= Enable write_kafka plugin
LOGSTASH_DESC= Enable log_logstash plugin (requires json)
MEMCACHEC_DESC= Enable memcachec plugin
MODBUS_DESC= Enable modbus plugin
MONGODB_DESC= Enable MongoDB-based plugins
MYSQL_DESC= Enable mysql-based plugins
-NOTIFYEMAIL_DESC= Enable notifications via email
NOTIFYDESKTOP_DESC= Enable desktop notifications
+NOTIFYEMAIL_DESC= Enable notifications via email
NUTUPS_DESC= Enable nut (ups) plugin
OLSRD_DESC= Enable olsrd plugin
ONEWIRE_DESC= Eanble onewire plugin (via owfs)
@@ -99,7 +100,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--without-libnetapp \
--without-libowcapi \
--without-libperfstat \
- --without-librdkafka \
--without-libsensors \
--without-libvarnish \
--without-lvm \
@@ -251,6 +251,15 @@ CONFIGURE_ARGS+=--with-libyajl=${LOCALBASE}
CONFIGURE_ARGS+=--without-libyajl
.endif
+.if ${PORT_OPTIONS:MKAFKA}
+LIB_DEPENDS+= librdkafka.so:${PORTSDIR}/net/librdkafka
+CONFIGURE_ARGS+=--enable-write_kafka
+PLIST_SUB+= KAFKA=""
+.else
+CONFIGURE_ARGS+=--disable-write_kafka
+PLIST_SUB+= KAFKA="@comment "
+.endif
+
.if ${PORT_OPTIONS:MLOGSTASH}
CONFIGURE_ARGS+=--enable-log_logstash
PLIST_SUB+= LOGSTASH=""
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index f33ee3458322..2fb983e94f86 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -97,6 +97,7 @@ lib/collectd/uuid.so
lib/collectd/write_graphite.so
%%CURL%%lib/collectd/write_http.so
lib/collectd/write_log.so
+%%KAFKA%%lib/collectd/write_kafka.so
%%MONGODB%%lib/collectd/write_mongodb.so
%%REDIS%%lib/collectd/write_redis.so
%%RIEMANN%%lib/collectd/write_riemann.so