aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-20 16:31:44 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-20 16:31:44 +0800
commit6046ebf6fa90581169b838e414e78e48f3041beb (patch)
tree55b142473858163d419830721a3cdc9b7d092f7b /net-mgmt
parentc897562bca636e63b9b43c2a713cae9dbd8d923f (diff)
downloadfreebsd-ports-gnome-6046ebf6fa90581169b838e414e78e48f3041beb.tar.gz
freebsd-ports-gnome-6046ebf6fa90581169b838e414e78e48f3041beb.tar.zst
freebsd-ports-gnome-6046ebf6fa90581169b838e414e78e48f3041beb.zip
Support staging
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-check_tftp/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-mgmt/nagios-check_tftp/Makefile b/net-mgmt/nagios-check_tftp/Makefile
index 774431fa7ca9..90f0b8f01419 100644
--- a/net-mgmt/nagios-check_tftp/Makefile
+++ b/net-mgmt/nagios-check_tftp/Makefile
@@ -17,18 +17,21 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
PLIST_DIRSTRY= libexec/nagios
PLIST_FILES= libexec/nagios/check_tftp
+
NO_BUILD= yes
NO_WRKSUBDIR= yes
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/check_tftp
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/check_tftp
do-extract:
- @${MKDIR} ${WRKDIR}
- @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}/
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${PORTNAME} ${WRKDIR}
+
do-install:
- @${MKDIR} ${PREFIX}/libexec/nagios
- @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/libexec/nagios
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/libexec/nagios
.include <bsd.port.mk>