aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-05-17 01:24:23 +0800
committerjgh <jgh@FreeBSD.org>2012-05-17 01:24:23 +0800
commit8a3c4ccf8ff8f25982c0e1bd9d3f53aa22752ad4 (patch)
tree20906f0e852c91ca96a3a64cd848a302b08820e7 /net-mgmt
parentcef6481a18a8f38f9079edfb7a9e6c191d97d87d (diff)
downloadfreebsd-ports-gnome-8a3c4ccf8ff8f25982c0e1bd9d3f53aa22752ad4.tar.gz
freebsd-ports-gnome-8a3c4ccf8ff8f25982c0e1bd9d3f53aa22752ad4.tar.zst
freebsd-ports-gnome-8a3c4ccf8ff8f25982c0e1bd9d3f53aa22752ad4.zip
- fix startup of zenoss service
- bump PORTREVISION PR: ports/167897 Submitted by: xenophon+freebsd@irtnog.org Approved by: maintainer, pphillips@experts-exchange.com Sponsored by: Experts Exchange, LLC.
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zenoss/Makefile1
-rw-r--r--net-mgmt/zenoss/files/patch-init.sh6
2 files changed, 6 insertions, 1 deletions
diff --git a/net-mgmt/zenoss/Makefile b/net-mgmt/zenoss/Makefile
index 6560a6ef099f..c78f3ee4fe5d 100644
--- a/net-mgmt/zenoss/Makefile
+++ b/net-mgmt/zenoss/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zenoss
PORTVERSION= 3.1.0
+PORTREVISION= 1
CATEGORIES= net-mgmt java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-3.1/${PORTNAME}-${PORTVERSION}:source1 \
http://dev.sencha.com/deploy/:source2
diff --git a/net-mgmt/zenoss/files/patch-init.sh b/net-mgmt/zenoss/files/patch-init.sh
index be7dfdb6d119..af073e034162 100644
--- a/net-mgmt/zenoss/files/patch-init.sh
+++ b/net-mgmt/zenoss/files/patch-init.sh
@@ -2,7 +2,7 @@ $FreeBSD$
--- /dev/null 2011-04-19 17:01:32.000000000 -0700
+++ init.sh 2011-04-19 17:02:19.000000000 -0700
-@@ -0,0 +1,15 @@
+@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+# load up the functions we'll use to build and install
+. shared-functions.sh
@@ -16,5 +16,9 @@ $FreeBSD$
+ exit 1
+fi
+
++if [ ! -f "$ZENHOME/etc/zope.conf" ]; then
++ cp -p $ZENHOME/etc/zope.conf.in $ZENHOME/etc/zope.conf
++fi
++
+init
+get_happy