aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2012-07-28 22:04:28 +0800
committerlme <lme@FreeBSD.org>2012-07-28 22:04:28 +0800
commit8b265c6885d7333eda1f89acde43c16f59f4e53b (patch)
treee4d85476cf93409589b0e5b99d74ba6ef5202fd5 /net-mgmt
parentb0f635ba1256077a17b071d845cc0f2c4219a49c (diff)
downloadfreebsd-ports-gnome-8b265c6885d7333eda1f89acde43c16f59f4e53b.tar.gz
freebsd-ports-gnome-8b265c6885d7333eda1f89acde43c16f59f4e53b.tar.zst
freebsd-ports-gnome-8b265c6885d7333eda1f89acde43c16f59f4e53b.zip
- Update to 1.7.1
- Change to new OPTIONS framework - Don't depend on specific lib versions
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/icinga/Makefile43
-rw-r--r--net-mgmt/icinga/distinfo4
2 files changed, 23 insertions, 24 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index f183967d90ff..71006f9677cb 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= icinga
-PORTVERSION= 1.7.0
-PORTREVISION= 3
+PORTVERSION= 1.7.1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -16,7 +15,7 @@ COMMENT= Enterprise grade open source monitoring system based on nagios
LICENSE= GPLv2
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
USE_ICONV= yes
@@ -24,14 +23,6 @@ USE_PERL5_BUILD= yes
USE_AUTOTOOLS= autoconf libltdl
USE_RC_SUBR= icinga
-OPTIONS= EMBEDDED_PERL "Enable embedded Perl" on \
- NANOSLEEP "Use nanosleep in event timing" off \
- UNHANDLED_HACK "Display passive checks in unhandled queries" off \
- IDOUTILS "Enable IDOUtils" on \
- PGSQL "Enable support for PostgreSQL" off \
- MYSQL "Depend on MySQL" off \
- APACHE "Depend on Apache and install webconfig" off
-
GNU_CONFIGURE= yes
ICINGAUSER?= icinga
@@ -46,8 +37,6 @@ ICINGAWWWDIR?= www/icinga
ICINGAHTMURL?= /icinga
ICINGACGIURL?= ${ICINGAHTMURL}/cgi-bin
-.include <bsd.port.pre.mk>
-
CPPFLAGS+= -I${LOCALBASE}/include -fPIC
CFLAGS+= ${CPPFLAGS}
@@ -94,7 +83,17 @@ SUB_FILES= pkg-install \
SUB_LIST= PREFIX=${PREFIX} \
${PLIST_SUB}
-.if defined(WITH_EMBEDDED_PERL)
+OPTIONS_DEFINE= EMBEDDED_PERL NANOSLEEP UNHANDLED_HACK IDOUTILS PGSQL MYSQL APACHE
+OPTIONS_DEFAULT= EMBEDDED_PERL IDOUTILS
+
+EMBEDDED_PERL_DESC= Enable embedded Perl
+NANOSLEEP_DESC= Use nanosleep in event timing
+UNHANDLED_HACK_DESC= Display passive checks in unhandled queries
+APACHE_DESC= Depend on Apache and install webconfig
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEMBEDDED_PERL}
USE_PERL5= 5.8.0+
CONFIGURE_ARGS+= --enable-embedded-perl \
--with-perlcache
@@ -103,12 +102,12 @@ PLIST_SUB+= EMBEDDED_PERL=""
PLIST_SUB+= EMBEDDED_PERL="@comment "
.endif
-.if defined(WITH_NANOSLEEP)
+.if ${PORT_OPTIONS:MNANOSLEEP}
CONFIGURE_ARGS+= --enable-nanosleep
.endif
-.if defined(WITH_IDOUTILS)
-LIB_DEPENDS+= dbi.1:${PORTSDIR}/databases/libdbi-drivers
+.if ${PORT_OPTIONS:MIDOUTILS}
+LIB_DEPENDS+= dbi:${PORTSDIR}/databases/libdbi-drivers
CONFIGURE_ARGS+= --enable-idoutils \
--enable-ssl \
--with-dbi-lib=${LOCALBASE}/lib \
@@ -120,16 +119,16 @@ PLIST_SUB+= IDOUTILS=""
PLIST_SUB+= IDOUTILS="@comment "
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-pgsql
.endif
-.if defined(WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE= 22+
CONFIGURE_ARGS+= --with-httpd-conf=${LOCALBASE}/${APACHEETCDIR}/extra
INSTALL_TARGET+= install-webconf
@@ -142,7 +141,7 @@ post-patch:
@${REINPLACE_CMD} -e 's#/bin/ping#/sbin/ping#' ${WRKSRC}/sample-config/cgi.cfg.in
@${REINPLACE_CMD} -e 's#Linux#FreeBSD#' ${WRKSRC}/sample-config/icinga.cfg.in
@${REINPLACE_CMD} -e 's#775#755#g; s#664#644#g' ${WRKSRC}/html/Makefile.in
-.if defined(WITH_UNHANDLED_HACK)
+.if ${PORT_OPTIONS:MUNHANDLED_HACK}
@${REINPLACE_CMD} -e 's#;serviceprops=42\&#;serviceprops=10\&#g' \
-e 's#;hostprops=42\"#;hostprops=10\"#g' ${WRKSRC}/html/menu.html.in
.endif
@@ -165,4 +164,4 @@ post-install:
@${CHOWN} ${ICINGAUSER}:${WWWGRP} ${ICINGADIR}/rw
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/icinga/distinfo b/net-mgmt/icinga/distinfo
index c1e2dd0b0df8..16a1e02f88cb 100644
--- a/net-mgmt/icinga/distinfo
+++ b/net-mgmt/icinga/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icinga-1.7.0.tar.gz) = e0d033e37bd3c4fb6a35151cc94aae4ca8e730510d9156ea755245728f8acb8b
-SIZE (icinga-1.7.0.tar.gz) = 12939198
+SHA256 (icinga-1.7.1.tar.gz) = 86662178fae6a3618340b2d0b0fad5033439556649f79214a9a2331c10c2cab6
+SIZE (icinga-1.7.1.tar.gz) = 12938365