aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-25 08:52:32 +0800
committermiwi <miwi@FreeBSD.org>2011-02-25 08:52:32 +0800
commit91003209040664d6ca9210f534eb9d6cac3bf216 (patch)
treeea5d5a3b400fc43e83bbc8d37cbef87dfd9586d6 /net-mgmt
parentfcad7d6603fff8cde093f411f3c1b860d1721a6a (diff)
downloadfreebsd-ports-gnome-91003209040664d6ca9210f534eb9d6cac3bf216.tar.gz
freebsd-ports-gnome-91003209040664d6ca9210f534eb9d6cac3bf216.tar.zst
freebsd-ports-gnome-91003209040664d6ca9210f534eb9d6cac3bf216.zip
- Backout previuse commit
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile26
-rw-r--r--net-mgmt/collectd/pkg-plist3
-rw-r--r--net-mgmt/collectd5/Makefile26
-rw-r--r--net-mgmt/collectd5/pkg-plist3
4 files changed, 8 insertions, 50 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 8cae9b909cf2..1f8f22e63c1d 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -16,13 +16,9 @@ COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoheader aclocal libtool libtoolize automake autoconf libltdl
+USE_AUTOTOOLS= libltdl
WANT_GNOME= yes
-AUTOMAKE_ARGS= --add-missing --copy
-LIBTOOLIZE_ARGS= --ltdl --copy --force
-ACLOCAL_ARGS=
-
OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
BIND "Enable BIND 9.5+ statistics" On \
DEBUG "Enable debugging" Off \
@@ -41,7 +37,8 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
PGSQL "Input: PostgreSQL" Off \
PING "Input: Network latency (liboping)" On \
SNMP "Input: SNMP" On \
- XMMS "Input: XMMS" Off
+ XMMS "Input: XMMS" Off \
+ RRDTOOL "Output: RRDTool" On
MAN1= collectd.1 collectd-nagios.1 collectdmon.1
MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
@@ -56,14 +53,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if ( ${OSVERSION} >= 800000 )
-OPTIONS+= ZFS_ARC "Input: ZFS ARC" Off
-.else
-.undef WITH_ZFS_ARC
-.endif
-
-OPTIONS+= RRDTOOL "Output: RRDTool" On
-
.if ( ${OSVERSION} < 601103 )
BROKEN= Need bind9 import post 6.1
.endif
@@ -134,6 +123,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-vserver \
--disable-wireless \
--disable-write_http \
+ --disable-zfs_arc \
--without-perl-bindings
.if defined(WITH_DEBUG)
@@ -325,14 +315,6 @@ CONFIGURE_ARGS+=--disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
-.if defined(WITH_ZFS_ARC) && ( ${OSVERSION} >= 800000 )
-CONFIGURE_ARGS+=--enable-zfs_arc
-PLIST_SUB+= ZFS_ARC=""
-.else
-CONFIGURE_ARGS+=--disable-zfs_arc
-PLIST_SUB+= ZFS_ARC="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's;@prefix@/var/;/var/;' \
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index 8d5652aeb47f..b899a8f03e4c 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -134,9 +134,6 @@ libdata/pkgconfig/libcollectdclient.pc
%%XMMS%%lib/collectd/xmms.a
%%XMMS%%lib/collectd/xmms.la
%%XMMS%%lib/collectd/xmms.so
-%%ZFS_ARC%%lib/collectd/zfs_arc.a
-%%ZFS_ARC%%lib/collectd/zfs_arc.la
-%%ZFS_ARC%%lib/collectd/zfs_arc.so
%%DATADIR%%/postgresql_default.conf
%%DATADIR%%/types.db
@dirrm lib/collectd
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 8cae9b909cf2..1f8f22e63c1d 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -16,13 +16,9 @@ COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoheader aclocal libtool libtoolize automake autoconf libltdl
+USE_AUTOTOOLS= libltdl
WANT_GNOME= yes
-AUTOMAKE_ARGS= --add-missing --copy
-LIBTOOLIZE_ARGS= --ltdl --copy --force
-ACLOCAL_ARGS=
-
OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
BIND "Enable BIND 9.5+ statistics" On \
DEBUG "Enable debugging" Off \
@@ -41,7 +37,8 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
PGSQL "Input: PostgreSQL" Off \
PING "Input: Network latency (liboping)" On \
SNMP "Input: SNMP" On \
- XMMS "Input: XMMS" Off
+ XMMS "Input: XMMS" Off \
+ RRDTOOL "Output: RRDTool" On
MAN1= collectd.1 collectd-nagios.1 collectdmon.1
MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
@@ -56,14 +53,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if ( ${OSVERSION} >= 800000 )
-OPTIONS+= ZFS_ARC "Input: ZFS ARC" Off
-.else
-.undef WITH_ZFS_ARC
-.endif
-
-OPTIONS+= RRDTOOL "Output: RRDTool" On
-
.if ( ${OSVERSION} < 601103 )
BROKEN= Need bind9 import post 6.1
.endif
@@ -134,6 +123,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-vserver \
--disable-wireless \
--disable-write_http \
+ --disable-zfs_arc \
--without-perl-bindings
.if defined(WITH_DEBUG)
@@ -325,14 +315,6 @@ CONFIGURE_ARGS+=--disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
-.if defined(WITH_ZFS_ARC) && ( ${OSVERSION} >= 800000 )
-CONFIGURE_ARGS+=--enable-zfs_arc
-PLIST_SUB+= ZFS_ARC=""
-.else
-CONFIGURE_ARGS+=--disable-zfs_arc
-PLIST_SUB+= ZFS_ARC="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's;@prefix@/var/;/var/;' \
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 8d5652aeb47f..b899a8f03e4c 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -134,9 +134,6 @@ libdata/pkgconfig/libcollectdclient.pc
%%XMMS%%lib/collectd/xmms.a
%%XMMS%%lib/collectd/xmms.la
%%XMMS%%lib/collectd/xmms.so
-%%ZFS_ARC%%lib/collectd/zfs_arc.a
-%%ZFS_ARC%%lib/collectd/zfs_arc.la
-%%ZFS_ARC%%lib/collectd/zfs_arc.so
%%DATADIR%%/postgresql_default.conf
%%DATADIR%%/types.db
@dirrm lib/collectd