aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-05-29 04:09:26 +0800
committerpi <pi@FreeBSD.org>2016-05-29 04:09:26 +0800
commita3cea3d941673c56c8c860d08bee729bc05024c1 (patch)
treee9bd79cc7b37e20b36734e1dbe77435b8d19f831 /net-mgmt
parent25c1f4c853e227d66a37aee5514eb72d27c1a498 (diff)
downloadfreebsd-ports-gnome-a3cea3d941673c56c8c860d08bee729bc05024c1.tar.gz
freebsd-ports-gnome-a3cea3d941673c56c8c860d08bee729bc05024c1.tar.zst
freebsd-ports-gnome-a3cea3d941673c56c8c860d08bee729bc05024c1.zip
net-mgmt/cacti: 0.8.8g -> 0.8.8h
This is a security update for cacti to resolve SQL exploits. - upgrade to 0.8.8h codebase from vendor - fix SQL vulnerabilities including CVE-2016-3659 - fix USE_MYSQL -> USES:mysql - fix deprecated mysql php module requirement (use mysqli instead) - fix overwriting of failure/recovery dates after outages PR: 209809 Submitted by: Daniel Austin <freebsd-ports@dan.me.uk> (maintainer) Security: CVE-2016-3659 MFH: 2016Q2
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cacti/Makefile6
-rw-r--r--net-mgmt/cacti/distinfo4
-rw-r--r--net-mgmt/cacti/files/patch-install__index.php13
-rw-r--r--net-mgmt/cacti/files/patch-lib__functions.php15
-rw-r--r--net-mgmt/cacti/pkg-plist1
5 files changed, 31 insertions, 8 deletions
diff --git a/net-mgmt/cacti/Makefile b/net-mgmt/cacti/Makefile
index 0711cd3e6a11..734171f77301 100644
--- a/net-mgmt/cacti/Makefile
+++ b/net-mgmt/cacti/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cacti
-PORTVERSION= 0.8.8g${PATCHLEVEL}
-PORTREVISION= 2
+PORTVERSION= 0.8.8h${PATCHLEVEL}
CATEGORIES= net-mgmt www
MASTER_SITES= http://www.cacti.net/downloads/ \
ftp://ftpmirror.uk/freebsd-ports/cacti/
@@ -15,8 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rrdtool:databases/rrdtool
-USES= cpe shebangfix
-USE_MYSQL= yes
+USES= cpe mysql shebangfix
USE_PHP= mysqli pcre session sockets snmp xml
WANT_PHP_WEB= yes
NO_ARCH= yes
diff --git a/net-mgmt/cacti/distinfo b/net-mgmt/cacti/distinfo
index 35a8a0e12289..c592245be42c 100644
--- a/net-mgmt/cacti/distinfo
+++ b/net-mgmt/cacti/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cacti-0.8.8g.tar.gz) = 3187bd5054ae4e54496bb23187f14c79a441fedcfd397a2d27cd60179f0dee33
-SIZE (cacti-0.8.8g.tar.gz) = 2584879
+SHA256 (cacti-0.8.8h.tar.gz) = 0673bd9513dad381c8bbb9133c721a32bc6422dc91c5a81de16e3cd32e4d0600
+SIZE (cacti-0.8.8h.tar.gz) = 2585226
diff --git a/net-mgmt/cacti/files/patch-install__index.php b/net-mgmt/cacti/files/patch-install__index.php
index 2f3db764e397..904c79ea1634 100644
--- a/net-mgmt/cacti/files/patch-install__index.php
+++ b/net-mgmt/cacti/files/patch-install__index.php
@@ -1,5 +1,14 @@
---- install/index.php.bak 2015-03-12 03:12:05.409276443 -0700
-+++ install/index.php 2015-03-12 03:14:17.596295374 -0700
+--- install/index.php.orig 2016-05-28 10:54:08.124059773 +0100
++++ install/index.php 2016-05-28 10:54:34.252057818 +0100
+@@ -63,7 +63,7 @@
+ }
+
+ function verify_php_extensions() {
+- $extensions = array("session", "sockets", "mysql", "xml");
++ $extensions = array("session", "sockets", "mysqli", "xml");
+ $ok = true;
+ $missing_extension = " <p style='font-family: Verdana, Arial; font-size: 16px; font-weight: bold; color: red;'>Error</p>
+ <p style='font-family: Verdana, Arial; font-size: 12px;'>The following PHP extensions are missing:</p><ul>";
@@ -267,7 +267,7 @@
if (config_value_exists("path_cactilog")) {
$input["path_cactilog"]["default"] = read_config_option("path_cactilog");
diff --git a/net-mgmt/cacti/files/patch-lib__functions.php b/net-mgmt/cacti/files/patch-lib__functions.php
new file mode 100644
index 000000000000..41a9c1006d90
--- /dev/null
+++ b/net-mgmt/cacti/files/patch-lib__functions.php
@@ -0,0 +1,15 @@
+--- lib/functions.php.orig 2016-05-28 10:58:17.522042409 +0100
++++ lib/functions.php 2016-05-28 11:00:31.399032747 +0100
+@@ -670,8 +670,10 @@
+ $issue_log_message = false;
+ $ping_failure_count = read_config_option("ping_failure_count");
+ $ping_recovery_count = read_config_option("ping_recovery_count");
+- $hosts[$host_id]["status_fail_date"] = '0000-00-00 00:00:00';
+- $hosts[$host_id]["status_rec_date"] = '0000-00-00 00:00:00';
++ if ((!isset($hosts[$host_id]["status_fail_date"])) || ($hosts[$host_id]["status_fail_date"] == ""))
++ $hosts[$host_id]["status_fail_date"] = '0000-00-00 00:00:00';
++ if ((!isset($hosts[$host_id]["status_rec_date"])) || ($hosts[$host_id]["status_rec_date"] == ""))
++ $hosts[$host_id]["status_rec_date"] = '0000-00-00 00:00:00';
+
+ if ($status == HOST_DOWN) {
+ /* update total polls, failed polls and availability */
diff --git a/net-mgmt/cacti/pkg-plist b/net-mgmt/cacti/pkg-plist
index 2f601fef5a12..7c5dcbf141fd 100644
--- a/net-mgmt/cacti/pkg-plist
+++ b/net-mgmt/cacti/pkg-plist
@@ -348,6 +348,7 @@
%%CACTIDIR%%/install/0_8_8d_to_0_8_8e.php
%%CACTIDIR%%/install/0_8_8e_to_0_8_8f.php
%%CACTIDIR%%/install/0_8_8f_to_0_8_8g.php
+%%CACTIDIR%%/install/0_8_8g_to_0_8_8h.php
%%CACTIDIR%%/install/0_8_to_0_8_1.php
%%CACTIDIR%%/install/index.php
%%CACTIDIR%%/install/install_finish.gif