aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-03-18 03:50:26 +0800
committerzi <zi@FreeBSD.org>2012-03-18 03:50:26 +0800
commitb4f19c8fbe9df37e0d7ec0120a672f38c0481a9e (patch)
tree2577d831eaf522f768e07bf7c908716cc9169b31 /net-mgmt
parent4a0b6064299f8456665bb2de5a002cc39070a6e8 (diff)
downloadfreebsd-ports-gnome-b4f19c8fbe9df37e0d7ec0120a672f38c0481a9e.tar.gz
freebsd-ports-gnome-b4f19c8fbe9df37e0d7ec0120a672f38c0481a9e.tar.zst
freebsd-ports-gnome-b4f19c8fbe9df37e0d7ec0120a672f38c0481a9e.zip
- Add LICENSE
- Add OPTION for logging snmptraps to MySQL - Add OPTION to restrict agentx access to a local socket only Feature safe: yes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index e3e8bd0f16ec..a930a8190434 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -16,6 +16,8 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= zi@FreeBSD.org
COMMENT= An extendable SNMP implementation
+LICENSE= BSD
+
OPTIONS= IPV6 "Build with IPv6 support" on \
MFD_REWRITES "Build with 64-bit Interface Counters" off \
PERL "Install additional perl modules" on \
@@ -24,6 +26,8 @@ OPTIONS= IPV6 "Build with IPv6 support" on \
DUMMY "Enable dummy values as placeholders" on \
TKMIB "Install graphical MIB browser" off \
DMALLOC "Enable dmalloc debug memory allocator" off \
+ MYSQL "Enable logging of traps to MySQL" off \
+ AX_SOCKONLY "Disable UDP/TCP transports for agentx" off \
UNPRIVILEGED "Allow unprivileged users to execute net-snmp" off
.include <bsd.port.options.mk>
@@ -114,6 +118,17 @@ LIB_DEPENDS+= dmalloc:${PORTSDIR}/devel/dmalloc
CONFIGURE_ARGS+=--with-dmalloc=${LOCALBASE}
.endif
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+=--with-mysql
+CONFIGURE_ENV+= MYSQLCONFIG=${LOCALBASE}/bin/mysql_config
+.endif
+
+.if defined(WITH_AX_SOCKONLY)
+CONFIGURE_ARGS+=--enable-agentx-dom-sock-only
+.endif
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--enable-ipv6
# --with-transport="UDPIPv6 TCPIPv6" --with-modules=mibII/ipv6"