aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-09 18:46:32 +0800
committerbapt <bapt@FreeBSD.org>2014-06-09 18:46:32 +0800
commitd85c4a8dc3a16d460305f303ebd20da8dd68eb89 (patch)
treec66ce570c4539ad99505813b360aa011ef5bb1e2 /net-mgmt
parent460eedfe7015a30fc881297b02f8a2d7ec329f7e (diff)
downloadfreebsd-ports-gnome-d85c4a8dc3a16d460305f303ebd20da8dd68eb89.tar.gz
freebsd-ports-gnome-d85c4a8dc3a16d460305f303ebd20da8dd68eb89.tar.zst
freebsd-ports-gnome-d85c4a8dc3a16d460305f303ebd20da8dd68eb89.zip
Fix building
Respect CFLAGS / LDFLAGS Add staging support PR: 190806 Submitted by: coco@executive-computing.de
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/sendip/Makefile23
-rw-r--r--net-mgmt/sendip/files/patch-Makefile15
-rw-r--r--net-mgmt/sendip/pkg-plist13
3 files changed, 29 insertions, 22 deletions
diff --git a/net-mgmt/sendip/Makefile b/net-mgmt/sendip/Makefile
index 11bd0e503777..0757e1b53e5c 100644
--- a/net-mgmt/sendip/Makefile
+++ b/net-mgmt/sendip/Makefile
@@ -3,23 +3,26 @@
PORTNAME= sendip
PORTVERSION= 2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt ipv6
MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= joseph@randomnetworks.com
COMMENT= SendIP is a commandline tool to allow sending arbitrary IP packets
-USES= gmake perl5
-USE_LDCONFIG= yes
+LICENSE= GPLv2
-MAN1= sendip.1
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+USES= gmake perl5
+
+USE_LDCONFIG= yes
-.if ${OSVERSION} >= 900000
-BROKEN= does not compile on FreeBSD 9.X
-.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sendip
+.for slib in ipv4.so ipv6.so icmp.so tcp.so udp.so rip.so ripng.so ntp.so \
+bgp.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/sendip/${slib}
+.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/sendip/files/patch-Makefile b/net-mgmt/sendip/files/patch-Makefile
index a3a0a455f5e1..42f6666caabb 100644
--- a/net-mgmt/sendip/files/patch-Makefile
+++ b/net-mgmt/sendip/files/patch-Makefile
@@ -7,21 +7,24 @@
-MANDIR ?= $(PREFIX)/share/man/man1
-LIBDIR ?= $(PREFIX)/lib/sendip
+#PREFIX ?= /usr/local
-+BINDIR=${PREFIX}/bin
-+MANDIR=${PREFIX}/man/man1
-+LIBDIR=${PREFIX}/lib/sendip
++BINDIR=${DESTDIR}${PREFIX}/bin
++MANDIR=${DESTDIR}${PREFIX}/man/man1
++LIBDIR=${DESTDIR}${PREFIX}/lib/sendip
#For most systems, this works
-INSTALL ?= install
+INSTALL?=install
#For Solaris, you may need
#INSTALL=/usr/ucb/install
- CFLAGS= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
- -Wstrict-prototypes -Wnested-externs -Winline -Werror -g -Wcast-align \
+-CFLAGS= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
+- -Wstrict-prototypes -Wnested-externs -Winline -Werror -g -Wcast-align \
- -DSENDIP_LIBS=\"$(LIBDIR)\"
++CFLAGS+= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings -Wno-empty-body -Wno-constant-conversion \
++ -Wstrict-prototypes -Wnested-externs -Winline -Werror -Wcast-align \
+ -DSENDIP_LIBS=\"${LIBDIR}\"
#-Wcast-align causes problems on solaris, but not serious ones
- LDFLAGS= -g -rdynamic -lm
+-LDFLAGS= -g -rdynamic -lm
++LDFLAGS+= -rdynamic -lm
#LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm -ldl
LDFLAGS_LINUX= -g -rdynamic -ldl -lm
diff --git a/net-mgmt/sendip/pkg-plist b/net-mgmt/sendip/pkg-plist
index fa444f45d78c..d804c6838b95 100644
--- a/net-mgmt/sendip/pkg-plist
+++ b/net-mgmt/sendip/pkg-plist
@@ -1,11 +1,12 @@
bin/sendip
+lib/sendip/bgp.so
+lib/sendip/icmp.so
lib/sendip/ipv4.so
lib/sendip/ipv6.so
-lib/sendip/icmp.so
-lib/sendip/tcp.so
-lib/sendip/udp.so
+lib/sendip/ntp.so
lib/sendip/rip.so
lib/sendip/ripng.so
-lib/sendip/bgp.so
-lib/sendip/ntp.so
-@dirrm lib/sendip
+lib/sendip/tcp.so
+lib/sendip/udp.so
+man/man1/sendip.1.gz
+@dirrmtry lib/sendip