aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2018-01-05 01:29:28 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:18:38 +0800
commit112239a075c28b7627c2ccbb30d1222380a3f1f4 (patch)
treeec31fd0310054e128d6c5238675d19dec54b1962 /net-mgmt
parent57ea64ca0e0db6e089b4856761c147c50679dab2 (diff)
downloadfreebsd-ports-gnome-112239a075c28b7627c2ccbb30d1222380a3f1f4.tar.gz
freebsd-ports-gnome-112239a075c28b7627c2ccbb30d1222380a3f1f4.tar.zst
freebsd-ports-gnome-112239a075c28b7627c2ccbb30d1222380a3f1f4.zip
- Resolve perl warnings
- Bump PORTREVISION
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagiosgraph/Makefile2
-rw-r--r--net-mgmt/nagiosgraph/files/patch-etc_ngshared.pm20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
index d00246e46f27..6689a275c651 100644
--- a/net-mgmt/nagiosgraph/Makefile
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagiosgraph
PORTVERSION= 1.5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= SF
diff --git a/net-mgmt/nagiosgraph/files/patch-etc_ngshared.pm b/net-mgmt/nagiosgraph/files/patch-etc_ngshared.pm
new file mode 100644
index 000000000000..fd86cc519426
--- /dev/null
+++ b/net-mgmt/nagiosgraph/files/patch-etc_ngshared.pm
@@ -0,0 +1,20 @@
+--- etc/ngshared.pm.orig 2018-01-04 17:27:27 UTC
++++ etc/ngshared.pm
+@@ -231,7 +231,7 @@ sub init {
+ my ($cgi, $params) = getparams();
+ getdebug($app, $params->{host}, $params->{service});
+
+- $errmsg = readi18nfile($cgi->param('language'));
++ $errmsg = readi18nfile($cgi->multi_param('language'));
+ if ($errmsg ne q()) {
+ debug(DBWRN, $errmsg);
+ }
+@@ -381,7 +381,7 @@ sub getparams {
+ my @rval = $cgi->param($ii);
+ $rval{$ii} = \@rval;
+ } elsif ($ii eq 'db' || $ii eq 'label') {
+- $rval{$ii} = [$cgi->param($ii),];
++ $rval{$ii} = [$cgi->multi_param($ii),];
+ } else {
+ $rval{$ii} = $cgi->param($ii);
+ }