aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-26 02:04:32 +0800
committerpav <pav@FreeBSD.org>2005-11-26 02:04:32 +0800
commit21c6a46fbed894a0bfd7cbeea7d6efde128258b4 (patch)
treedf67922eaac79a502d1d7ff44c33bf1a5aa44234 /net-mgmt
parentd972d779a2310e31fa43754ef3f40a4ef76c145a (diff)
downloadfreebsd-ports-gnome-21c6a46fbed894a0bfd7cbeea7d6efde128258b4.tar.gz
freebsd-ports-gnome-21c6a46fbed894a0bfd7cbeea7d6efde128258b4.tar.zst
freebsd-ports-gnome-21c6a46fbed894a0bfd7cbeea7d6efde128258b4.zip
Aircrack is a set of tools for auditing wireless networks:
* airodump: 802.11 packet capture program * aireplay: 802.11 packet injection program * aircrack: static WEP and WPA-PSK key cracker * airdecap: decrypts WEP/WPA capture files * arpforge: forges ARP packets At the moment airodump and aireplay cannot be built on FreeBSD PR: ports/88870 Submitted by: Lars Engels <lars.engels@0x20.net>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/aircrack/Makefile47
-rw-r--r--net-mgmt/aircrack/distinfo3
-rw-r--r--net-mgmt/aircrack/pkg-descr14
-rw-r--r--net-mgmt/aircrack/pkg-message9
5 files changed, 74 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 3036eafa4837..1dbffcc446b7 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -7,6 +7,7 @@
SUBDIR += TkTopNetFlows
SUBDIR += aggregate
SUBDIR += aguri
+ SUBDIR += aircrack
SUBDIR += airport
SUBDIR += angst
SUBDIR += annextools
diff --git a/net-mgmt/aircrack/Makefile b/net-mgmt/aircrack/Makefile
new file mode 100644
index 000000000000..2f48a6dd57f0
--- /dev/null
+++ b/net-mgmt/aircrack/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: aircrack
+# Date created: 25 Nov 2005
+# Whom: Lars Engels <lars.engels@0x20.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aircrack
+PORTVERSION= 2.41
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.cr0.net:8040/code/network/ \
+ http://100h.org/wlan/aircrack/ \
+ http://100h.org/wlan/aircrack/archives/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lars.engels@0x20.net
+COMMENT= Aircrack is a set of tools for auditing wireless networks
+
+ALL_TARGET= aircrack airdecap arpforge mergeivs pcap2ivs
+
+PLIST_FILES= bin/aircrack bin/airdecap bin/arpforge bin/mergeivs bin/pcap2ivs
+PORTDOCS= *
+
+USE_REINPLACE= yes
+
+pre-fetch:
+ @${CAT} ${PKGMESSAGE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/aircrack ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/airdecap ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/arpforge ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mergeivs ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pcap2ivs ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/aircrack/distinfo b/net-mgmt/aircrack/distinfo
new file mode 100644
index 000000000000..59febb4d209d
--- /dev/null
+++ b/net-mgmt/aircrack/distinfo
@@ -0,0 +1,3 @@
+MD5 (aircrack-2.41.tgz) = 05a37c8a165efb11ea226829c809deb3
+SHA256 (aircrack-2.41.tgz) = 0273c476875e5dd09c7e15e8de58ed18fa9f5f2f9482a78e4171b3f56d75efa4
+SIZE (aircrack-2.41.tgz) = 480946
diff --git a/net-mgmt/aircrack/pkg-descr b/net-mgmt/aircrack/pkg-descr
new file mode 100644
index 000000000000..82b9e2d55449
--- /dev/null
+++ b/net-mgmt/aircrack/pkg-descr
@@ -0,0 +1,14 @@
+aircrack is a set of tools for auditing wireless networks:
+
+ * airodump: 802.11 packet capture program
+ * aireplay: 802.11 packet injection program
+ * aircrack: static WEP and WPA-PSK key cracker
+ * airdecap: decrypts WEP/WPA capture files
+ * arpforge: forges ARP packets
+
+At the moment airodump and aireplay cannot be built on FreeBSD.
+
+WWW: http://www.cr0.net:8040/code/network/aircrack/
+
+- Lars Engels
+lars.engels@0x20.net
diff --git a/net-mgmt/aircrack/pkg-message b/net-mgmt/aircrack/pkg-message
new file mode 100644
index 000000000000..28a8a3fb37d4
--- /dev/null
+++ b/net-mgmt/aircrack/pkg-message
@@ -0,0 +1,9 @@
+====
+Attention!
+
+Of the aircrack suite only airdecap, arpforge and aircrack are working
+with FreeBSD. Airump and aireplay are too Linux-specific to run at the
+moment.
+However aircrack can handle kismet's dumpfile so there is only no
+FreeBSD equivalent to aireplay.
+====