aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-08-24 22:55:36 +0800
committeritetcu <itetcu@FreeBSD.org>2007-08-24 22:55:36 +0800
commit2b473b295ca82ac781cc36c03245c4425a4ed39c (patch)
treef56557988947498321b31c52de18e97bb504a48a /net-mgmt
parent82087af302bfdcf5f7cf17c7855790b6e2aade9a (diff)
downloadfreebsd-ports-gnome-2b473b295ca82ac781cc36c03245c4425a4ed39c.tar.gz
freebsd-ports-gnome-2b473b295ca82ac781cc36c03245c4425a4ed39c.tar.zst
freebsd-ports-gnome-2b473b295ca82ac781cc36c03245c4425a4ed39c.zip
Open Computer and Software Inventory Next Generation is an application designed
to help a network or system administrator keep track of the computers configuration and software that are installed on the network WWW: http://www.ocsinventory-ng.org/ PR: ports/115520 Submitted by: Dennis Cabooter
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/ocsinventory-agent/Makefile28
-rw-r--r--net-mgmt/ocsinventory-agent/distinfo3
-rw-r--r--net-mgmt/ocsinventory-agent/pkg-descr5
-rw-r--r--net-mgmt/ocsinventory-agent/pkg-plist130
5 files changed, 167 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 4fea5a1ed964..4ad02c02b1c3 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -143,6 +143,7 @@
SUBDIR += nsca-client
SUBDIR += nstreams
SUBDIR += ocs-unix-agent
+ SUBDIR += ocsinventory-agent
SUBDIR += openlldp
SUBDIR += openvmps
SUBDIR += oproute
diff --git a/net-mgmt/ocsinventory-agent/Makefile b/net-mgmt/ocsinventory-agent/Makefile
new file mode 100644
index 000000000000..779d69a7c920
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ocs-unix-agent
+# Date created: 14 August 2007
+# Whom: Dennis Cabooter
+#
+# $FreeBSD$
+#
+
+PORTNAME= Ocsinventory
+PORTVERSION= 0.0.6
+CATEGORIES= net-mgmt
+MASTER_SITES= http://nana.rulezlan.org/~goneri/ocsinventory-agent/
+PKGNAMESUFFIX= -Agent
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= freebsd@rootxs.org
+COMMENT= Keep track of the computers configuration and software
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Net/IP.pm:${PORTSDIR}/net-mgmt/p5-Net-IP \
+ ${SITE_PERL}/Proc/Daemon.pm:${PORTSDIR}/devel/p5-Proc-Daemon \
+ dmidecode:${PORTSDIR}/sysutils/dmidecode \
+ lspci:${PORTSDIR}/sysutils/pciutils
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/ocsinventory-agent/distinfo b/net-mgmt/ocsinventory-agent/distinfo
new file mode 100644
index 000000000000..ac48dce30faf
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/distinfo
@@ -0,0 +1,3 @@
+MD5 (Ocsinventory-Agent-0.0.6.tar.gz) = b1173d08dd12a26c267ea787dc145e2f
+SHA256 (Ocsinventory-Agent-0.0.6.tar.gz) = 141d5e2be8d3473ecda8ed2eb68a187147b85db27f219ca6d716fec7f49fac26
+SIZE (Ocsinventory-Agent-0.0.6.tar.gz) = 64708
diff --git a/net-mgmt/ocsinventory-agent/pkg-descr b/net-mgmt/ocsinventory-agent/pkg-descr
new file mode 100644
index 000000000000..2157af66868c
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/pkg-descr
@@ -0,0 +1,5 @@
+Open Computer and Software Inventory Next Generation is an application designed
+to help a network or system administrator keep track of the computers
+configuration and software that are installed on the network
+
+WWW: http://www.ocsinventory-ng.org/
diff --git a/net-mgmt/ocsinventory-agent/pkg-plist b/net-mgmt/ocsinventory-agent/pkg-plist
new file mode 100644
index 000000000000..f7ed7b7bfa8d
--- /dev/null
+++ b/net-mgmt/ocsinventory-agent/pkg-plist
@@ -0,0 +1,130 @@
+bin/ocsinventory-agent
+%%SITE_PERL%%/Ocsinventory/Agent/AccountConfig.pm
+%%SITE_PERL%%/Ocsinventory/Agent/AccountInfo.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/AccessLog.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/DeviceID.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Controller.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Domains.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Drives.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Hardware.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/IPv4.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Mem.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Memory.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Modems.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Networks.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Slots.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Software.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Sounds.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Storages.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Users.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX/Videos.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Archs/Alpha.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Archs/I386.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Archs/Sgimips.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Archs/Sparc.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Domains.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Drives.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/IPv4.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Mem.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Networks.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Storages.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Sys.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Uptime.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Bios.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Memory.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Ports.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode/Slots.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Hostname.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci/Controllers.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci/Modems.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci/Sounds.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci/Videos.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/BSDpkg.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Deb.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/Gentoo.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging/RPM.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Screen.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Users.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/I386.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs/PowerPC.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Controllers.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Debian.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Fedora.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Gentoo.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Knoppix.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Mandrake.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Mandriva.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Redhat.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Slackware.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/SuSE.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Trustix.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro/Ubuntu.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Domains.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Drives.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Mem.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network/IPv4.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network/Networks.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sounds.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Storages.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Sys.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Uptime.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/MacOS.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Bios.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/CPU.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Controllers.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Domains.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Drives.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/IPv4.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Mem.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Memory.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Networks.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Packages.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Slots.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Storages.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris/Users.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Common.pm
+%%SITE_PERL%%/Ocsinventory/Agent/CompatibilityLayer.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Config.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Network.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Option/Download.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Option/Ipdiscover.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Option/Update.pm
+%%SITE_PERL%%/Ocsinventory/Agent/Pid.pm
+%%SITE_PERL%%/Ocsinventory/Agent/XML/Inventory.pm
+%%SITE_PERL%%/Ocsinventory/Agent/XML/Prolog.pm
+%%SITE_PERL%%/Ocsinventory/Compress.pm
+%%SITE_PERL%%/Ocsinventory/Logger.pm
+%%SITE_PERL%%/Ocsinventory/LoggerBackend/File.pm
+%%SITE_PERL%%/Ocsinventory/LoggerBackend/Stderr.pm
+%%SITE_PERL%%/Ocsinventory/LoggerBackend/Syslog.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Ocsinventory-Agent/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Ocsinventory-Agent
+@dirrm %%SITE_PERL%%/Ocsinventory/LoggerBackend
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/XML
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Option
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Solaris
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Network
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Distro
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux/Archs
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Linux
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Packaging
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Lspci
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic/Dmidecode
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/Generic
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD/Archs
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/BSD
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS/AIX
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend/OS
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent/Backend
+@dirrm %%SITE_PERL%%/Ocsinventory/Agent
+@dirrm %%SITE_PERL%%/Ocsinventory