aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
committeraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
commit4539b36e07dc5d3a00796c31225b2da419544ef0 (patch)
tree59a0148ef943ecb5bc12a830cc669c801d3c91f8 /net-mgmt
parenta7f25a26617517dba99672639956e265390f576a (diff)
downloadfreebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.gz
freebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.zst
freebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.zip
- Convert to new perl framework
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/netspoc/Makefile3
-rw-r--r--net-mgmt/p5-Data-Validate-IP/Makefile3
-rw-r--r--net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile3
-rw-r--r--net-mgmt/p5-Mon/Makefile3
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/Makefile3
-rw-r--r--net-mgmt/p5-Net-IPv6Addr/Makefile3
-rw-r--r--net-mgmt/p5-SNMP-Simple/Makefile3
-rw-r--r--net-mgmt/p5-SNMP-Util/Makefile3
8 files changed, 16 insertions, 8 deletions
diff --git a/net-mgmt/netspoc/Makefile b/net-mgmt/netspoc/Makefile
index 4053e109545e..19cd574edf0e 100644
--- a/net-mgmt/netspoc/Makefile
+++ b/net-mgmt/netspoc/Makefile
@@ -18,7 +18,8 @@ COMMENT= A Network Security Policy Compiler
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= netspoc.1 print-group.1
MAN3= Netspoc.3
diff --git a/net-mgmt/p5-Data-Validate-IP/Makefile b/net-mgmt/p5-Data-Validate-IP/Makefile
index d6decf67be80..d14c4479096b 100644
--- a/net-mgmt/p5-Data-Validate-IP/Makefile
+++ b/net-mgmt/p5-Data-Validate-IP/Makefile
@@ -14,7 +14,8 @@ COMMENT= Common data validation methods for IPs
BUILD_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Validate::IP.3
diff --git a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile
index 86217161f55e..668bbc58519e 100644
--- a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile
+++ b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= FusionInventory::Agent::Task::NetDiscovery.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/p5-Mon/Makefile b/net-mgmt/p5-Mon/Makefile
index 0399f41bb5fa..c2e10e2cadc4 100644
--- a/net-mgmt/p5-Mon/Makefile
+++ b/net-mgmt/p5-Mon/Makefile
@@ -15,7 +15,8 @@ DISTNAME= Mon-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl module that supports mon, a network and system monitoring daemon
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Mon::SNMP.3 \
Mon::Client.3 \
diff --git a/net-mgmt/p5-Net-IPv4Addr/Makefile b/net-mgmt/p5-Net-IPv4Addr/Makefile
index 3f62be93d9a0..f378c13cb352 100644
--- a/net-mgmt/p5-Net-IPv4Addr/Makefile
+++ b/net-mgmt/p5-Net-IPv4Addr/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for manipulating IPv4 addresses
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= ipv4calc.1
MAN3= Net::IPv4Addr.3
diff --git a/net-mgmt/p5-Net-IPv6Addr/Makefile b/net-mgmt/p5-Net-IPv6Addr/Makefile
index ed694d425851..71641bcbc985 100644
--- a/net-mgmt/p5-Net-IPv6Addr/Makefile
+++ b/net-mgmt/p5-Net-IPv6Addr/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Net-IPv4Addr>=0:${PORTSDIR}/net-mgmt/p5-Net-IPv4Addr \
p5-Math-Base85>=0:${PORTSDIR}/math/p5-Math-Base85
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::IPv6Addr.3
diff --git a/net-mgmt/p5-SNMP-Simple/Makefile b/net-mgmt/p5-SNMP-Simple/Makefile
index 6b8f9a54ffb3..17e5b14a2a7b 100644
--- a/net-mgmt/p5-SNMP-Simple/Makefile
+++ b/net-mgmt/p5-SNMP-Simple/Makefile
@@ -17,7 +17,8 @@ COMMENT= Shortcuts for when using p5-SNMP
RUN_DEPENDS= net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SNMP::Simple.3
diff --git a/net-mgmt/p5-SNMP-Util/Makefile b/net-mgmt/p5-SNMP-Util/Makefile
index f6489c152589..7f8faec00aa7 100644
--- a/net-mgmt/p5-SNMP-Util/Makefile
+++ b/net-mgmt/p5-SNMP-Util/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp
EXTRA_PATCHES= ${PATCHDIR}/extra-net-snmp-patch-Makefile.PL
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SNMP::Util.3