aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-05-15 19:38:21 +0800
committerbsam <bsam@FreeBSD.org>2013-05-15 19:38:21 +0800
commit4a07f4a50cac07c8719859f9f8b9d4a0dfd76611 (patch)
treedd6187685767501035e0aa43d399b9447f4554ce /net-mgmt
parent58e28fae1c2ef42664060309b4d68cd90a27b9c1 (diff)
downloadfreebsd-ports-gnome-4a07f4a50cac07c8719859f9f8b9d4a0dfd76611.tar.gz
freebsd-ports-gnome-4a07f4a50cac07c8719859f9f8b9d4a0dfd76611.tar.zst
freebsd-ports-gnome-4a07f4a50cac07c8719859f9f8b9d4a0dfd76611.zip
. add new option MODBUS (off by default); [1]
. add a mandatory dependency upon libinotify; [2] . bump PORTREVISION. [2] while I'm here: . pet portlint: remove whitespace before end of line; . add a mandatory dependency upon libinotify to the accompanying port (net-mgmt/collectd) and bump PORTREVISION. PR: ports/178637 [1] ports/178634 [2] Submitted by: bsam (me) Approved by: ports@bsdserwis.com (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile4
-rw-r--r--net-mgmt/collectd5/Makefile18
-rw-r--r--net-mgmt/collectd5/files/patch-src_modbus.c12
-rw-r--r--net-mgmt/collectd5/pkg-plist2
4 files changed, 31 insertions, 5 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 07437a702b8e..f48e5f210676 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -3,13 +3,15 @@
PORTNAME= collectd
PORTVERSION= 4.10.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
MAINTAINER= ports@bsdserwis.com
COMMENT= Systems & network statistics collection daemon
+LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf autoheader automake libltdl
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index e526da1706e7..3ea5fb637fcb 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -3,13 +3,15 @@
PORTNAME= collectd
PORTVERSION= 5.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
MAINTAINER= ports@bsdserwis.com
COMMENT= Systems & network statistics collection daemon
+LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
+
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -22,7 +24,7 @@ OPTIONS_DEFINE= CGI BIND DEBUG GCRYPT VIRT
OPTIONS_GROUP= INPUT OUTPUT
OPTIONS_GROUP_OUTPUT= RRDTOOL RRDCACHED WRITE_GRAPHITE WRITE_HTTP NOTIFYEMAIL
OPTIONS_GROUP_INPUT= APACHE APCUPS CURL CURL_JSON CURL_XML DBI DISK GCRYPT \
- NUTUPS INTERFACE IPMI MBMON MEMCACHED MYSQL NGINX \
+ NUTUPS INTERFACE IPMI MBMON MEMCACHED MODBUS MYSQL NGINX \
OPENVPN PDNS PGSQL PING PYTHON ROUTEROS SNMP TABLE \
TOKYOTYRANT VARNISH XMMS
@@ -46,6 +48,7 @@ INTERFACE_DESC= Network interfaces (libstatgrab)
IPMI_DESC= IPMI plugin (openipmi)
MBMON_DESC= MBMon
MEMCACHED_DESC= Memcached
+MODBUS_DESC= Modbus support via libmodbus
MYSQL_DESC= MySQL
NOTIFYEMAIL_DESC= Email notifications (libesmtp)
NGINX_DESC= Nginx
@@ -111,8 +114,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-match_timediff \
--disable-match_value \
--disable-memcachec \
- --disable-modbus \
- --without-libmodbus \
--disable-multimeter \
--disable-netapp \
--without-libnetapp \
@@ -289,6 +290,15 @@ CONFIGURE_ARGS+=--disable-memcached --without-libmemcached
PLIST_SUB+= MEMCACHED="@comment "
.endif
+.if ${PORT_OPTIONS:MMODBUS}
+CONFIGURE_ARGS+=--enable-modbus
+LIB_DEPENDS+= modbus:${PORTSDIR}/comms/libmodbus
+PLIST_SUB+= MODBUS=""
+.else
+CONFIGURE_ARGS+=--disable-modbus
+PLIST_SUB+= MODBUS="@comment "
+.endif
+
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+=--enable-mysql
diff --git a/net-mgmt/collectd5/files/patch-src_modbus.c b/net-mgmt/collectd5/files/patch-src_modbus.c
new file mode 100644
index 000000000000..8c5d9be78e45
--- /dev/null
+++ b/net-mgmt/collectd5/files/patch-src_modbus.c
@@ -0,0 +1,12 @@
+--- src/modbus.c.orig 2013-01-27 17:47:18.246255000 +0400
++++ src/modbus.c 2013-05-14 18:40:05.000000000 +0400
+@@ -25,6 +25,9 @@
+ #include "plugin.h"
+ #include "configfile.h"
+
++/* FreeBSD needs this */
++#include <sys/socket.h>
++
+ #include <netdb.h>
+
+ #include <modbus/modbus.h>
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 2d904067bf55..f8dec079d2c5 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -56,6 +56,8 @@ lib/collectd/load.la
lib/collectd/load.so
lib/collectd/logfile.la
lib/collectd/logfile.so
+%%MODBUS%%lib/collectd/modbus.la
+%%MODBUS%%lib/collectd/modbus.so
%%MBMON%%lib/collectd/mbmon.la
%%MBMON%%lib/collectd/mbmon.so
%%MEMCACHED%%lib/collectd/memcached.la