aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-27 18:39:00 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-27 18:39:00 +0800
commit5afb3656dd260a4f16d06bbbefcdcd2ca93e38de (patch)
treee20109be1cb9e8f4947e7dc4d167ad96140749b0 /net-mgmt
parenta887b5b524f0c87d11d3ee18c68a835c4fc0acc0 (diff)
downloadfreebsd-ports-gnome-5afb3656dd260a4f16d06bbbefcdcd2ca93e38de.tar.gz
freebsd-ports-gnome-5afb3656dd260a4f16d06bbbefcdcd2ca93e38de.tar.zst
freebsd-ports-gnome-5afb3656dd260a4f16d06bbbefcdcd2ca93e38de.zip
Attempt to fix inner makefiles so the port (and its slaves) are make jobs
(-jX) safe. Reported by: pointyhat-west
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/netmagis-common/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-mgmt/netmagis-common/Makefile b/net-mgmt/netmagis-common/Makefile
index 0e4cbce13ece..d801d793d4c6 100644
--- a/net-mgmt/netmagis-common/Makefile
+++ b/net-mgmt/netmagis-common/Makefile
@@ -65,6 +65,13 @@ ALL_TARGET=nothing
INSTALL_TARGET= install${PKGNAMESUFFIX}
+# Change "cd foo; make" into "$(MAKE) -C foo" to unbreak parallel builds
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name Makefile -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -E 's,cd(.+) (;|&&) make,$$(MAKE) -C\1,'
+ ${REINPLACE_CMD} -E 's,cd (.+) ; (ln -s en ),\2\1/,' \
+ ${WRKSRC}/www/Makefile
+
.if !target(post-install)
post-install:
@if [ -f ${PKGMESSAGE} ] ; then ${CAT} ${PKGMESSAGE} ; fi