aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-04-07 19:15:09 +0800
committerdemon <demon@FreeBSD.org>2014-04-07 19:15:09 +0800
commit617fa1a57150ae3a8ea92e97aa87163da5a7d6d9 (patch)
tree44a5f0d8dec73de1e88d211b36a110d2d207aa67 /net-mgmt
parent3982217186d3c7bb9bce00554982c8e806abf333 (diff)
downloadfreebsd-ports-gnome-617fa1a57150ae3a8ea92e97aa87163da5a7d6d9.tar.gz
freebsd-ports-gnome-617fa1a57150ae3a8ea92e97aa87163da5a7d6d9.tar.zst
freebsd-ports-gnome-617fa1a57150ae3a8ea92e97aa87163da5a7d6d9.zip
Add RIEMANN option.
PR: 184458 Submitted by: maintainer
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile12
-rw-r--r--net-mgmt/collectd5/pkg-plist3
2 files changed, 14 insertions, 1 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index c7f6755025d9..f0a07db8e18b 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc:${PORTSDIR}/devel/gli
OPTIONS_DEFINE= CGI DEBUG GCRYPT VIRT
OPTIONS_GROUP= INPUT OUTPUT
-OPTIONS_GROUP_OUTPUT= RRDTOOL NOTIFYEMAIL NOTIFYDESKTOP
+OPTIONS_GROUP_OUTPUT= RRDTOOL NOTIFYEMAIL NOTIFYDESKTOP RIEMANN
OPTIONS_GROUP_INPUT= CURL DBI JSON MEMCACHEC MODBUS MONGODB MYSQL \
NUTUPS PGSQL PING PYTHON RABBITMQ REDIS \
ROUTEROS SIGROK SNMP STATGRAB TOKYOTYRANT XML XMMS
@@ -42,6 +42,7 @@ PING_DESC= Enable ping plugin
PYTHON_DESC= Enable python-based plugins
RABBITMQ_DESC= Enable rabbitmq-based plugins
REDIS_DESC= Enable redis-based plugins
+RIEMANN_DESC= Enable write_riemann plugin (via protobuf-c)
ROUTEROS_DESC= Enable routeros plugin
RRDTOOL_DESC= Enable rrdtool plugin (also rrdcached plugin)
SIGROK_DESC= Enable sigrok plugin
@@ -335,6 +336,15 @@ CONFIGURE_ARGS+=--without-libcredis \
PLIST_SUB+= REDIS="@comment "
.endif
+.if ${PORT_OPTIONS:MRIEMANN}
+LIB_DEPENDS+= libprotobuf-c.so:${PORTSDIR}/devel/protobuf-c
+CONFIGURE_ARGS+=--enable-write_riemann
+PLIST_SUB+= RIEMANN=""
+.else
+CONFIGURE_ARGS+=--disable-write_riemann
+PLIST_SUB+= RIEMANN="@comment "
+.endif
+
.if ${PORT_OPTIONS:MROUTEROS}
LIB_DEPENDS+= librouteros.so:${PORTSDIR}/net/librouteros
CONFIGURE_ARGS+=--with-librouteros=${LOCALBASE} --enable-routeros
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 9bec24478af0..de99caa35a0f 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -232,6 +232,9 @@ lib/collectd/write_graphite.la
%%REDIS%%lib/collectd/write_redis.a
%%REDIS%%lib/collectd/write_redis.so
%%REDIS%%lib/collectd/write_redis.la
+%%RIEMANN%%lib/collectd/write_riemann.a
+%%RIEMANN%%lib/collectd/write_riemann.so
+%%RIEMANN%%lib/collectd/write_riemann.la
%%XMMS%%lib/collectd/xmms.a
%%XMMS%%lib/collectd/xmms.so
%%XMMS%%lib/collectd/xmms.la