aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormux <mux@FreeBSD.org>2007-04-12 00:20:53 +0800
committermux <mux@FreeBSD.org>2007-04-12 00:20:53 +0800
commit667261a1156785940d1f8c9ad71225e26fe94057 (patch)
tree261642d17f7183c561ffb01291aad1144252f097 /net-mgmt
parentd7583fcd1dd05bcbca188e22a5fbca55a9371911 (diff)
downloadfreebsd-ports-gnome-667261a1156785940d1f8c9ad71225e26fe94057.tar.gz
freebsd-ports-gnome-667261a1156785940d1f8c9ad71225e26fe94057.tar.zst
freebsd-ports-gnome-667261a1156785940d1f8c9ad71225e26fe94057.zip
Add a patch taken from CVS to fix EXEC actions handling with monitoring
thresholds, and bump PORTREVISION.
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cricket/Makefile2
-rw-r--r--net-mgmt/cricket/files/patch-lib-Monitor.pm19
2 files changed, 20 insertions, 1 deletions
diff --git a/net-mgmt/cricket/Makefile b/net-mgmt/cricket/Makefile
index 2dc953e3b76f..d941dea259a8 100644
--- a/net-mgmt/cricket/Makefile
+++ b/net-mgmt/cricket/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cricket
PORTVERSION= 1.0.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-mgmt/cricket/files/patch-lib-Monitor.pm b/net-mgmt/cricket/files/patch-lib-Monitor.pm
new file mode 100644
index 000000000000..71e006604aa9
--- /dev/null
+++ b/net-mgmt/cricket/files/patch-lib-Monitor.pm
@@ -0,0 +1,19 @@
+--- lib/Monitor.pm.orig 2004/02/19 15:58:07 1.31
++++ lib/Monitor.pm 2007/01/21 04:17:22 1.32
+@@ -526,14 +526,15 @@
+ sub alarmExec {
+ my ($args, $action) = @_;
+ my $alarmArgs = $$args[7];
+- system($alarmArgs->[0]);
+
+ if ($action eq 'ADD') {
++ system($alarmArgs->[0]);
+ Info("Monitor: Triggered event with system command '".
+ $alarmArgs->[0]."' .");
+ }
+
+ else {
++ system($alarmArgs->[1]);
+ Info("Monitor: Cleared event with shell command '".
+ $alarmArgs->[1]."' .");
+ }