aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2012-06-05 03:43:12 +0800
committerlme <lme@FreeBSD.org>2012-06-05 03:43:12 +0800
commit80d703c9ef7eb2e7fd10e92fecaaa878a8eb3cff (patch)
treeba3bf1682c701f593ae3dfcc9f7ec6bf2910bdc1 /net-mgmt
parenta68005e4ae4ba51f6493bff27244036965308527 (diff)
downloadfreebsd-ports-gnome-80d703c9ef7eb2e7fd10e92fecaaa878a8eb3cff.tar.gz
freebsd-ports-gnome-80d703c9ef7eb2e7fd10e92fecaaa878a8eb3cff.tar.zst
freebsd-ports-gnome-80d703c9ef7eb2e7fd10e92fecaaa878a8eb3cff.zip
Use the new options framework.
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/aircrack-ng/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/net-mgmt/aircrack-ng/Makefile b/net-mgmt/aircrack-ng/Makefile
index 0091e8b4c4f8..5ea4b47670fa 100644
--- a/net-mgmt/aircrack-ng/Makefile
+++ b/net-mgmt/aircrack-ng/Makefile
@@ -32,9 +32,17 @@ PLIST_FILES= bin/aircrack-ng bin/airdecap-ng bin/airdecloak-ng \
sbin/airserv-ng sbin/airtun-ng sbin/easside-ng \
sbin/tkiptun-ng sbin/wesside-ng
-OPTIONS= SQLITE "Use SQLite for storing pre-computed key tables" off
+OPTIONS_DEFINE= SQLITE
+SQLITE_DESC= Use SQLite for storing pre-computed key tables
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_SQLITE= yes
+MAKE_ARGS+= SQLITE=true
+MAN1+= airolib-ng.1
+PLIST_FILES+= bin/airolib-ng
+.endif
.if ${ARCH} == "powerpc"
BROKEN= Does not compile on powerpc
@@ -43,13 +51,6 @@ BROKEN= Does not compile on powerpc
BROKEN= Does not compile on sparc64-9
.endif
-.if defined(WITH_SQLITE)
-USE_SQLITE= yes
-MAKE_ARGS+= SQLITE=true
-MAN1+= airolib-ng.1
-PLIST_FILES+= bin/airolib-ng
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's|= /usr/local|= ${PREFIX}|' \
@@ -74,4 +75,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>