aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-08-04 21:05:44 +0800
committerwg <wg@FreeBSD.org>2013-08-04 21:05:44 +0800
commitb91656f64390adbe9380ffe9a39ecf64197bae93 (patch)
tree04f4fd630019c776feaf7f9296710fc6de4984d2 /net-mgmt
parent28c3ad54efa3cc58af6a7af9d7729926bb6a5d64 (diff)
downloadfreebsd-ports-gnome-b91656f64390adbe9380ffe9a39ecf64197bae93.tar.gz
freebsd-ports-gnome-b91656f64390adbe9380ffe9a39ecf64197bae93.tar.zst
freebsd-ports-gnome-b91656f64390adbe9380ffe9a39ecf64197bae93.zip
net-mgmt/collectd5: fix PYTHON option
- Fix PYTHON option (use ${PYTHON_CMD}) PR: ports/180838 Submitted by: wg (myself) Approved by: maintainer
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd5/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index a76ff0a0d48a..81378101ff55 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= collectd
PORTVERSION= 5.3.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -17,7 +17,7 @@ USE_AUTOTOOLS= autoconf autoheader automake libltdl
LATEST_LINK= collectd5
-OPTIONS_DEFINE= CGI CURL DEBUG DBI GCRYPT JSON MEMCACHEC MODBUS MYSQL NUTUPS PGSQL PING PYTHON REDIS ROUTEROS RRDTOOL SNMP STATGRAB TOKYOTYRANT VIRT XML XMMS
+OPTIONS_DEFINE= CGI CURL DEBUG DBI GCRYPT JSON MEMCACHEC MODBUS MYSQL NOTIFYEMAIL NUTUPS PGSQL PING PYTHON REDIS ROUTEROS RRDTOOL SNMP STATGRAB TOKYOTYRANT VIRT XML XMMS
CGI_DESC= Install collection.cgi (requires rrdtool)
CURL_DESC= Enable curl-based plugins (apache, nginx, etc)
@@ -99,7 +99,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--without-libyajl \
--without-oracle \
--without-perl-bindings \
- --without-python
# NOTE: Plugins without external dependencies
CONFIGURE_ARGS+= \
@@ -275,12 +274,12 @@ PLIST_SUB+= PING="@comment "
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
-CONFIGURE_ARGS+=--with-python=${LOCALBASE} --enable-python
+CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} --enable-python
PLIST_SUB+= PYTHON=""
.else
+CONFIGURE_ARGS+=--without-python
PLIST_SUB+= PYTHON="@comment "
.endif
-
.if ${PORT_OPTIONS:MREDIS}
LIB_DEPENDS+= credis:${PORTSDIR}/databases/credis
CONFIGURE_ARGS+=--with-libcredis=${LOCALBASE} \