aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-02-25 04:42:17 +0800
committerzi <zi@FreeBSD.org>2014-02-25 04:42:17 +0800
commitcc21cdfc7eaa514fb3b0265fe95afcfdb325d409 (patch)
treed2e9fc74fada404d10509ab89860cef8a5b89a8d /net-mgmt
parent1b5d4c93421f863748c6c7359876b4cfae1ddd49 (diff)
downloadfreebsd-ports-gnome-cc21cdfc7eaa514fb3b0265fe95afcfdb325d409.tar.gz
freebsd-ports-gnome-cc21cdfc7eaa514fb3b0265fe95afcfdb325d409.tar.zst
freebsd-ports-gnome-cc21cdfc7eaa514fb3b0265fe95afcfdb325d409.zip
- Bring in bugfix for upstream bug #2525 to resolve snmpd crash
- Remove unneeded test.t from FILESDIR - Bump PORTREVISION
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c13
-rw-r--r--net-mgmt/net-snmp/files/test.t12
3 files changed, 13 insertions, 14 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 5aa39286fe69..1a9727162a7c 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c b/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c
index 572462466418..2aee6f9ce65f 100644
--- a/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c
+++ b/net-mgmt/net-snmp/files/patch-agent__mibgroup__host__data_access__swrun_kinfo.c
@@ -1,5 +1,5 @@
--- ./agent/mibgroup/host/data_access/swrun_kinfo.c.orig 2012-10-09 18:28:58.000000000 -0400
-+++ ./agent/mibgroup/host/data_access/swrun_kinfo.c 2013-02-12 18:55:42.000000000 -0500
++++ ./agent/mibgroup/host/data_access/swrun_kinfo.c 2014-02-24 14:33:08.000000000 -0500
@@ -186,7 +186,7 @@
#if HAVE_KVM_GETPROC2
argv = kvm_getargv2( kd, &(proc_table[i]), 0);
@@ -9,3 +9,14 @@
#endif
entry->hrSWRunName_len = snprintf(entry->hrSWRunName,
+@@ -219,8 +219,8 @@
+ if (argv)
+ argv++; /* Skip argv[0] */
+ while ( argv && *argv ) {
+- strcat(buf, " ");
+- strcat(buf, *argv);
++ strncat(buf, " ", sizeof(buf) - strlen(buf) - 1);
++ strncat(buf, *argv, sizeof(buf) - strlen(buf) - 1);
+ argv++;
+ }
+ entry->hrSWRunParameters_len = snprintf(entry->hrSWRunParameters,
diff --git a/net-mgmt/net-snmp/files/test.t b/net-mgmt/net-snmp/files/test.t
deleted file mode 100644
index cca9d9ed4191..000000000000
--- a/net-mgmt/net-snmp/files/test.t
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/usr/bin/perl -w
-#
-# $FreeBSD$
-
-use strict;
-use Test::More tests => 1;
-
-my $cmd = 'snmpwalk -c public -v 1 localhost';
-
-# ports/86572
-my $output = `$cmd hrSWRunType`;
-like($output, qr/operatingSystem/, 'hrSWRunType');