aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-02-07 21:29:40 +0800
committermat <mat@FreeBSD.org>2014-02-07 21:29:40 +0800
commitcfa4dd2908f4aa11c3178579c99bab005244d232 (patch)
treea064bc73587b4378b09616c8ff24ca59cba2986f /net-mgmt
parent664499657c0781db0156e48b44b30aa95bc0f38d (diff)
downloadfreebsd-ports-gnome-cfa4dd2908f4aa11c3178579c99bab005244d232.tar.gz
freebsd-ports-gnome-cfa4dd2908f4aa11c3178579c99bab005244d232.tar.zst
freebsd-ports-gnome-cfa4dd2908f4aa11c3178579c99bab005244d232.zip
It seems nagios 4 can't build without the event broker, so remove the option
and force it on. While there, replace a REINPLACE_CMD by a patch to get rid of a bsd.port.options.mk include. Reported by: demon, pkg-fallout Sponsored by: Absolight
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios4/Makefile17
-rw-r--r--net-mgmt/nagios4/files/extra-patch-html__side.php15
2 files changed, 21 insertions, 11 deletions
diff --git a/net-mgmt/nagios4/Makefile b/net-mgmt/nagios4/Makefile
index 4de403ef129c..79c2cfc21336 100644
--- a/net-mgmt/nagios4/Makefile
+++ b/net-mgmt/nagios4/Makefile
@@ -37,7 +37,8 @@ CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
--localstatedir=${NAGIOSDIR} \
--with-httpd-conf=${PREFIX}/etc \
--with-checkresult-dir=${NAGIOSDIR}/checkresults \
- --disable-statuswrl
+ --disable-statuswrl \
+ --enable-event-broker
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
@@ -70,23 +71,17 @@ NAGIOSCGIURL?= ${NAGIOSHTMURL}/cgi-bin
USERS= ${NAGIOSUSER}
GROUPS= ${NAGIOSGROUP}
-OPTIONS_DEFINE= NANOSLEEP EVENT_BROKER UNHANDLED_HACK
+OPTIONS_DEFINE= NANOSLEEP UNHANDLED_HACK
NANOSLEEP_DESC= Use nanosleep in event timing
-EVENT_BROKER_DESC= Enable event broker functionality
UNHANDLED_HACK_DESC= Display passive checks in unhandled queries
OPTIONS_SUB=
NANOSLEEP_CONFIGURE_ENABLE= nanosleep
-EVENT_BROKER_CONFIGURE_ENABLE= event-broker
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ${PORT_OPTIONS:MUNHANDLED_HACK}
- @${REINPLACE_CMD} -e 's#;serviceprops=42\&#;serviceprops=10\&#g' \
- -e 's#;hostprops=42\"#;hostprops=10\"#g' ${WRKSRC}/html/side.php
-.endif
+# sed -e 's#;serviceprops=42\&#;serviceprops=10\&#g' -e \
+# 's#;hostprops=42\"#;hostprops=10\"#g' ${WRKSRC}/html/side.php
+UNHANDLED_HACK_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-html__side.php
post-install:
@${MV} ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/config.inc.php ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/config.inc.php.sample
diff --git a/net-mgmt/nagios4/files/extra-patch-html__side.php b/net-mgmt/nagios4/files/extra-patch-html__side.php
new file mode 100644
index 000000000000..ca8355d577b7
--- /dev/null
+++ b/net-mgmt/nagios4/files/extra-patch-html__side.php
@@ -0,0 +1,15 @@
+--- ./html/side.php.orig 2013-11-25 14:16:25.000000000 +0000
++++ ./html/side.php 2014-02-07 13:14:41.000000000 +0000
+@@ -59,10 +59,10 @@
+ <a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?host=all&amp;servicestatustypes=28" target="<?php echo $link_target;?>">Problems</a>
+ <ul>
+ <li>
+-<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?host=all&amp;servicestatustypes=28" target="<?php echo $link_target;?>">Services</a> (<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?host=all&amp;type=detail&amp;hoststatustypes=3&amp;serviceprops=42&amp;servicestatustypes=28" target="<?php echo $link_target;?>">Unhandled</a>)
++<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?host=all&amp;servicestatustypes=28" target="<?php echo $link_target;?>">Services</a> (<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?host=all&amp;type=detail&amp;hoststatustypes=3&amp;serviceprops=10&amp;servicestatustypes=28" target="<?php echo $link_target;?>">Unhandled</a>)
+ </li>
+ <li>
+-<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?hostgroup=all&amp;style=hostdetail&amp;hoststatustypes=12" target="<?php echo $link_target;?>">Hosts</a> (<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?hostgroup=all&amp;style=hostdetail&amp;hoststatustypes=12&amp;hostprops=42" target="<?php echo $link_target;?>">Unhandled</a>)
++<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?hostgroup=all&amp;style=hostdetail&amp;hoststatustypes=12" target="<?php echo $link_target;?>">Hosts</a> (<a href="<?php echo $cfg["cgi_base_url"];?>/status.cgi?hostgroup=all&amp;style=hostdetail&amp;hoststatustypes=12&amp;hostprops=10" target="<?php echo $link_target;?>">Unhandled</a>)
+ </li>
+ <li><a href="<?php echo $cfg["cgi_base_url"];?>/outages.cgi" target="<?php echo $link_target;?>">Network Outages</a></li>
+ </ul>