aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2015-05-27 22:31:01 +0800
committerfeld <feld@FreeBSD.org>2015-05-27 22:31:01 +0800
commitf2b3d8059572cc19bdf3ea84cef70e657151cc9e (patch)
treee1a856f2d8462e36a87981baa7a6f49ed64dc654 /net-mgmt
parente35555bb71e941c4a46327fa2fffda67364bb96f (diff)
downloadfreebsd-ports-gnome-f2b3d8059572cc19bdf3ea84cef70e657151cc9e.tar.gz
freebsd-ports-gnome-f2b3d8059572cc19bdf3ea84cef70e657151cc9e.tar.zst
freebsd-ports-gnome-f2b3d8059572cc19bdf3ea84cef70e657151cc9e.zip
Add PYPOLLER option to add support for the Python poller wrapper
Submitted by: mat
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/observium/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index 26668b580d0c..e14b3572e619 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= observium
PORTVERSION= 0.14.11.6000
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.observium.org/
DISTNAME= ${PORTNAME}-community-latest
@@ -16,7 +16,7 @@ LICENSE= GPLv3
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= shebangfix
+USES= python shebangfix
SHEBANG_FILES= mibs/process.pl html/js/makemini.pl \
scripts/watchmaillog/watchmaillog.pl \
scripts/agent-local/postgresql.pl \
@@ -34,19 +34,21 @@ RUN_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool \
${LOCALBASE}/share/pear/Net/IPv6.php:${PORTSDIR}/net/pear-Net_IPv6 \
snmpget:${PORTSDIR}/net-mgmt/net-snmp
-OPTIONS_DEFINE= APACHEMOD FPING IPMITOOL LIBVIRT MYSQLD NAGPLUGINS NMAP SVN WMIC
-OPTIONS_DEFAULT= APACHEMOD FPING IPMITOOL LIBVIRT NAGPLUGINS NMAP SVN WMIC
+OPTIONS_DEFINE= APACHEMOD FPING IPMITOOL LIBVIRT MYSQLD NAGPLUGINS NMAP PYPOLLER SVN WMIC
+OPTIONS_DEFAULT= APACHEMOD FPING IPMITOOL LIBVIRT NAGPLUGINS NMAP PYPOLLER SVN WMIC
APACHEMOD_DESC= Use PHP with Apache 2.2+ module
FPING_DESC= Enable fping support ping monitoring
IPMITOOL_DESC= Enable support for monitoring hardware IPMI
MYSQLD_DESC= Use local MySQL server
WMIC_DESC= Enable support for WMI polling
+PYPOLLER_DESC= Enable Python Poller Wrapper
FPING_RUN_DEPENDS= fping:${PORTSDIR}/net/fping
IPMITOOL_RUN_DEPENDS= ipmitool:${PORTSDIR}/sysutils/ipmitool
LIBVIRT_RUN_DEPENDS= virsh:${PORTSDIR}/devel/libvirt
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
NMAP_RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
+PYPOLLER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>0:${PORTSDIR}/databases/py-MySQLdb
SVN_RUN_DEPENDS= svn:${PORTSDIR}/devel/subversion
WMIC_RUN_DEPENDS= wmic:${PORTSDIR}/net-mgmt/wmi-client