aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-03-08 01:47:40 +0800
committermat <mat@FreeBSD.org>2016-03-08 01:47:40 +0800
commit621e4b9e09ebbb5e91989c2d20faeac46634a5af (patch)
tree369db088e2bb6b780579e5aa7c483f9691f8163e /net-mgmt
parentad3d4daa669efdce602a38f0c26689b7aabd6a31 (diff)
downloadfreebsd-ports-gnome-621e4b9e09ebbb5e91989c2d20faeac46634a5af.tar.gz
freebsd-ports-gnome-621e4b9e09ebbb5e91989c2d20faeac46634a5af.tar.zst
freebsd-ports-gnome-621e4b9e09ebbb5e91989c2d20faeac46634a5af.zip
Update to 0.9.14
PR: 207164 Submitted by: tkato432 yahoo com Sponsored by: Absolight
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/etherape/Makefile24
-rw-r--r--net-mgmt/etherape/distinfo4
-rw-r--r--net-mgmt/etherape/files/patch-src_decode__proto.c (renamed from net-mgmt/etherape/files/patch-src__decocde_proto.c)2
-rw-r--r--net-mgmt/etherape/files/patch-src_diagram.c21
-rw-r--r--net-mgmt/etherape/files/patch-src_names.c (renamed from net-mgmt/etherape/files/patch-src__names.c)2
-rw-r--r--net-mgmt/etherape/files/patch-src_thread__resolve.c23
-rw-r--r--net-mgmt/etherape/files/patch-thread_resolve.c23
-rw-r--r--net-mgmt/etherape/pkg-plist1
8 files changed, 61 insertions, 39 deletions
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index b8e6db67d2a0..a1eef668ec0d 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -2,15 +2,15 @@
# $FreeBSD$
PORTNAME= etherape
-PORTVERSION= 0.9.13
-PORTREVISION= 2
+PORTVERSION= 0.9.14
CATEGORIES= net-mgmt gnome
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical network traffic monitor tool modeled after Etherman
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gettext gmake iconv pathfix pkgconfig
USE_GNOME= gnomedocutils libglade2 libgnomeui
@@ -18,18 +18,20 @@ GNU_CONFIGURE= yes
INSTALLS_OMF= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -export-dynamic # XXX: G_MODULE_EXPORT?
+LDFLAGS+= -L${LOCALBASE}/lib
-PORTDOCS= *
+PORTDOCS= AUTHORS ChangeLog FAQ NEWS README README.bugs TODO
OPTIONS_DEFINE= DOCS
-post-install:
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|char \*argv)|char **argv)|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|__EXPORT__|__EXPORT_H__|' ${WRKSRC}/src/export.h
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} FAQ README* TODO ${STAGEDIR}${DOCSDIR}
-.for f in AUTHORS ChangeLog NEWS
- ${ICONV_CMD} -f latin1 -t utf-8 ${WRKSRC}/${f} > \
- ${STAGEDIR}${DOCSDIR}/${f}
-.endfor
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/net-mgmt/etherape/distinfo b/net-mgmt/etherape/distinfo
index 3b4f6aaa72ef..bf1b64fd79ed 100644
--- a/net-mgmt/etherape/distinfo
+++ b/net-mgmt/etherape/distinfo
@@ -1,2 +1,2 @@
-SHA256 (etherape-0.9.13.tar.gz) = 2a3d2a28b824ce4797529bb90d19a213d80e70f5b3f0cc5f455379aac31c09f7
-SIZE (etherape-0.9.13.tar.gz) = 1399211
+SHA256 (etherape-0.9.14.tar.gz) = 7447435ef64e569d8e10b6a0525806c01f527e76ae9eed5c84821f545f357ade
+SIZE (etherape-0.9.14.tar.gz) = 1438255
diff --git a/net-mgmt/etherape/files/patch-src__decocde_proto.c b/net-mgmt/etherape/files/patch-src_decode__proto.c
index e1bc96de9f01..7c89891b9573 100644
--- a/net-mgmt/etherape/files/patch-src__decocde_proto.c
+++ b/net-mgmt/etherape/files/patch-src_decode__proto.c
@@ -1,4 +1,4 @@
---- src/decode_proto.c.orig
+--- src/decode_proto.c.orig 2014-02-02 18:38:16 UTC
+++ src/decode_proto.c
@@ -27,6 +27,15 @@
#include "appdata.h"
diff --git a/net-mgmt/etherape/files/patch-src_diagram.c b/net-mgmt/etherape/files/patch-src_diagram.c
new file mode 100644
index 000000000000..62acd31ecebc
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src_diagram.c
@@ -0,0 +1,21 @@
+--- src/diagram.c.orig 2016-01-25 20:19:16 UTC
++++ src/diagram.c
+@@ -21,7 +21,18 @@
+ #include <config.h>
+ #endif
+
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_SOCKET_H
++#include <sys/socket.h>
++#endif
++#ifdef HAVE_NETINET_IN_H
++#include <netinet/in.h>
++#endif
++#ifdef HAVE_ARPA_INET_H
+ #include <arpa/inet.h>
++#endif
+
+ #include <gnome.h>
+ #include <regex.h>
diff --git a/net-mgmt/etherape/files/patch-src__names.c b/net-mgmt/etherape/files/patch-src_names.c
index d005e2025ec3..64b6aef2e5b8 100644
--- a/net-mgmt/etherape/files/patch-src__names.c
+++ b/net-mgmt/etherape/files/patch-src_names.c
@@ -1,4 +1,4 @@
---- src/names.c.orig
+--- src/names.c.orig 2014-02-02 11:30:03 UTC
+++ src/names.c
@@ -21,7 +21,18 @@
#include <config.h>
diff --git a/net-mgmt/etherape/files/patch-src_thread__resolve.c b/net-mgmt/etherape/files/patch-src_thread__resolve.c
new file mode 100644
index 000000000000..bc26055be7d7
--- /dev/null
+++ b/net-mgmt/etherape/files/patch-src_thread__resolve.c
@@ -0,0 +1,23 @@
+--- src/thread_resolve.c.orig 2015-06-06 07:18:29 UTC
++++ src/thread_resolve.c
+@@ -161,6 +161,10 @@ thread_pool_routine(void *dt)
+
+ pthread_mutex_unlock(&resolvemtx);
+ }
++
++ /* close mutex */
++ close_mutex();
++
+ return NULL;
+ }
+
+@@ -279,9 +283,6 @@ thread_close(void)
+ {
+ /* thread pool shutdown */
+ stop_threads();
+-
+- /* close mutex */
+- close_mutex();
+ }
+
+ const char *
diff --git a/net-mgmt/etherape/files/patch-thread_resolve.c b/net-mgmt/etherape/files/patch-thread_resolve.c
deleted file mode 100644
index dd20e557e440..000000000000
--- a/net-mgmt/etherape/files/patch-thread_resolve.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/thread_resolve.c.orig Tue Apr 25 09:08:28 2006
-+++ src/thread_resolve.c Mon May 29 00:37:45 2006
-@@ -167,6 +167,10 @@
-
- pthread_mutex_unlock(&resolvemtx);
- }
-+
-+ /* close mutex */
-+ close_mutex();
-+
- return NULL;
- }
-
-@@ -268,9 +272,6 @@
- {
- /* thread pool shutdown */
- stop_threads();
--
-- /* close mutex */
-- close_mutex();
- }
-
- /* returns 1 if the current dns implementation has a socket wich needs a select() */
diff --git a/net-mgmt/etherape/pkg-plist b/net-mgmt/etherape/pkg-plist
index 211053f9ea7c..430560086d1b 100644
--- a/net-mgmt/etherape/pkg-plist
+++ b/net-mgmt/etherape/pkg-plist
@@ -1,5 +1,4 @@
bin/etherape
-%%ETCDIR%%/services
man/man1/etherape.1.gz
share/applications/etherape.desktop
%%DATADIR%%/glade/etherape.glade