aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-10-25 00:29:51 +0800
committermva <mva@FreeBSD.org>2014-10-25 00:29:51 +0800
commit9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22 (patch)
tree68b40f3f4036b306637ebfb7679083aa441086a8 /net-mgmt
parent7cb20804acb2b46d4c0c3489dd746591f311f6de (diff)
downloadfreebsd-ports-gnome-9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22.tar.gz
freebsd-ports-gnome-9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22.tar.zst
freebsd-ports-gnome-9602e7be3cefab5a04d6cf3c09fdf9720bfb2c22.zip
- Convert ports of net-im/, net-mgmt/ and net-p2p/ to new USES=python
Approved by: portmgr (implicit)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile2
-rw-r--r--net-mgmt/collectd5/Makefile2
-rw-r--r--net-mgmt/flow-tools-ng/Makefile3
-rw-r--r--net-mgmt/flow-tools/Makefile2
-rw-r--r--net-mgmt/nagios-check_smartmon/Makefile2
-rw-r--r--net-mgmt/nagstamon/Makefile4
-rw-r--r--net-mgmt/ndpmon/Makefile2
-rw-r--r--net-mgmt/py-flowtools/Makefile5
-rw-r--r--net-mgmt/py-ipcalc/Makefile4
-rw-r--r--net-mgmt/py-ipy/Makefile5
-rw-r--r--net-mgmt/py-pyang/Makefile4
-rw-r--r--net-mgmt/py-snmp4-apps/Makefile5
-rw-r--r--net-mgmt/py-snmp4-mibs/Makefile5
-rw-r--r--net-mgmt/py-snmp4/Makefile5
-rw-r--r--net-mgmt/py-yapsnmp/Makefile3
-rw-r--r--net-mgmt/virtinst/Makefile5
16 files changed, 25 insertions, 33 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 563358e8c1a0..8e94d53396de 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -352,7 +352,7 @@ PLIST_SUB+= PING="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
CONFIGURE_ARGS+=--enable-python --with-python=${PYTHON_CMD}
PLIST_SUB+= PYTHON=""
.else
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index b50209ee8a87..c398bc1ae7a7 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -317,7 +317,7 @@ PLIST_SUB+= PING="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USES+= python
CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} --enable-python
PLIST_SUB+= PYTHON=""
.else
diff --git a/net-mgmt/flow-tools-ng/Makefile b/net-mgmt/flow-tools-ng/Makefile
index fa10e8a8065b..183c46205ac6 100644
--- a/net-mgmt/flow-tools-ng/Makefile
+++ b/net-mgmt/flow-tools-ng/Makefile
@@ -26,9 +26,8 @@ OPENSSL_USE= OPENSSL=yes
CONFLICTS= flow-tools-[0-9]*
-USES= gmake libtool tar:bzip2
+USES= gmake libtool python:run tar:bzip2
USE_LDCONFIG= yes
-USE_PYTHON_RUN= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index c96ac5674539..53039cb4b6c8 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -16,8 +16,8 @@ OPTIONS_DEFINE= MYSQL OPENSSL PGSQL
CONFLICTS= flow-tools-ng-[0-9]*
+USES= python:run
USE_GCC= any
-USE_PYTHON_RUN= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--localstatedir="${PREFIX}"
diff --git a/net-mgmt/nagios-check_smartmon/Makefile b/net-mgmt/nagios-check_smartmon/Makefile
index f242a31694a2..85a0509ae93a 100644
--- a/net-mgmt/nagios-check_smartmon/Makefile
+++ b/net-mgmt/nagios-check_smartmon/Makefile
@@ -13,7 +13,7 @@ COMMENT= Nagios plug-in to get status from smartmontools
RUN_DEPENDS= ${LOCALBASE}/sbin/smartctl:${PORTSDIR}/sysutils/smartmontools
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
do-install:
diff --git a/net-mgmt/nagstamon/Makefile b/net-mgmt/nagstamon/Makefile
index 82b986217bce..fdd48907556e 100644
--- a/net-mgmt/nagstamon/Makefile
+++ b/net-mgmt/nagstamon/Makefile
@@ -15,8 +15,8 @@ LICENSE= GPLv2
RUN_DEPENDS= sox:${PORTSDIR}/audio/sox
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
+USES= python:2
+USE_PYTHON= distutils
USE_GNOME= pygtk2 librsvg2
WRKSRC= ${WRKDIR}/Nagstamon
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index 9f8982de37ab..f311bb752741 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -23,7 +23,7 @@ MACRESOLV_DESC= Enable MAC Manufacturer Resolution (use p5-libwww)
.if ${PORT_OPTIONS:MPY4SUITE}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Ft/Xml/Domlette.py:${PORTSDIR}/textproc/py-4suite-xml
-USE_PYTHON= yes
+USES+= python
PLIST_SUB+= PY=""
.else
PLIST_SUB+= PY="@comment "
diff --git a/net-mgmt/py-flowtools/Makefile b/net-mgmt/py-flowtools/Makefile
index 33b663e85402..044146b13ae9 100644
--- a/net-mgmt/py-flowtools/Makefile
+++ b/net-mgmt/py-flowtools/Makefile
@@ -18,9 +18,8 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
PROJECTHOST= py${PORTNAME}
diff --git a/net-mgmt/py-ipcalc/Makefile b/net-mgmt/py-ipcalc/Makefile
index bb1a3ddef1f6..2bd5d1721f08 100644
--- a/net-mgmt/py-ipcalc/Makefile
+++ b/net-mgmt/py-ipcalc/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Module to perform IP subnet calculations
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
.include <bsd.port.mk>
diff --git a/net-mgmt/py-ipy/Makefile b/net-mgmt/py-ipy/Makefile
index 46446c06d20e..a549ceb8ccfe 100644
--- a/net-mgmt/py-ipy/Makefile
+++ b/net-mgmt/py-ipy/Makefile
@@ -12,9 +12,8 @@ DISTNAME= IPy-${PORTVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python module for handling IPv4 and IPv6 Addresses and Networks
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
test: install
${PYTHON_CMD} ${WRKSRC}/test/test_IPy.py
diff --git a/net-mgmt/py-pyang/Makefile b/net-mgmt/py-pyang/Makefile
index 69a77d2f9ccd..47ba48e3d2a7 100644
--- a/net-mgmt/py-pyang/Makefile
+++ b/net-mgmt/py-pyang/Makefile
@@ -12,8 +12,8 @@ COMMENT= Validator and code generator for YANG (RFC 4741)
LICENSE= BSD
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USES= python
+USE_PYTHON= distutils
DATADIR= ${PREFIX}/share/yang
diff --git a/net-mgmt/py-snmp4-apps/Makefile b/net-mgmt/py-snmp4-apps/Makefile
index 76fb01a00ed7..7e251db618b6 100644
--- a/net-mgmt/py-snmp4-apps/Makefile
+++ b/net-mgmt/py-snmp4-apps/Makefile
@@ -16,9 +16,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:${PORTSDIR}/net-mgmt/py-snmp4
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
diff --git a/net-mgmt/py-snmp4-mibs/Makefile b/net-mgmt/py-snmp4-mibs/Makefile
index 873d02585c0b..e03eb7764f4e 100644
--- a/net-mgmt/py-snmp4-mibs/Makefile
+++ b/net-mgmt/py-snmp4-mibs/Makefile
@@ -17,9 +17,8 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=4.2.3:${PORTSDIR}/net-mgmt/py-snmp4
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
diff --git a/net-mgmt/py-snmp4/Makefile b/net-mgmt/py-snmp4/Makefile
index f1741d3dd8ed..71fce5d7fe0d 100644
--- a/net-mgmt/py-snmp4/Makefile
+++ b/net-mgmt/py-snmp4/Makefile
@@ -17,9 +17,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.2:${PORTSDIR}/devel/py-asn1 \
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.4.1:${PORTSDIR}/security/py-pycrypto
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
diff --git a/net-mgmt/py-yapsnmp/Makefile b/net-mgmt/py-yapsnmp/Makefile
index 1032c918bc95..2f74da463fbb 100644
--- a/net-mgmt/py-yapsnmp/Makefile
+++ b/net-mgmt/py-yapsnmp/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake libtool
-USE_PYTHON= yes
+USES= gmake libtool python
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net-mgmt/virtinst/Makefile b/net-mgmt/virtinst/Makefile
index e65ec3573387..28ddba5d0561 100644
--- a/net-mgmt/virtinst/Makefile
+++ b/net-mgmt/virtinst/Makefile
@@ -14,9 +14,8 @@ COMMENT= Module to help in starting installations inside of virtual machines
LIB_DEPENDS= libvirt.so:${PORTSDIR}/devel/libvirt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.9.1:${PORTSDIR}/www/py-urlgrabber
-USES= gettext
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= gettext python
+USE_PYTHON= distutils
post-patch:
${REINPLACE_CMD} 's|share/man|man|g' \