aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-02 06:40:38 +0800
committerpav <pav@FreeBSD.org>2006-04-02 06:40:38 +0800
commite7234cba3884de69ccb64e85489124aca0b91063 (patch)
tree5d949c8aaed7ea3b23e3b2ee56bdbf60c21cea0f /net-mgmt
parentb062b994c0c2f077ab52d6989bff8e77eebdf942 (diff)
downloadfreebsd-ports-gnome-e7234cba3884de69ccb64e85489124aca0b91063.tar.gz
freebsd-ports-gnome-e7234cba3884de69ccb64e85489124aca0b91063.tar.zst
freebsd-ports-gnome-e7234cba3884de69ccb64e85489124aca0b91063.zip
- Unbreak: install into www/nagios instead share/nagios
- Don't depend on p5-CGI when not needed PR: ports/92944 Submitted by: Takayuki Nakao <t@nakao.org> Approved by: Janos Mohacsi <mohacsi@niif.hu> (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagiostat/Makefile20
-rw-r--r--net-mgmt/nagiostat/distinfo1
-rw-r--r--net-mgmt/nagiostat/pkg-plist4
3 files changed, 16 insertions, 9 deletions
diff --git a/net-mgmt/nagiostat/Makefile b/net-mgmt/nagiostat/Makefile
index ff3f44c46dc9..cb97f11adc61 100644
--- a/net-mgmt/nagiostat/Makefile
+++ b/net-mgmt/nagiostat/Makefile
@@ -16,10 +16,7 @@ MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Nagiostat parses performance-data from Nagios and generates graphs
RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool \
- nagios:${PORTSDIR}/net-mgmt/nagios \
- ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
-
-BROKEN= Does not install
+ nagios:${PORTSDIR}/net-mgmt/nagios
USE_PERL5= yes
NO_BUILD= yes
@@ -28,6 +25,9 @@ NO_WRKSUBDIR= yes
NAGIOSDIR?= /var/spool/nagios
DOC_FILES= README GPL.txt
+NAGIOSWWWDIR?= www/nagios
+PLIST_SUB+= NAGIOSWWWDIR=${NAGIOSWWWDIR}
+
post-patch:
@${REINPLACE_CMD} \
-e 's|%%NAGIOSTATCONFDIR%%|${PREFIX}/etc/|' \
@@ -39,9 +39,9 @@ do-install:
@${MKDIR} ${PREFIX}/libexec/${PORTNAME}
@${MKDIR} ${NAGIOSDIR}/${PORTNAME}rrd
@${INSTALL_SCRIPT} ${WRKSRC}/nagiostat ${PREFIX}/libexec/${PORTNAME}/
- @${LN} -fs ${PREFIX}/libexec/${PORTNAME}/nagiostat ${PREFIX}/share/nagios/cgi-bin/nagiostat.cgi
+ @${LN} -fs ${PREFIX}/libexec/${PORTNAME}/nagiostat ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/nagiostat.cgi
@${INSTALL_DATA} ${WRKSRC}/nagiostat.conf ${PREFIX}/etc/nagiostat.conf-sample
- @${INSTALL_DATA} ${WRKSRC}/graph.gif ${PREFIX}/share/nagios/images/logos
+ @${INSTALL_DATA} ${WRKSRC}/graph.gif ${PREFIX}/${NAGIOSWWWDIR}/images/logos
@${MKDIR} ${PREFIX}/libexec/${PORTNAME}/html-templates/
@${INSTALL_DATA} ${WRKSRC}/html-templates/default.html ${PREFIX}/libexec/${PORTNAME}/html-templates/
@${INSTALL_DATA} ${WRKSRC}/html-templates/graphindex.html ${PREFIX}/libexec/${PORTNAME}/html-templates/
@@ -54,4 +54,10 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/nagiostat/distinfo b/net-mgmt/nagiostat/distinfo
index 9e7439e52fd8..2f3ab9722f11 100644
--- a/net-mgmt/nagiostat/distinfo
+++ b/net-mgmt/nagiostat/distinfo
@@ -1,2 +1,3 @@
MD5 (nagiostat-1.0.0.tgz) = 10ecfebe9430b2daf6a0e87b71dc739c
+SHA256 (nagiostat-1.0.0.tgz) = 95470cbbb40ff7ab9456ea8c8448960aa8d8727f49681b06bf5ededabc43f8cf
SIZE (nagiostat-1.0.0.tgz) = 18883
diff --git a/net-mgmt/nagiostat/pkg-plist b/net-mgmt/nagiostat/pkg-plist
index 0cbe3ad484d9..d441a47a2530 100644
--- a/net-mgmt/nagiostat/pkg-plist
+++ b/net-mgmt/nagiostat/pkg-plist
@@ -3,11 +3,11 @@
@exec chown nagios:nagios /var/spool/nagios/nagiostatrrd
@unexec rmdir /var/spool/nagios/nagiostatrrd 2>/dev/null || true
etc/nagiostat.conf-sample
-share/nagios/cgi-bin/nagiostat.cgi
+%%NAGIOSWWWDIR%%/cgi-bin/nagiostat.cgi
libexec/nagiostat/nagiostat
libexec/nagiostat/html-templates/default.html
libexec/nagiostat/html-templates/graphindex.html
-share/nagios/images/logos/graph.gif
+%%NAGIOSWWWDIR%%/images/logos/graph.gif
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/GPL.txt
@dirrm libexec/nagiostat/html-templates