aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-07-09 05:49:14 +0800
committerwg <wg@FreeBSD.org>2013-07-09 05:49:14 +0800
commita11fd86d167b8c3ac7df3685e3e6bcce7d4a70a8 (patch)
tree2ac8e0c086f90fcacdb8f7c37d89ea03204d90fc /net-mgmt
parent09502239c31cecd88903ec41faf9a1b7cd3844f0 (diff)
downloadfreebsd-ports-gnome-a11fd86d167b8c3ac7df3685e3e6bcce7d4a70a8.tar.gz
freebsd-ports-gnome-a11fd86d167b8c3ac7df3685e3e6bcce7d4a70a8.tar.zst
freebsd-ports-gnome-a11fd86d167b8c3ac7df3685e3e6bcce7d4a70a8.zip
net-mgmt/collectd: sanity checking for options requiring CURL
For options that actually require CURL, check to see if it is enabled before we even try to build. PR: ports/180376 Submitted by: brd Approved by: maintainer
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 039567ec0e44..451211c4098a 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -155,6 +155,9 @@ CONFIGURE_ARGS+=--enable-bind
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
PLIST_SUB+= BIND=""
+. if empty(PORT_OPTIONS:MCURL)
+IGNORE= BIND requires CURL. Either select CURL or deselect BIND
+. endif
.else
CONFIGURE_ARGS+=--disable-bind
PLIST_SUB+= BIND="@comment "
@@ -164,6 +167,9 @@ PLIST_SUB+= BIND="@comment "
CONFIGURE_ARGS+=--enable-apache
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
PLIST_SUB+= APACHE=""
+. if empty(PORT_OPTIONS:MCURL)
+IGNORE= APACHE requires CURL. Either select CURL or deselect APACHE
+. endif
.else
CONFIGURE_ARGS+=--disable-apache
PLIST_SUB+= APACHE="@comment "
@@ -285,6 +291,9 @@ PLIST_SUB+= MYSQL="@comment "
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--enable-nginx
PLIST_SUB+= NGINX=""
+. if empty(PORT_OPTIONS:MCURL)
+IGNORE= NGINX requires CURL. Either select CURL or deselect NGINX
+. endif
.else
CONFIGURE_ARGS+=--disable-nginx
PLIST_SUB+= NGINX="@comment "