aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2002-04-10 18:30:26 +0800
committerkuriyama <kuriyama@FreeBSD.org>2002-04-10 18:30:26 +0800
commitb74b7c1e7802dc8c557b037ef73dfc82c446c6b0 (patch)
treef9610495e4a1e397969390b2da5b86f499e90c48 /net-mgmt
parentff6b9a9d9cb97ef605ae06c31174315cef460d11 (diff)
downloadfreebsd-ports-gnome-b74b7c1e7802dc8c557b037ef73dfc82c446c6b0.tar.gz
freebsd-ports-gnome-b74b7c1e7802dc8c557b037ef73dfc82c446c6b0.tar.zst
freebsd-ports-gnome-b74b7c1e7802dc8c557b037ef73dfc82c446c6b0.zip
I've mistaken the treatment of --with-mib-modules configure argument
with multiple modules. With this fix, both of host and ucd-snmp/diskio modules are activated. Spotted by: Alexandr Listopad <laa@laa.zp.ua>
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp-devel/Makefile8
-rw-r--r--net-mgmt/net-snmp/Makefile8
-rw-r--r--net-mgmt/net-snmp4/Makefile8
-rw-r--r--net-mgmt/net-snmp53/Makefile8
4 files changed, 12 insertions, 20 deletions
diff --git a/net-mgmt/net-snmp-devel/Makefile b/net-mgmt/net-snmp-devel/Makefile
index e4a0887682a4..691973efe5ac 100644
--- a/net-mgmt/net-snmp-devel/Makefile
+++ b/net-mgmt/net-snmp-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.4
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ucd-snmp.ucdavis.edu/ \
@@ -21,8 +22,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host" --with-gnu-ld \
- --with-libwrap
+CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host ucd-snmp/diskio" \
+ --with-gnu-ld --with-libwrap --with-libs="-ldevstat"
.if defined(BATCH)
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
.else
@@ -63,9 +64,6 @@ STARTUP_FILE= ${PREFIX}/etc/rc.d/snmpd.sh
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.if !defined(WITHOUT_SNMP_DISKIO)
-CONFIGURE_ARGS+=--with-mib-modules="ucd-snmp/diskio" --with-libs="-ldevstat"
-.endif
SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index e4a0887682a4..691973efe5ac 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.4
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ucd-snmp.ucdavis.edu/ \
@@ -21,8 +22,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host" --with-gnu-ld \
- --with-libwrap
+CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host ucd-snmp/diskio" \
+ --with-gnu-ld --with-libwrap --with-libs="-ldevstat"
.if defined(BATCH)
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
.else
@@ -63,9 +64,6 @@ STARTUP_FILE= ${PREFIX}/etc/rc.d/snmpd.sh
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.if !defined(WITHOUT_SNMP_DISKIO)
-CONFIGURE_ARGS+=--with-mib-modules="ucd-snmp/diskio" --with-libs="-ldevstat"
-.endif
SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index e4a0887682a4..691973efe5ac 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.4
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ucd-snmp.ucdavis.edu/ \
@@ -21,8 +22,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host" --with-gnu-ld \
- --with-libwrap
+CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host ucd-snmp/diskio" \
+ --with-gnu-ld --with-libwrap --with-libs="-ldevstat"
.if defined(BATCH)
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
.else
@@ -63,9 +64,6 @@ STARTUP_FILE= ${PREFIX}/etc/rc.d/snmpd.sh
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.if !defined(WITHOUT_SNMP_DISKIO)
-CONFIGURE_ARGS+=--with-mib-modules="ucd-snmp/diskio" --with-libs="-ldevstat"
-.endif
SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}
diff --git a/net-mgmt/net-snmp53/Makefile b/net-mgmt/net-snmp53/Makefile
index e4a0887682a4..691973efe5ac 100644
--- a/net-mgmt/net-snmp53/Makefile
+++ b/net-mgmt/net-snmp53/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.4
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ucd-snmp.ucdavis.edu/ \
@@ -21,8 +22,8 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host" --with-gnu-ld \
- --with-libwrap
+CONFIGURE_ARGS+= --enable-shared --with-mib-modules="host ucd-snmp/diskio" \
+ --with-gnu-ld --with-libwrap --with-libs="-ldevstat"
.if defined(BATCH)
CONFIGURE_ARGS+= --with-defaults --with-sys-contact=nobody@no.where
.else
@@ -63,9 +64,6 @@ STARTUP_FILE= ${PREFIX}/etc/rc.d/snmpd.sh
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.if !defined(WITHOUT_SNMP_DISKIO)
-CONFIGURE_ARGS+=--with-mib-modules="ucd-snmp/diskio" --with-libs="-ldevstat"
-.endif
SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}